Echo and virtual switch

I had/have and interesting issue. I created a virtual switch (called Movie Mode) that changes a mode to movie mode. My movie mode ignores my motion detectors preventing my living room lights from turning on. When I initially integrated the Echo, it was working flawlessly. I could say “turn on movie mode” and it would switch modes. But it has stopped working. Echo says ok but my smarthings app doesn’t see the activity. However if i say “alexa turn off living room lights” it works.

Any thoughts on why it would work and then stop?

There were some really weird cloud problems yesterday that affected a lot of echo activity. It got cleaned up again later in the day.

I would start by just opening both the echo app and the smart things mobile app and make sure that the devices are all set up the way you expected to be. Mine changed all on their own twice yesterday.

You may need to rediscover the switch in echo.

Once you are sure everything is set up the way it should be, tried again and see if it works. Yesterday was just really goofy all day.


Thanks @JDRoberts! I’ll give 'er a shot when I get home.

1 Like

Yeah, during that cloud-out (before I knew that’s what it was), I was screwing around with one of my sensors and ended up removing it. When I added it back, there was a ghost image of it left on the Echo. When I tried to operate the switch with Echo, she told me there were two of those switches and I needed to rename one. I just had to ‘forget’ the ghost switch, then it all worked. Growing pains…

1 Like

It was a pretty big cloud mess it looks like. Looked at my virtual switch and it was associated with other switches instead of the smartapp it was supposed to be. After re-configuring, all was good. Weird.

1 Like

Has anyone else seen in the Echo app under skills it has a new skill to directly control Scout Alarms. You can arm/disarm, check status of sensors and latest activity.