Virtual Switch .... Mode change; Frustrating


(Greg Rawls) #1

So I created the virtual switch, and I now have Alexa with the ability to turn the switch on and off… But I can not figure how to connect/ associate the switch with changing the mode. I have played with this for hours. Not sure if there is an smart app I am missing…


(Bobby) #2

There is an app that you can install from the marketplace, is called ‘switch changes mode’, listed under Light & Switches category. However, I had mixed results with it lately, so I created a simple piston in CoRE and it seems to be more consistent.

Alternatively, you can install Ask Alexa, and you don’t even need a virtual swith in the middle.


(Jason "The Enabler" as deemed so by @Smart) #3

To piggy back on what @SBDOBRESCU said, there is an app call Alexa helper that was designed specifically for this. It much simpler to use than askAlexa. So, whatever your comfort level is.

[RELEASE] Alexa Helper


#4

This should help.

If you decide you don’t want to use the “ask Alexa” smart app (it’s gotten much more complicated since it was first created as it now does many more things) you can still follow the FAQ but instead of using the ask Alexa Smart app there is a very simple smart app in the “marketplace” section of the official mobile app which only does one thing: assign a mode to a switch.

To find that one open the mobile app, select the marketplace section (use the*icon at the bottom of the screen), choose “smart apps”, choose “lights and switches”

To find that one open the mobile app, select the marketplace section (use the*icon at the bottom of the screen), choose “smart apps”, choose “lights and switches” and you will find it. :sunglasses:

You’ll still need to follow the FAQ, though, because it’s not enough to just assign the mode to the switch, there still a couple more steps to get echo to use it


(Greg Rawls) #5

well I found and published “for me” Alexia Helper app. It appears as installed app on the https://graph.api.smartthings.com/ with the other app big turn on.

but I can not find it on my mob app… went to marketplace looked at my apps… the big turn on is listed by the Alexia helper does not. I have turned my phone on and off; I have logged out of app and logged back in with no success. I am sure there are many steps I missed which is causing this issue, but can you think of something I should check?


(Jason "The Enabler" as deemed so by @Smart) #6

When you’re in the web site to install the smart app ensure you tap on save AND THEN tap on publish, a drop down appears and tap on FOR ME.

the so should then assist in your marketplace.

In marketplace scroll to the bottom. You will see a tab, my smartapps, it will be in there.

You only need to go here the very first time you install it. After that, you will find it by tapping the the horizontal lines (hamburger) in the to right corner. Go to smartapp and there it will be.

Go here for more detailed instructions…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #7

You may have to paste & publish to a different Shard applicable to your Location…

…Terry.


(Greg Rawls) #8

got it to work… not sure what I did to fix it. But it might had something to do with clicking “forking” button and get hub.

thanks for the help!