Drayton wiser home thermostat


(mark) #1

Hi all
Just bought the Drayton wiser home thermostat system and have just finished setting them up (very easy to set up)
First impressions are pretty good but it is very early days.
I believe it is a new system so at the moment no integration with ST or IFTTT
As anyone else used this system yet and any ideas if it could be integrated with ST.


(David Tucker) #2

I spoke to their sales / development guys at a recent trade show and they said they would be focusing on Amazon Alexa, and had no plans to release a developers API…so not much chance of writing our own integration either. Shame, as they are quite keenly priced if you have lots of radiators to control.


(Colin ) #3

Drayton have confirmed that they are working on IFTTT support http://www.automatedhome.co.uk/hvac/drayton-wiser-smart-heating-controls-review-part-2-installation-update.html


(Colin ) #4

IFTTT integration is now enabled but is so far very limited, it appears to be restricted to turning away mode on or off for now, hopefully they will open this up further.

Just noticed the Wiser site says they are adding more over the coming months

https://wiser.draytoncontrols.co.uk/support/faq/when-will-more-ifttt-actions-be-added

This is the site that is used for account linking in IFTTT, maybe someone can figure out a way to connect directly to Smartthings.

https://api-nl.wiserair.com


(mark) #5

Just set this up with IFTTT and it seems to work well.
Have it set to away mode when we both leave the house and return to heating when one of us arrives home.

Was looking around on the web and found that some guys on the openhab forum are making good progress on integration.

Wish I had the skills to do something like that!!!


(Colin ) #6

I’ve taken the code from the openHAB guys (https://github.com/RobPope/DraytonWiser) and used it to create a quick and dirty Android app and can communicate with my HeatHub through it. I’m not overly familiar with Groovy and haven’t created a device handler before but I will give it a go!


(mark) #7

That’s a good start Colin if you need anyone to help test this I be happy to help.


#8

Great to hear some progress is being made on this and that @colc is having a crack at it, do let us know how you get on with it :+1:


(Colin ) #9

I’ve made some progress with this and it’s looking promising but not ready for testing yet and I’m away for a week so won’t be able to do anything else for a bit


(Chris Evans) #10

I too have started on a Drayton Wiser device type and smart app. Before using this I should say it’s VERY beta, dirty, quite hacky and should not be used by anybody, ever.

Add the repo at https://github.com/chrisduffer/drayton-wiser using the master branch. Don’t use dev, you WILL have problems. Install the drayton-wiser-connect smart app, drayton-wiser-room device type and drayton-wiser-away device type.

Follow the instructions in https://github.com/chrisduffer/drayton-wiser/blob/master/README.md to get your secret. Open the smart app, paste this in and choose how many rooms you have. A room device for each room will be created along with an away mode switch.

Things this currently does:
Reads temperature for rooms
Read away mode
Override room temperatures
Cancel room overrides

Things this currently does badly:
Set away mode. This might be a bug with the way Wiser works, but having a room override while setting away mode will not work as expected.

Things this DOESN’T do:
Anything hot water related

Once again this is very beta and will probably cause you problems.

Smart app:

Room device:

Away mode device:


#11

Looks like great progress, nice work!!

Can you choose the device that determines the user’s presence (e.g. Life360 that is already set up as a input/sensor?)


(Chris Evans) #12

It doesn’t do anything presence related. I created the away mode switch so it so that with automations though. E.g. when I leave turn on away mode.

I’ve made a device type thread at [BETA] Drayton Wiser Room Thermostats and fixed a few bugs. If you have issues please put them in that thread and I’ll have a look.


(Colin ) #13

So a week turned into two and slowed progress and I see that Chris has made some good progress in the meantime but I’ll present my efforts anyway.

I haven’t got round to setting up a github yet so it’s all a bit manual I’m afraid…
Now on github, see link at bottom

You will need your system secret and hub IP address and I recommend configuring your router to give the hub a fixed IP to make things easier. You can get the system secret by doing the following:-

  1. Press the setup button on your HeatHub, the light will start flashing
  2. Look for the SSID 'WiserHeatXXX' where XXX is random
  3. Connect to the SSID from a PC
  4. Once connected run the following command in PowerShell
  5. Invoke-RestMethod -Method Get -UseBasicParsing -Uri http://192.168.8.1/secret/

  6. This will return a string which is your system secret
  7. Press the setup button on the HeatHub again and it will go back to normal operations

You then need to create and publish the smartapp and device handlers in the IDE from the links below.

Add the Drayton Wiser (Connect) smartapp in the SmartThings app and enter your IP address and system secret (you can also add these in the IDE so you can enter temporary details in the app then just copy and paste the secret)
When you save the settings, devices will be created for the hub, all your rooms, and hot water if you have it.

In the hub device you can control away mode and eco mode

In the hot water device you can turn the water on or off, change between auto and manual modes, and turn on boost (set to 30 minutes for now)

In the room devices you can see the temperature and humidity (room stat only), change the set point, change between auto and manual modes. Boost is not implemented for rooms yet.


All this is working well on my system but obviously all systems are different so your mileage may very (it’s possible it may only work on my system but hopefully not!)

Smartapp - https://drive.google.com/open?id=1TH5aZc-WqzzbGJCMm9OFTdSfWecUli6P

Hub device handler - https://drive.google.com/open?id=1600DsiSgLzDfAR4KI7P2Hfjy1JqcmsBe

Room device handler - https://drive.google.com/open?id=1OuskhBbVJcVqj5Jgkm5Aj0tV9eXeOgRW

TRV device handler - https://drive.google.com/open?id=13rSzEhHbQxZQPbbKJBF7bIwWGIwjm_-U

Hot water device handler - https://drive.google.com/open?id=1xYZY5gCdwY4eWujc2WOXQgdSIhwNNHaI

Hopefully this is of some use!

EDIT

Now on github

add colc1705, DraytonWiser, master to your IDE


(mark) #14

Hi Colin,
Great start on this I have followed your instructions and all is looking good apart from I can’t see my wiser hub. All rooms have populated in ST and I can see temps from trv’s in each room but I can’t see the hub at all.

I have the wiser hub with out the hot water control so I am assuming it is because my hub is not the same as yours were as the trv’s and roomstats are.
I think it is probably something in the heat hub DH that needs changing but not sure what.
Any ideas?

Thanks Mark.


(Colin ) #15

Hi Mark,

It could be a difference in our hubs. First thing I would check is that you have the ‘Drayton Wiser Hub’ device handler installed and published properly. Assuming it is have a look at the live logging in the IDE and see what messages are appearing for the ‘Drayton Wiser (Connect)’ smartapp. There are a lot of debug messages in the code at the moment so you should get quite a lot of logging for the app, let me know if there are any errors appearing in your log.

Cheers,
Colin


(Colin ) #16

Sorry Mark, I’ve just noticed the link to the Hub device handler is wrong, here is the correct link.

https://drive.google.com/open?id=1600DsiSgLzDfAR4KI7P2Hfjy1JqcmsBe

EDIT

Now on github

add colc1705, DraytonWiser, master to your IDE


(Colin ) #17

Room boost is now working, default of 30 minutes for now. Each room also now shows whether it is calling for heat or not


(mark) #18

All working good now Colin. I can see my hub and all rooms are displaying correct temps. Small issue I have noticed on each device I can see that the call for heat is on constant in the ST screens, when I check the wiser app I can see that some are off.


(Colin ) #19

Glad to hear you got it working Mark.

I actually noticed the opposite on my system, my room thermostat had the flame symbol but the hub was reporting that the room didn’t need heat.

The hub has a ControlOutputState flag for each room which is either on or off and this is what I am using to show call for heat in ST. I think the Wiser app does some fancy calculations based on the type of boiler you have and the percentage demand to decide whether to display the flame symbol or not. I’ve noticed in the past on mine that the flame symbol is showing but the boiler is off and vice versa.

I think I will replace the simple on/off state for heat to show the actual percentage demand, this might make more sense when compared with the Wiser app.

Do you have any rooms with more than one Wiser device (e.g. 2 TRVS in the same room)? I only have the room thermostat in my living room and 1 TRV in a bedroom so my testing is limited to that.

Cheers,
Colin


(mark) #20

Yes Colin, my setup is as follows:
Living room has room stat and two trv’s all grouped as one room.
Then trv’s in the hall, two bedrooms and kitchen.
So five rooms in total.
The living room works very well with the room stat as the master control and the two trv’s must be some kind of slaves to the room stat. When I look at the wiser app the room temp is reported by the room stat only but when I alter the temp on it it turns both trv’s up or down.
The other four rooms take the temp from the trv.
Like I say all seems to be working in ST apart from all rooms constantly reporting call for heat yet when I check the wiser app all rooms could be off with no flame by them.
I agree that maybe it would be better to have percentage demand reported for each room rather then just on/off.