Dishwasher/Appliance stuck on registering(and some fixes)

I’ve been in the trenches trying to get my dishwasher registered into Smartthings. 10 hours later and it is finally done and I wanted to post up all the information I’ve gathered that might help if you run into this issue with a Samsung appliance and then ultimately what fixed it.

First the behavior. Following the steps to register my dishwasher the app would reach the final screen of ‘registering to your Samsung account’ and then never proceed past that.

Here are some things that other people say helped them:

  • use your 2.4ghz network
  • use no special characters in your SSID or password
  • use only an 8 character password
  • if on iphone register with the QR code(note I did this all on Android myself)
  • reset the WiFi settings(after turning on Smart Control into AP mode hold the Hi Temp button for 7 seconds until it beeps then changes back to AP and then power cycle)
  • unplug it for a few minutes

Any of these things might help you but here are the details around my situation. The first odd question I got was from Samsung support about the % my registration reached. The current version of the app on Android does not have a registration % anymore. It also never fails and provides an error code.

Eventually I found an older version 1.7.63.23 and side loaded it. This version DOES have a registration %. My registration reached 99% then provided error code 1500-300. Amazingly the dishwasher also showed as connected to WiFi for the first time though as an unknown device in Smartthings. Due to this I believe registration on the current android version 1.7.77.22 may be fundamentally broken as at this point I had done nothing different, only tried installing with a different app having just attempted again on the latest version.

With error code 1500-300 I was able to locate a Reddit post that indicated a resolution with a DNS change. I got into my router and changed my DNS that was set to Cox Communications DNS to Google’s 8.8.8.8/8.8.4.4.

I attempted registration again and it immediately registered as expected with no problems. I believe this may resolve issues with registration across a wide berth of Samsung devices being added to Smartthings as I’ve seen people having this same issue with washers/dryers/vacuums/TV’s. I do not know if the current version of Smartthings would have worked if I had adjusted the DNS setting but I’m inclined to say very possibly not as it never connected my dishwasher to WiFi like the old version did despite the registration error code that came up.

What makes this particularly challenging is the lack of error codes in the latest version of the Android app. Had I gotten the error code originally this would have only taken a few minutes to resolve vs the 10 or so hours I dumped into this.

Had this same issue needing to reconnect existing appliances due to a change in WiFi networks. Even tried plugging in the old router and couldn’t connect back to that either.

Side loaded an old version of the app as suggested and was able to re register appliances absolutely fine.

1 Like

That really makes me think this latest version is buggered up somewhere and Samsung and Smartthings aren’t aware given it just released on Android on the 13th of January.