Cannot register dishwasher with SmartThings (Error 01-001)

Hello, I’m having trouble connecting my dishwasher to the SmartThings app. I follow all of the steps, selecting the network I’d like the dishwasher to use, the dishwasher beeps with the [ ] symbol on its display, then the app gets stuck on the Registering Your Device screen before failing after about 2 minutes with error code 01-001.

Has anyone else had this trouble?

1 Like

Tagging @SamsungZell

1 Like

Hey there! @Nick_Rodgers, Welcome to the Community! :slight_smile: Thank you for providing the Error code that you are receiving when attempting to onboard the Dishwasher to the ST App. I would be happy to troubleshoot your issue.

Can you please provide me with the model code of your dishwasher, the device that you are using the ST App with (Android or IOS), and any troubleshooting steps you’ve already attempted?

Here is some information on locating the model code on your Dishwasher:

I hope this message finds you well!


1 Like

Hi there! The model number is:
DW60A8060BB and I’m using an iPhone 11 Pro running iOS 15.0.2

So far I have tried:

  • Changing my router for another one

  • Disabling the 5Ghz network

  • Turning off my router’s firewall

  • Placing the Dishwasher into the DMZ on my router

  • Turning off “Private Address” and “iCloud Private Relay” (VPN) on my iPhone

  • Logging out and back into my Samsung account on the ST app on my iPhone

The Dishwasher shows up as being connected on my router’s device list, but it will not register with my Samsung account.

I have a simple SSID and WPA2 key that uses just upper and lower case letters, with a couple of numbers in. No special characters, spaces or non-ASCII character.

I tried to connect using my wife’s iPhone (same configuration) and she got a different error code, 38-004, but it still didn’t register.

Oh, and:

  • Restarting my iPhone
  • Disconnecting the dishwasher for 10 minutes and plugging it back in
  • Turning Wifi off and on on the dishwasher

Hey there! @Nick_Rodgers, thank you for providing that detailed information on the troubleshooting steps that you have already attempted.

Two suggestions that I noticed that was not mentioned; would be to attempt to clear the storage cache of your ST Application on your Iphones, and to uninstall and reinstall the ST Application to ensure your running the latest versions, and see if you are able to onboard the device or received the error code again.

After reviewing the User manual in regards to the onboarding process, Did you attempt to add the device by QR Code or Serial Number located underneath the QR code?

I was also able to review your model ‘DW60A8060BB’ and it is an international UK model, There are differences between the US and International firmware, which I do not have access to. As your product is a non-US model and support for these models is very limited, please seek a support team for your area if the symptom persists.

You can reach out directly to a support team in your area using the below information:

UK: 0333 0000333

I hope this message finds you well!


Hi @Nick_Rodgers did you get your problem fixed? I’m having a similar issue with my dishwasher; getting code 38-004. I have the silver version of what you have - DW60A8060FS. I’d be grateful for help in connecting mine. Thanks.

I wish I had a better answer for you, but it just started working for seemingly no reason. I reinstalled the app, it continued to fail and then it worked the next day.
The only thing I can think of is if I’ve of the customer service staff I spoke to found I was halfway registered and reset it on their end?

I think you’re right. I think staff need to do something their end with my issue. I’m currently ping-ponging emails with all the usual basic troubleshooting stuff.

My phone does connect to my dishwasher, I sign into my account, then it comes up with that error afterwards.

Thanks for getting back to me. Hopefully they’ll sort it soon.

This app is absolute trash, whoever developed it needs to go back to working at a supermarket checkout.

Why bother making something that does not work!!?

“Clear the cache” - a solution given by people that have no clue what they are on about, and a solution that has NEVER solved any problem since 1998.

1 Like

I too had the same problem with my samsung tv

I’m having the exact same problem with newly installed Samsung dishwasher. Would LOVE to know what the solution is… ASAP. @SamsungZell ?

Same issue with a Samsung range delivered yesterday. The app can find the range and even prompts me to add the device, but fails with a ‘network or server error 01-001’, telling me to try again later. My network is fine, but this range might be going back to Samsung if it doesn’t work. @SamsungZell, any ideas?

I am having the same issue with my new Samsung TV Q60B. I have tried all the options mentioned above but no go.

things to try:

  • SSID and password with no special characters or spaces in either
  • WPA2 only (meaning WPA2/WPA3 probably will not work)
  • 2.4Ghz only
  • Phone needs to be on the same SSID

you can try creating a temp SSID to see if you can get it connected.

for TVs, you can try using Ethernet on the TV to see if you can get it connected. If successful, try to switch it to WIFI after that.

If nothing works… contact Samsung or SmartThings Support.

Did anyone get a definitive way to fix this… I am getting the error Error code: 01-001 when I try and register both my washing machine and dryer … and it’s starting to get annoying because then when I try and redo it says it’s registered elsewhere but not showing in my smart things app