Disable temperature on SmartSense Multi Sensor

I’ve recently setup my SmartThings hub because I wanted to monitor some door/window sensors and smoke/CO alarms remotely. So far things are working reasonably well but I have one question about the SmartSense multi sensor.

I’m using the multi sensor on a window to detect both open/close as well as vibrations. I have no real use for its temperature sensor (for now at least). Since the sensor seems to be reporting temperature much more frequently than anything else, I’m sure that will affect its battery life unnecessarily.

Does anyone know how I can disable the temperature function, or at least stop the sensor from reporting temperature?

I found a post on this topic that’s about 18 months old, but I’m unable to alter the device type in the way that @jadorelavie describes. I just don’t see a “smartsense multi (configurable)” in the list of device types when I login to the SmartThings web interface.

Does that device type no longer exist? Are there any other methods of doing this? Thanks!

1 Like

Anyone?

Little help, please? Should I be posting this question in another category?

The battery lasts a year+. I wouldn’t sweat it.

Z-Wave sensors oftentimes have openly documented configuration parameters that can be set, but SmartThings doesn’t provide the nitty gritty on the firmware in their sensors — even if you were to edit a devise type to stop showing the temperature, the sensor would still be sending the update over the network anyhow.

I didn’t need to swap the batteries for over 2 years on mine. I do see the appeal in making a device type sans temperature monitoring though. It floods the event log, and is horribly inaccurate anyway.

OK thanks for the reassurance on battery life. Even without improving battery use, it would still be kinda nice to be able to easily hide the temperature sensor readings. As @corys mentioned, the activity log is full of temperature readings, and mine’s definitely not accurate (could be that I put it on a window and it’s being affected by the temperature of the glass or something).

If I really care enough about it, maybe I’ll try to create a custom device type based on the stock multisensor device code. But I really don’t know anything about groovy, or coding in general, so I haven’t decided if it’s worth the effort yet.

Thanks again for the responses.

Bump. SmartThings, Please enable the functionality to disable the temperature functionality in a Multi Sensor. I have one monitoring my garage door and I do not care what the temperature is in my garage. The temperature is always changing and the alerts are over bearing. Thanks
Travis

1 Like

I have mine outside and it dies within a month or two. It has been cold, but I bet the constant temperature reporting isn’t really helping either.

1 Like

Bump. I would also like to disable temperature reporting for a few SmartSense items: Open/Closed Sensor, Motion Sensor and Multi Sensor. Im sure battery longevity will increase if they dont report temperature. I think the key number for temperature is “0402”.

Here is my edited code for the Open/Close Sensor. Im using this on an Iris Contact Sensor. Open/Close events still show up on the app instantly and Recently. If you had a temp offset, delete it from preferences and it should clear out the field.

The Motion Sensor. Im using this on official ST sensors.

The Multi Sensor was a bit tricky. I left some comments where I was confused. I noticed that the other sensor temps refreshed every hour, so it was easy to find the lines that has 3600. The multi sensor seems to update every time the temp changes by 1, so I am not as confident on this mod than the others. Im using this on official ST sensors.

Any update on this issue?

I came here looking for the same solution. Scrolling my activity feed for open/close details is a nightmare where it is positively overrun with 1 degree temperature changes. I would still like it to note temp and can trigger actions based on it, but I don’t want it in my activity feed!

Found this thread: Way to disable Multi temperatrure sensor/notifications

I followed the suggestion about editing the sensor via the web site.

Unfortunately, the device type "SmartSense Multi (configurable) " listed in this thread [Way to disable Multi temperatrure sensor/notifications]Way to disable Multi temperatrure sensor/notifications) does not show up on the web API anymore:

Any suggestions?

I hate to revive this thread but…I have multiple new version Smartthings multi-purpose sensors in my home. Exterior doors and windows, interior and closet doors, fridge and freezer doors, etc. The problem I am having is that the exterior door and window sensors are killing batteries. Here in South Carolina we can have some pretty big temperature swings in the winter, and the sensors report every degree. Anyone have any ideas?

My multi sense unit kept sending in temp updates I watched the battery continually get lower and lower until it reached about 66% in about 3 months and then the unit disconnected from the network, I will not put up with that so I am going to swap it out for a Nortek gocontrol without temperature sensing.

Bump. Has anyone found a way to disable temperature reporting in the activity feed? I too have a fast battery drain and it might have to do with lots of unwanted temperature reports.

Bump. Definitely need some preferences to disable some parts of this sensor. Temp especially in my case.

Maybe even if someone has the code for the “Smartsense Multi Sensor (configurable)” Device Type that was previously available. That might suffice.

1 Like

I’ve also been scouring the internet trying to find a way to disable the continuous temperature updates which help drain the small button cell battery.

I have tried the various Smartsense Multisensor device handlers from the online web interface, but they all seem to report temperature.

Have never figured how to disable but you can slow it from the default 30sec and 5min reporting frequency to something less frequent like 60min, 2hrs. Replace the zigbee.temperatureConfig(30,300) you will find in your device handler to something like zigbee.temperatureConfig(3600, 7200)

Technicall you should also be able to also change the min temp change value of 0.1 (0x01) on cluster ID “0x0010” below to something like 5deg or 0x32 but I have not been able to confirm that this actually will work,

if (device.getDataValue(“manufacturer”) == “Samjin”) {
log.debug “Samjin multi-sensor configuration”
configCmds += zigbee.configureReporting(zigbee.POWER_CONFIGURATION_CLUSTER, 0x0021, DataType.UINT8, 30, 21600, 0x10) +
zigbee.temperatureConfig(3600, 7200) +
zigbee.configureReporting(0xFC02, 0x0010, DataType.BITMAP8, 0, 3600, 0x01, [mfgCode: manufacturerCode]) +
zigbee.configureReporting(0xFC02, 0x0012, DataType.INT16, 0, 3600, 0x0001, [mfgCode: manufacturerCode]) +
zigbee.configureReporting(0xFC02, 0x0013, DataType.INT16, 0, 3600, 0x0001, [mfgCode: manufacturerCode]) +
zigbee.configureReporting(0xFC02, 0x0014, DataType.INT16, 0, 3600, 0x0001, [mfgCode: manufacturerCode])
} else {
log.debug “Non Samjin multi-sensor configuration”
configCmds += zigbee.batteryConfig() +
zigbee.temperatureConfig(3600, 7200) +
zigbee.configureReporting(0xFC02, 0x0010, DataType.BITMAP8, 10, 3600, 0x01, [mfgCode: manufacturerCode]) +
zigbee.configureReporting(0xFC02, 0x0012, DataType.INT16, 1, 3600, 0x0001, [mfgCode: manufacturerCode]) +
zigbee.configureReporting(0xFC02, 0x0013, DataType.INT16, 1, 3600, 0x0001, [mfgCode: manufacturerCode]) +
zigbee.configureReporting(0xFC02, 0x0014, DataType.INT16, 1, 3600, 0x0001, [mfgCode: manufacturerCode])
}