Difficulties with Ikea Trådfri Controller devices

Hey folks!

I’m having trouble pairing my Ikea trådfri controller devices with my Aeotec hub. I managed to get one motion sensor and a couple of on/off buttons to work, but:

This second motion sensor does not pair. I have tried dozens of times. I hold the button for ten seconds, but it never seems to get discovered. I have managed to pair this sensor directly with an Ikea bulb with no problem.

I also have a trådfri button that will successfully pair, but after pairing Smartthings says that it cannot connect to device (it shows up as grey scale in the room and can’t be configured).

It’s weird that i managed to get it to work with one motion sensor and not another, given that the sensor itself seems to be fine; it connects to bulbs directly after all.

I would try hard resetting the hub but… I’ve set up loads of devices, it took hours - will all of this work have to be repeated if I reset the hub?

Appreciate any tips…


Hub: Aeotec branded EU region
Ikea motion sensor: the new one
Ikea single button: I guess there’s only one model?

That will be the problem. You just need to reset the device by pressing the link button four times in quick succession.

The ten second press may have been correct for an earlier model (I don’t know) but now it is used for pairing to other devices. It’s not as if SmartThings haven’t been told the onboarding instructions are wrong …

This is generally the case with IKEA devices and SmartThings. You need to do whatever is required to reset the device. With buttons and motion sensors that means pressing the button four times. With outlets it is pushing the reset button for about five seconds.

Thanks for the answer - I don’t think that’s right though, the instructions from Ikea that came with the motion sensor say to hold the button for ten seconds, the instructions in the Smartthings app say to hold for ten seconds, and by holding for 10 seconds i am able to pair the motion sensor with Ikea light bulbs, and i was able to pair my other Ikea motion sensor by holding the button for 10 seconds.

I have of course also tried pressing the link button 4 times, with no success.

as far as I remember for my remote

  • 4 press is for the reset, required to join to the hub network
  • long press is for a direct link to bulbs.

The same thing happened to me, what I did and it solved the problem was to press the link button 4 times quickly and then leave it pressed for 10 seconds and the little red light blinking slowly, then I added it to my Aeotec hub and it works!

Oh man, thanks so much!

I didn’t realize there was a light on the motion sensor as it it not visible from the back!

The light helped me understand that i was pressing 4 times too slowly - I needed to press faster.

Thanks for the help! Ideally the app would have the right instructions…

Do any of you have any tips for the button? This one pairs fine, but after it has paired I can’t configure it: when I select it it says ‘no connection to button’…

Really appreciate the help!

1 Like

Check the battery, I didn’t have any problems with pairing or configuration, I selected ikea boton in the smartthings app without the tradfri hub directly to the aeotec hub and it was done. With tradfri devices if I don’t get it right the first time, what I do is delete the device leave 1 or 2 min for it to refresh properly both in the app and in the hub and pair it again. Sorry I can’t help you more in this case

Thanks for the help. I switched the battery with one that is known to work and it didn’t help. I’m guessing there’s a hardware problem with the button. I will try to return it…

Really appreciate all the replies!


1 Like