Devices won't open, "loading"

In the last few days, when i click on a device on the app, it says “loading” and nothing opens.

Anyone familiar with this issue?

What I see are 14 devices that are offline (top row - broken icon) so you may wish to start there in your investigation. ST has been migrating devices from groovy DTH to Edge drivers for some users. Go to Addanced Web App and look at those devices. In most cases it will simply be that you need different drivers or for some, remove and pair again. Once you start identifying these offline devices and provide us with more info, the community can provide you with more answers on how to resolve :slight_smile:

Those are things not I’m use at the moment. Such as Xmas plugs that I pack away. Some are devices gone for a while yet it won’t even let me force remove them. I have fixed many devices to new drivers recently.

So those offline devices are not new and none of the devices offline are devices I’m trying to open.

you can use the link above to force delete them.

if android, have you tried clearing your app cache?

can you open any devices or is it specific devices? the ones you can’t access… if you can provide us with more details… brand/model, driver being used.

I just tried clearing the app cache

It’s oddly, all devices. I can ‘control’ devices if they have a ‘button’ on the screen, for example lights/outlets I can click the ‘button’ and devices such as those work (on/off). But even when I can turn something on/off on the device screen, even those won’t open. It will say “loading…” for a few seconds then nothing happens.

My ecobee thermostats (AC and heat), won’t open and that has no driver. The ecobee account just links to SmartThings. So essentially, not being able to open the thermostat, I cannot control the temperature. The thermostat settings are all controlled (time/temp) via ecobee so it’s really just a link. This all worked a few days ago along with all other apps.

Essentially, even apps (lighting, outlets, door locks) they all ‘function’ but I cannot open a single app. I’ve gone in and looked at the drivers on the link you sent and drivers all appear good.

As an update. Today, having done nothing, now everything is fine. Every app opens.

I did clean the cache yesterday and at the time that didn’t appear to solve the problem.

I had also disconnected and reconnected my ecobee account which didn’t solve the thermostat apps.

This morning…everything works