Devices not available in automation and Scenes (13 Oct 2021)

Hi, I’m looking for help please. I was cleaning up my account earlier and deleted a couple of old smartapps I no longer use, however I did by mistake remove my virtual device creator app which in turn deleted all my virtual switches… very annoying . Now I have re-created those but I’ve hit a very weird problem , which is … all the devices are no longer available in any of the automations or scenes. I tried to create new automations or scenes and stile the same the control devices is greyed out. Any ideas as I cant seem to find a way to fix this one
Help

Thanks

Andy

wow, i’m seeing the same thing. @garrett.kranz is this a known issue?

1 Like

Nothing that I’m aware of yet, but possibly. Having a look now. Thanks for the ping.

2 Likes

I’m having the same issue. Replaced a harmony remote, which created a bunch of new virtual switches. Those switches appear as devices in the room panels but not visible in the automations menu.

I signed out and signed back in to try to refresh. Now “device status” is greyed out an an option when I try to create a new automation.

I cannot add any automations through the Smartthings App for Android. No devices show up (greyed out) when I click the ‘Then’ option of an automation setup. I’ve tried uninstall / reinstall of app, restarting my phone and hub (v2). Tried toggling between wifi and LTE on phone as well. Anyone else seeing issues?

1 Like

Hey there!

If anyone is experiencing this issue, the best practice would be to submit a Support ticket with your attached logs to be reviewed and tracked.

@Stan_Andrews, I’ve been following up on reports with this symptom present in the IOS system, and haven’t seen android experiencing the symptoms until now. Thank you for providing me with the troubleshooting steps that you have already attempted.

I’d like to collect some additional information about your devices and firmwares.

  1. What Android device are you using with the ST APP?
  2. ST APP Version? Located in the ‘About SmartThings’ Section of your SmartThings Settings Menu.
  3. Hub Firmware that is being run on your V2 Hub? Located in the Device Tile for your V2 Hub, (…) Three Dot Menu> Information> Firmware Verison will display here.
  4. Did a clearing of the Cache of the ST Application? Settings>Apps>SmartThings>Storage>Clear Cache and Restart your device? (If you haven’t already tried)

Additionally, I wanted to provide you with the contact information so you can submit a support ticket to a team in your area.

You can reach out directly to a support team in your area using the below information:

US: 1-866-813-2404
US: support@smartthings.com
UK support 0333 0000333
UK: support@smartthings.co.uk
CA: support@smartthings.ca

I hope this message finds you well!

^SamsungZell

1 Like

@SamsungZell @garrett.kranz Same issue here. iPhone 12, iOS 15.0.2. I submitted logs and a ticket (1266422) earlier this morning - ST tech said I needed to delete all of my devices, which I did not…

Yeh I’m on iPhone 13 iOS 15.0.1. With a V2 hub on 39.00006

Hope that helps

One other point … if this is effecting more than one user … which appears to be the case , why does the smartthings status say no reported issues … I reported this several hours ago via email …. Just asking

2 Likes
  1. LG-AS998 is the smartphone I have the app installed on
  2. Version 1.7.72.21
  3. Hub firmware 000.039.00006
  4. Just tried that, no change

Thanks for the support information!

You should be fixed now. There was an issue with what I assume was a recently deleted Roku device. Cleaned up some records and all should be good.

1 Like

For everyone else, there was a change rolled back and the issue should be resolved for you all.

4 Likes

Just tried it and Nope stil not working. Do we need to logout and back in, restart hub ? or anything else

Works for me, I had to log out and log back in.

@Brad_ST Thank you!!!

1 Like

They hardly ever put issues with the app or device type handlers on the status page. Just cloud platform stuff and occasionally some hub issues. It’s just always been that way. I don’t know who is responsible for deciding what goes up on the status page or when, but it’s a very small set of what actually happens. There are lots of “known issues“ which never show up there. :thinking:

1 Like

Yeh same here had to log out and back in , but all working now. Would be nice thou if they did update the status page so you know its not just your install that’s having issues

Thanks for all the replies and input to help resolve this

1 Like

You should have been in the middle of fighting another ST issue and have this happen… I thought I was losing my mind! :confused:

2 Likes

Yes, I was able to add automations! Thanks!

2 Likes