SmartThings Community

Devices consistently unavailable


(Todd) #1

Hi. I’ve had 4 devices report as unavailable in the ST app for months now. I’ve been working with support, but nothing they’ve suggested has worked. Here are a few of the things I’ve done so far:
1 - Excluded one of the devices, then added it back. It immediately went back to unavailable. I didn’t try this with the other devices since it didn’t help with the first one.
2 - Unplugged the hub for 15 minutes, then plugged it back up and did a Z-wave repair 3 times in a row. No resulting changes.

The devices show as unavailable in the classic ST app. In the new app, they will show a state (on/off), but that state may not be correct. Also, if the new app shows the state incorrectly (e.g., on), then I can’t turn it on with the app. However, all the unavailable devices seem to work correctly with Alexa even though they are going through the ST hub.

Any more suggestions before I start looking for a replacement? Thanks!


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2
  • Turn off “Device Health”. It is too aggressive and will mark functional devices offline too soon.
  • Only use the Classic App.
  • Isolate the problem one device at a time. Add repeaters (any powered device except lightbulbs) in between your Hub and the problem device).
  • Unplug other repeaters one at a time - a bad one can mess up the entire mesh.
  • Move the problem device close to the hub to make sure the device itself is not the problem.
  • … scream.

(jkp) #3

Out of curiosity- what are the 4 devices?


(Todd) #4

Thanks. I’ll give these things a try…


(Todd) #5

Also, the 4 devices are GE Z-Wave Wireless Smart Lighting Control Appliance Modules. I have a few others that don’t have this issue. I’ll try tgauc’s suggestions this weekend when I have time to devote to this. Thanks!


(Todd) #6

I tried everything I could, but they still aren’t working correctly. If I leave device health off, I can communicate with these devices; but they always show an On status even if they are actually Off. I have a few other GE appliance modules that work correctly. However, does anyone think that the problem is the appliance modules instead of the ST hub?

Todd