Devices added via IDE are not listed as Devices in App - Do show up under Hub in App as "No Room Assigned"

I have a few devices that I have added via the IDE and through the app that I just cannot get to show up in the Device List on the App. I would think they should all show up. Some are compatible devices like Zooz sensors. Some were added by “scanning near by”. Some are created from Device Handlers. And some are from the Default list of Types in the IDE. I have made sure that the devices have a set location in the IDE but they never show up in the Device List. I just can’t figure out what I am doing wrong. Hopefully it is something simple.

Any suggestions?

How exactly did you add a Zwave device through the IDE?

Zooz offers Device Handlers for some of their products.

https://www.support.getzooz.com/kb/article/219-how-to-access-advanced-settings-for-zse29-outdoor-motion-sensor-on-smartthings/

After adding that, as a last resort I tried adding the device manually within the IDE by choosing the option the handler created and giving it the ID that was next in line for Z-Wave devices (or was it the same ID it had when added via the app, I can’t remember now). I got the same results.

That’s not going to add the device to your system. Zooz devices are ZWave and they MUST be added by the hub and assigned the correct network ID by the hub during the inclusion process. Once a device has been included you can switch it’s device handler to the one you added to your IDE. I’d bet money that the reason they’re not showing up is the app is confused. It sees a Zwave device in your IDE but the Hub has no clue how to deal with it because as far as your hub is concerned there’s no such device.

Also when dealing with ZWave - mucking about with the network IDs without knowing specifically what the end result is will break stuff.

Delete the device added in the IDE. Join the device to your Zwave network using the app - THEN switch the device handler on the device you added once it’s visible in the IDE.

EDIT: That’s also why the Location, Hub and Group fields are blank. They’re all required.

OK. Understood and thank you for the clarification when it comes to ZWave devices. Those fields are blank in my picture above because I just went to the Add Device section in the IDE. They are not blank for the device itself when added through the app (see below pic). Currently, it is listed and working properly in the IDE (and working using tiles/rules in other places like SharpTools). It was added through the App using the Brand - Zooz - Motion Sensor - Zooz Motion Sensor method and said it was added properly. I did exclude it from the ZWave Network and Factory Reset it before adding it this way as it is right now. But I am still at a loss as to why it is not showing correctly. I can try to remove it via the IDE again, exclude it from the ZWave network again, factory reset it, and add it back via the app using the brand method but this will be the 3rd time.

Guess I am just getting frustrated.

Should other devices be visible as a device in the App? For instance the Sony BraviaTV that is in the picture. In the thread where I found that handler, I saw another post where the user had it as a usable item in devices in the new SmartThings app. Mine is not. It does have a Location Hub and Group listed in the IDE as well.

Is there a guide to device handlers and/or SmartApps where I can read up other than the forum?

Generally speaking, every device you’ve added should be visible (with the exception of the phone presence device from the new app)

The behavior you’re describing is very abnormal - you should open a ticket with support.

There’s some FAQs for DTHs but TBH they’re not going to be very helpful in this situation. Worry about fixing what’s causing your devices to not join the system properly THEN figure out what’s going on with DTHs

When you rejoin the Zooz device - try ‘search nearby’ instead of by brand. Its the closest equivalent to how Classic used to add devices. As long as you have the Zooz device handler installed properly (which it appears you do) and the DTH is for the correct device type - the system should match it up for you by something called the device fingerprint during the join process. (Read: you may not have to switch the device handler after joining the device.)

2 Likes

OK Thank you. I have tried Search Nearby to add it in my troubleshooting but will try once more.

I think I may need to open up a ticket with SmartThings. But I dread doing that. Was hoping to find a quick solution or something that I was just missing. Early on I was having weird issues where things did not work properly like messages saying “Not supported in your Country” and I finally figured out it was because the location in my Samsung account was listed as India! Opened a ticket to get that changed to my proper location (since you can’t change it yourself) and that took 7 days!!! Maybe that is related to my current problem.

Thanks again for your help.

2 Likes

OK. Back to this topic. Wanted to just update incase anyone else ever runs into the same issue.

This has been in the hands of the SmartThings Developers for over 2 weeks after having the ticket escalated. It is definitely something very strange even to them. In that time frame, we have even went and got actual SmartThings Motion and Multipurpose Sensors to try and they do the same thing. Add correctly in the app but then wont display in the Device List. Only show up as an attached device in the Hub itself. No go. ANd they are ZigBee not ZWave. Work fine in the IDE.

After trying a ton of different troubleshooting steps with them, the developers are now to the point where they say they would like to just have us create a completely new SmartThings Account and that they can “move all of the devices over to the new account on Samsung’s US Based Page.” They are saying they believe the issue stems from the fact that this account was originally mistakenly setup with India as the Country, and that even though they changed it over to have a US location, something broke in the process since that is when the issue started.

My main concern is that this will break all of the rules and other stuff that we have created. There are currently 88 devices and a ton of rules, automations, and scenes. And a another big worry is that we will have to start from scratch with all of the Rules and Dashboards in SharpTools!!! That’s like 20 dashboards and quite a few rules that were built there. I guess I can ask about that over on their forums. @joshua_lyon

Just wanted to update incase anyone has the issue in the future. I guess if you have an issue with the region of your SmartThings Account, it is probably best to just create a new fresh one so you dont have all these issues. Lessons learned.

Feel free to reach out to support@sharptools.io and we would be happy to help however we can. I’ll shoot you a PM as well. :slight_smile:

Great. Thanks so much Josh. Fast customer service and support as always.

1 Like