Device not responding in Alexa, is it smartthings fault or alexa?

so I have two Smart Power outlet device (ZigBee) that I purchased two-three months back from mydigitaldiscounts. Both were working great for the longest with Alexa, they show power usage when it’s working. Both are in the same room. Now one of them is acting wonky. Usually I say ‘Alexa turn on/off mini TiVo outlet’ and sec or two later it works.

Now it doesn’t work Alexa says "Sorry, mini Tivo outlet isn’t responding. The odd thing is that outlet works just fine reports energy, and turns on/off but ONLY with Smartthings App.

I thought it was an Alexa issue and used to do a ‘forget all’ procedure and still nothing. I tried a different device type so I went with ‘SmartPower Outlet V1’ and guess what Alexa is able to turn on/off no problems…what?! but V1 doesn’t do energy reporting :confused: son of a … .

So any suggestions on who I should open a ticket with Amazon alexa support or Smartthings support and in the meantime is there another ZigBee device type that’s an outlet AND reports energy that I can try?

Another route is to factory reset. Is there a way to reset the device without losing the routines, pistons that I have associated with it?

good news, I’m using device type: ‘ZigBee Switch Power’ and Alexa is working fine and this device type does report energy…

phewww, weird that the other device type stopped working out of the blue. let’s see how long this device type works :sunglasses:

I am also having issues with a few dimmers suddenly no longer working with Alexa. I have not tried making DTH changes but I don’t see why it would be that. Rather I wonder whether making any changes just forces some update that fixes the issue. I read somewhere else that forgetting and discovering the device fixes it too but I was hoping it would just revert back to working before I started tearing things down…