Device in Connect - not in classic or github?

I know many devices only work in classic still but I haven’t seen this issue yet. I added an Aeotec Home Energy Manager to my smartthings v2. The device appears in my Samsung Connect apps but not in github or Smartthings classic. I have removed the device reset the app and tried a number of attempts to get this installed but no luck. Help would be appreciated.

Without being in github, I cannot apply device handler to make the device useful. Also many of my devices haven’t moved to Connect yet so I still use Classic as my primary control point.

Thank you in advance for having a look at this challenge.

Can you explain a little more about what you mean about not being in Github? Did you create your own repo and fork code from someone else, or did you set up GitHub Repository Integration in the IDE?

If you joined the device, and can see it in the new app, it should be in the classic because it joins just 1 hub which both apps link to.

When you’re in a Room and go to add a device to it, does it show up?

What about your Things list in the classic app?

What does your My Device list look like in the IDE?

I’m not sure what you mean by that. Can you provide a little more info?

1 Like

I have the same problem.
This morning I tried to add Aeotec Home Energy Meter Gen5 ZW095 using the Classic app, I added 5 times (I tried several times because the app was not discovering).

I installed and setup new Samsung app and I found 5 devices:

I checked the List Events and was added 5 times but was not listed under hub devices or in the Classic App.
I tried to erase it and I got this error but, IDE was showing the device deleted (I pressed the exclusion button 5 times).

I called Support, actually they(was a nice lady) don’t know what IDE means or how I can see logs on web browser. She also said… I cannot delete a device if is on my default location. ?!?!?!

I tried again to add the device using the New Samsung app and I was unable to add it, I did it with the Classic app like this I have 6 devices but just one is working on the new app but not in old app or IDE.

Now I can’t delete 5 of them.
Also I have 5 locations, I am not able to delete 3 that are empty_(Under IDE I have just 2 locations)_

I spent hours with Customer Support, maybe SmartThings Staff can help me. Thanks.

Sorry, I mean IDE. No fork code or anything like that. The device needs a device handler for added functionality. The device does not appear in IDE.

My other devices that only control from a single app appear in both but oddly enough the Home Energy Monitor does not appear in classic or IDE - it does register and update in Samsung Connect. I have tried to add it from the Classic app but it doesn’t show up however magically appears in the new Connect app.

I had the same but worked it down to one - which works in connect but want to get into IDE where I can hopefully add functionality. I did it by unplugging the HEM and then deleted the same way you tried. It wont delete if it is getting a signal but offline it will. I then re-added it bur only once.

try logging into IDE with an incognito/private tab in your web browser at

FYI: In order to delete a Home Location that has nothing in it:

  1. Login to IDE at
  2. Goto Locations
  3. If you have multiple Locations, select the invalid one
  4. Make sure there is no Hub associated to it
  5. Scroll to the right and click Edit
  6. If the Default Location shows “true” (will be read only)
  7. If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
  8. Now you can edit/delete the additional Home location as it will automatically be set to “false”.
1 Like

Thanks, I will try again later.

Same, two locations on IDE or Classic App, 6 on new App.

In every Test location are no devices.
Clear data, cache, uninstall new app, No change.