New device not showing in "my devices"

I just added a new device to my Smartthings.IDE. the new deivce "Dome On/Off-switch shows in “My Device Handler” but when i go to “My Devices” the new item is not listed…

just a little back ground. i tried many times yesterday to load the device handler. and was successful. but when i add the new device to my Smarting App on my phone i didnt get the upgrade i was looking for. so i deleted it.
today i’m trying to reinstall the device handler and goods Ok but not showing in “My Devices”

please help… going crazy.

Are you using SmartThings classic app when trying to add the device? Once you install the device handler and publish it in IDE, you need to add the device using the Classic app.

Hello. Thanks for the reply
Yes I’m using the classic app.
Once I add it to my smartthings IDE it shows in “My Devise List” then when I click on “My Devices” it doesn’t show.
Are you saying once I add it from code, then publish it for me and see it in “My Devise List” I should the load the " Dome On/Off-switch before I can see not in “My Devises”?

  • login to IDE at add device handler in My Device Handlers, save and publish
  • open the Classic app, click on the My Home tab in the lower menu, then select Things in the upper menu, click on the + to Add a Device and follow instructions for including that device. usually pressing the switch to finish the setup

if you provide a link to the post where you got the device handler, it will probably offer us more details on what you have.

Thank you for the help. I figured this would show before I added the device to the ST App. I followed your instructions and this worked


Hello, all routines that i need to use have been set up for over a year now and all have been published in the IDE. are you suggesting i have to set all devices up again in the IDE?

This thread is extremely old and so many things have changed in that time. Mainly, the migration to the new app is the biggest change. What exactly do you mean by “All routines that i need to use have been set up for over a year now and all have been published in the IDE.”?

Routines are not set up in IDE. What are you trying to do?

so sorry, i replied to the wrong thread…