Smartthings Connect vs Classic. IDE Inconsistencies. Other Comm Issues

I have been using SmartThings devices for several years now, and only recently have I began having any trouble.

Having issues with my HA devices has prompted me to get under the hood of ST much more than I have in the past, and I’ve made some peculiar observations. Unfortunately, I’m not sure if this is the way it is supposed to work, or if there is something corrupted that is causing all of my recent frustration.

The first thing that I’d like to know/understand, is why when I modify locations in the new ST connect app, these changes are not always reflected in the IDE. For instance, if I rename the Home location to NewHome in the app, it does not change in the IDE, and vice versa. The classic app appears to update both ways in real time. Could this have something to do with the shard architecture?

I was also wondering if my account may have splintered somehow since Samsung has recently allowed SSO with google accounts. If my credentials are the same, is it possible that the same username/password combination could have created a duplicate account due to the way SSO with google works? If I just log in to a Google account with no preexisting Samsung account, it creates a Samsung account with the same username and prompts for password creation.

My v2 hub disappeared from my IDE the other day, but was still visible in the app, although unresponsive. During my troubleshooting I ended up manually deleting everything that I could all the way to the Samsung account level.

After creating a new account and factory resting the hub, my code still showed as being registered elsewhere. Since the account had been deleted, there was no way I could even go in and try to delete the locations, etc. again. Samsung is working on getting back to me with a way to unbrick this hub.

In the meantime, I have purchased a v3 hub to try to get my system back up. It works well, except for that fact that it must not speak zigbee. It refuses to register any zigbee device. It simply times out when I try to add them. I have tried five or six different types of devices and at least two of each, all after following factory reset instructions on each individual device.

Oddly enough, the hub is logging zbjoin events such as these below. What is going on? Is my account corrupt. Is the zigbee radio in my new hub defective? Surely 20 zigbee sensors haven’t banded together and decided not to talk to the new hub? It is odd thought, that if I power on several buttons, multi-sensors, outlets, etc., they appear the be joining their own mesh network, according to the status lights, but there is no way for me to interface with them or monitor them with the hub being out of the loop.

Sorry so long. This has been beyond frustrating. If anyone can shed light on any of the above topics, please do, and help me understand what is happening here.


Start here

Is the green LED on the hub flashing when you add a zigbee device?


Let’s start with something simple and go from there. First, do you login to IDE at ? Second, have you tried adding your zigbee devices using the Classic app?

1 Like

Yes, when I manually add the device from either the ST Connect or Classic app, it flashes green. I believe that is when it receives the zbjoin messages from the individual devices, but seems to ignore them.

Thank you for the reply. Yes, I have done both of these things many times. I read that this link will take you to the correct shard, but is this the shard for classic or the new app, or what?

1 Like

not the device, the hub. Is the light on the hub flashing green when trying to pair?

Yes, I’m sorry if I wasn’t clear. The green light on the hub flashes when I attempt to manually add a device. At the time I do this, I also follow the individual device reset instructions trying to initiate a pairing. It’s as if the hub is completely ignoring them. z-wave devices work fine, and the zigbee devices all worked fine on my v2 hub before.

is your hub at least 5 ft away from your wifi router?

But you have two Samsung accounts now?

Well, it is not near my router, but it does usually sit within 5 feet of a dual band extender. I have considered this and disabled the 2.4GHz access point while troubleshooting. I also moved the hub across the room, and none of that has made any difference.

1 Like

Well, I’ve actually created several trying to figure out if it was my original account that was the problem. I have deleted most of the test accounts and use the one exclusively for all things Samsung. I just wonder if the google SSO thing could be an issue.

Is this the account that originally contained the v2 hub?

Well, that’s where it gets a little confusing. It is the same email address, but I’m pretty sure I deleted the original account in frustration hoping that would at least allow me to rebuild my setup from scratch. During this process, I also changed the email address of that original account two or three times to insure that I wasn’t inadvertently logging in to the sso google account of the same name.

This all happened immediately after I installed android 9 pie on my S9. While I was configuring everything, I was jumping back and forth between logging in to my samsung account and google account that have the same username. At one point, an SSO prompt came up that allowed me to log in to my Samsung account with my Google credentials. At that point, I wasn’t certain how anything was authenticating and how it could have effected ST. It just seems very coincidental that all of this happened at the same time.

Have you tried logging in with the Samsung account and not google? Logout and choose New to SmartThings and use your Samsung account.

1 Like

I’m not logging in to the IDE or anywhere else Samsung with my Google account. I have made sure of that because the passwords are different. The only time I logged in to the Google account was when I was going through the prompts configuring my phone. I only bring it up, because the timing was coincidental, and it was the first time that I’ve seen a sso prompt for a Samsung account with Google credentials. The username(email address) is the same on both accounts. I feel that there is a small chance that this could have caused some account confusion within the system. Grasping at straws here.

The Shard is completely irrelevant to the SmartThings Apps.

Your Location Object (and all its Hubs and Devices) live on a Shard of the SmartThings Cloud and are contained entirely in that Shard and are not replicated to others.

A single SmartThings Account can have Locations on many different Shards. Thus the login cannot determine the customer’s Shard in every case. I presume it picks the Shard of the first Location.

To redirect to the correct Shard for your Location, go to My Locations and click on the Location Name.

Let’s just hold out hope they can get everything working on the new app because it does look graphically much better then the classic app. I know somethings can be frustrating and I am not an expert at this stuff but let’s just keep our fingers crossed.

1 Like