Device Handler for Yoolax zigbee motorized shades

I couldn’t figure out where you changed this code, was it in the device itself or the handler? Everything is showing backwards for me.

So I know this is getting a bit old. Just got some shades myself and needed to reverse them. Changed the following to swap up / down. I created a separate handler to toy with so I now have left hand and right hand handler. I had to make these changes for a right hand motor otherwise open and closed were reversed.

Line 174, swap how the shade understand the open / closed state:
from: sendEvent(name: “windowShade”, value: currentLevel == 0 ? “closed” : “open”)
to: sendEvent(name: “windowShade”, value: currentLevel == 100 ? “closed” : “open”)

Line 175, swap the understanding of positioning of level increasing or decreasing:
from: if (lastLevel < currentLevel) {
to: if (lastLevel > currentLevel) {

Line 177:
from: } else if (lastLevel > currentLevel) {
to: } else if (lastLevel < currentLevel) {

Line 216, change definition of closed:
from: setLevel(0)
to: setLevel(100)

Line 221, change the definition of open:
from: setLevel(100)
to: setLevel(0)

Line 231, remove the inverse position:
from: data = 100 - data
to: data = data

Hope this helps.

Hello,

I have version 2 of the ST Hub and was semi-successful with pairing and controlling 3 new Graywind Blinds (ZF Motor) with Google Home. It works just fine with the remote control that it came with. And Windows 2 and 3 work as expected with google home. However, Window 1 experienced the same issue as Shizzaq’s post on June 21. And so I removed the device, reset it and added it again. However, now it pairs, but smartthing does not appear to have access to it like Windows 2 and 3. I get the constant 'A network or server error occurred, Try again later." error and thus Google Home does not have access to it


. I’ve already tried resetting the ST hub, rebooting my wireless router, resetting my cable modem, shutting off the blind and turning it back on, renaming the device, etc, etc. Is it me or is the original device stuck somewhere on the Hub’s side? Thank you.

I have this same exact issue and seems to be happening with some motors. This btw was on a replacement motor I got sometime last month or so. But I only got time now to try and figure this out with hubs. The remote works fine but no response on smartthings. Any luck trying to figure this out?

I messed around again when I logged into https://account.smartthings.com. At first, when I deleted the device, I received a message that Window 1 was deleted, but also got the Access Denied message. It appears that Window 1 was deleted since I did not see it under my Devices afterwards. I tried to manually add the device, but ultimately just paired it again. Long story short, I changed the device type from Zigbee Window Shade Battery to just Zigbee Window Shade and then changed it back and Google Home was able to fully open or Fully close it, but not 50% open or 50% close. So right now, it semi-works. The icon Window 1 icon is still grayed out, unlike Window 2 and 3. But at least Google Home is able to open and close it. I had to use routines to get it to work like window 2 and 3, or when i group them all together to either open all windows or close all windows. I am now happy with my results. Good Luck.

1 Like

Thank you.
I tried it again :frowning:
Looks like it isn’t responding at all. Also, the switch may be the culprit on this particular motor. It was a bit hard to press and wouldn’t click. And then, a tiny black switch fell from it. May be that is the issue. Even google home doesn’t do anything. I am reaching out to them. The other motors seem to work fine for now.

Yeah, I too, have reversed statues on 2 out of 3 blinds. Windows 2 and 3, these are the two that are recognized by smartthings. I use Google routines to get all 3 to work in the same order. I know how frustrating it is when trying to set these up to the way you envision using them. I spent days and countless trial and error until I got it working, which is very satisfying. Try reaching out to Graywind sales, they are responsive. I needed to reach out to them when I received my blinds and couldn’t pair them with my ZF remote. The issue was that they sent me a manual for the RF motor.

1 Like

I just installed me new Yoolax blackpout zigbee shade. All works. Have it hooked up to ST2 and Google home. Will this code correct the “opposite” problem I am having? My motor is on the left.

I just installed this. It fixed everything. Thank you so much.

The only thing that doesn’t really work is saying “Hey Google, open shade 50% or close shade 50%”. It’s worked a handful of times, but mostly it just opens and closes. When I was using the Yooksmart handler, this function would work, albeit all screwed up due to my motor being on the left. The slider function in SmartThings for percentage open or close does work.

Also there is no function in the Google Home app to operate the shade. It just gives me settings. Not a big deal, just wondering if that is the case for everyone using this handler. Thank again.

I also don’t have controls in the Google Home app, but telling google percentages works for me even though she always says “opening” the shade to XX percent.

What command do you use? Did you remove it from smartthings and readd it after making the changes?

“Hey Google open/close [name] shade to xx%”

Thank you so much. The “to” is the key. I was just saying “Hey Google, open shade 50%”.

1 Like

Thanks so much! I had to do this as well for my new Yoolax roller blinds with the motor on the right-hand. In this configuration, 0% is fully open (blinds up, no shade) and 100% is fully closed (blinds down, fully shaded). The blinds report this as well when looking at the live logging.

Everything works perfectly within the SmartThings app and all status is reflected properly.

Integrating with Google Home/Assistant works for the most part as well. I can ask it to open, close, and set to a %-age.

However, within the Google Home/Assistant app itself, the current fully Opened/Closed status is displayed incorrectly. Seems it always shows “Closed” when it’s 0% and “Open” when 100%. Same response when you “Hey Google, are the blinds open?” It’ll respond that they’re closed when the %-age is 0% when this is actually fully open.

Any ideas on how to resolve this? Thanks in advance.

I ended up with the same issue with my third order of shades, it’s frustrating that the other 4 work correctly and the latest 3 don’t.

Do we know if these are going to get any firmware updates to correct this?

I gave up on this and will just reverse the motor and put it on the opposite side. Here’s a video they put together for that: How to Change Motor Position - YouTube. This should take care of it but you’ll also have to configure the remote to do the opposite.

It was worth a try, but I still had the same issue of 100% being closed and it being backwards in the Google Home App. It’s just frustrating after having the 4 others I bought work fine with this DTH.

Hi all, trying to get my new Graywind/Yooksmart shades to work properly. Currently, they are showing as reversed status in both ST and Google Home (shows open when they are actually closed, and opens when I say “close the blinds”). I was able to get it somewhat working with voice by creating opposite scenes, but they still display incorrectly in the apps.

I created a new DTH with the code, and edited the specific lines noted in a comment above to reverse the statuses. I set my device to this new reversed DTH, but nothing seems to have changed in either app.

Do I need to do anything to force the shades to switch to the new device type? Maybe reboot ST? Maybe delete my shade and try to add it again?

I used ST a long time ago, and I remember being able to pick the specific DTH I wanted before adding a new device. The new app doesn’t seem to allow that, unless I’m missing it?

Any help appreciated! Thanks in advance :slight_smile: