Device handler corruption (Error 500) killed my keypads from ever working with SmartThings (April 2019)

I recently migrated to SmartThings from Iris. I set up a hub with about 160 devices that included 5 Iris keypads. Something happened with the keypads about a week into my journey with SmartThings. My app lost connection to the hub and I could not see my devices. When I tried to pull up devices or the hub on the IDE page I received error 500. Looking under the “Home” link where I could see my rooms, none of the rooms that had keypads in them would open and again I received error 500.

Fast forward, with no resolution from support, I bought a new hub and opened a new Samsung account (because the new hub would not install in the previous account) and began pairing all my devices to the new hub with a fresh start. All devices other than the keypads paired just fine. None of the keypads that were previously paired will pair to the new hub but I was able to pair a spare one that had not been paired to the previous hub.

The keypads are fine because I successfully paired with the Iris hub before Iris was shutdown.

It was suggested to me that the device handler for the keypads had become corrupt and caused this problem. That the keypads remain on the Smartthings system somewhere, undeleted or removed and is preventing me from pairing with my system.

Here is what I have tried so far.

Wiping the old hub.
Since I was unable to remove anything from the previous account (support could not remove anything either) I deleted the entire Samsung account.
Setting up the previous hub in my wife’s account to see if the keypads would pair with the old hub, thinking that maybe they were locked to that hub.

My suspicion is that the old account has not really been removed from the servers like support told me that it would be.

Is there anyway to get my keypads to pair with my new account?

Tagging @Brad_ST

500: Internal Server Error. How to fix it?


Have you tried manually resetting the keypad?

Page 3:

Do that first, and then pair with ST.

1 Like

It is not a reset issue, I assure you that I have fully reset the devices and they go into pairing mode.

Do you have a reference ID for one of your 500 errors?

It sounds like the issue jkp referenced which I can fix.

Hey Brad. When support couldn’t fix the issue, we deleted the account, which I am now thinking was a mistake. I do not have a reference number for the error. After this happened, I paired all of the keypads to Iris and dumped the info about each of the keypads to a text file. Would that help? I could also send you the emails back and forth to support.

Edit: I do have a reference number. I took a screen shot. Hang tight.


Well, I am happy to say that @Brad_ST got it fixed for me. My old hub an location had not deleted as I suspected. He was able to finally remove it and the keypads will pair now. Thanks.


@Brad_ST, I happened upon another thread where you had helped out a user that had the same issue with his keypads. I noticed that he said that he had switched device handlers and later he had the error 500 problem. I also had switched device handlers before my error 500 issue appeared. I had started with Mitch Ponds handler and then switched to rboys and then reverted back to Mitch’s handler. I see a pattern here.