Detecting Arlo Motion stopped working

Only that they’re working on it. I’ve asked them several times for an estimated fix date, but they won’t respond. This is typical of Big Tech. They may, or may not, know yet. Either that, or they’re waiting to push a software update across multiple devices. Sometimes a “fix”, that covers a wide-range of products, can have unintended consequences, so they need to test on multiple platforms.

I’ve offered my experience as a software developer & product beta-tester, and for them to (remotely) use my smart-home network as a test-bed, but they’ve ignored my offer.

Others have had success using Alexa app instead of Arlo’s unreliable integration. I haven’t tried it yet, so I can’t advise on the steps, but I believe that the Alexa app also has a provision to create rule-based automations. So basically you’re telling Alexa to sense motion from the Arlo cameras, to then turn on your SmartThings devices. That, of course, assumes that you have an Amazon Echo or other device with “Alexa built-in” that can serve as an Alexa hub (some devices can, and some can’t.)

1 Like

Note: Arlo app updated to version 3.5.13_28425 on 01/25/22

So today I tried again to unlink Arlo from Smartthings and then relink. After unlinking I went into the Smartthings IDE and I discovered only 1 of the 8 cameras was removed after unlinking, even though none of the cameras were showing in the Smartthings app itself. To ensure the relink was going to be fresh and from scratch, I removed the remaining Arlo cameras via the Smartthings IDE.

After relinking Arlo / Smartthings the basestation and all cameras were successfully brought into Smartthings and correctly showed in the app. ON/OFF functionality worked fine, and the current battery status for each camera came across with the relinking, but I cannot yet confirm that the battery status was correctly updating. The battery icon on the Smartthings camera display would never go solid with a displayed percentage but appeared to be attempting to get battery status as it was displaying rotating dots on top of the battery icon.

To test whether the motion sensor functionality was now working correctly… I created a simple Smartthings automation that would turn ON a virtual switch if motion was detected by a specific Arlo camera. The testing showed that Smartthings was again receiving and processing motion detection from the Arlo cameras as the Arlo camera motion detection successfully triggered the Smartthings virtual switch.

So bottom-line… It appears if you unlink Arlo from Smartthings and ensure all devices have indeed been deleted via the Smartthings IDE, then relink Arlo / Smartthings, all functionality (except for possibly battery status updates) will again be working.

1 Like

New to this forum but I too cannot get ST automation to work with Arlo Pro 2 motion detection. I’ve tried everything mentioned in all the posts. Sounds like something broke back around November 2021. Hope they get this fixed soon!?

An update was posted in the Arlo forum today (see link above from @mwf369):

There will be an update coming soon, roughly early next week that should resolve this issue.

1 Like

So, after following these steps, it gets even more curious for me…

The cameras are now recognized by Smartthings, and function as they should as standalone cameras. However, I know have the following issues:

  1. The cameras are only recognized by Home Monitoring in “Stay” mode. They are not listed as devices in “Away” mode. However, they do work correctly in Stay mode when armed.
  2. Attempting to access settings for home monitor produces an error and tells me to try again later.
  3. All of my lighting automations are a mess. They work when they want to, and don’t when they don’t.
  4. At times, turning on/off a single light, either manually with the switch on the controller, or by means of Smartthings or Google Home, will turn on/off multiple lights.

What a mess. My setup worked without issue for three years. Now nothing is working correctly, even automations unrelated to Arlo.

@ciarlatano: Your issue #4 may be due to the recent ST firmware update. See the folllowing

What is “Home Monitoring”? “Stay” and “Away” sound like ADT terms. If you’re throwing another app in the mix, you might have a conflict, but I’m just guessing. I presume that all of your app are up-to-date?

Someone else mentioned the recent ST update. I just got Arlo communicating motion to ST, and I was afraid the new ST update would screw something up, but it didn’t.

Home Monitoring is the section of SmartThings that monitors any motion, open/close, smoke, leak, etc sensors and alerts. Nothing to do with ADT.

I have discovered that the only automations that have stopped working are those that are triggered by time. If they are reacting to a switch or sensor they are working with no issue. So, if I have multiple lights set to turn on at different times, if I turn on one of them manually, everything that should be on at that given time (but isn’t because the automations failed) turns on.

I am really thinking about trashing this for another hub.

1 Like

Ive never used Home Monitor, or anything under the Life tab. I use IFTTT and Automations, based on either a specific time, or sunset/sunrise. I’m not having any time-related issues. Now that motion is being sent from Arlo to ST, all of my automations are working just fine.

Have you tried deleting one or two of the automations? Have you done a “sanity check” on the automation to be sure you’re doing what you think you’re doing? One thing that initially tripped me up when creating the automations was the “When all conditions below are met” vs “When any condition below is met”.

Update from Arlo today: Re: SmartThings integration failing (motion events... - Page 11 - Arlo Community

This issue should now be resolved. If you have previously removed your Devices, please try adding them back to SmartThings and test again.

You didn’t mention if it is resolved for you?

My Arlo Q+ and Arlo 2’s are still not showing any motion in SmartThings. I opened the Arlo linked service in SmartThings and closed it, and I rebooted the Arlo Hub and Q+ camera, and still no motion from the cameras are shown in SmartThings. So it’s still not resolved for me.

I have the same problem and use IFTTT to actually control a light on Motion from Arlo. Actiontiles show a similar issue, select an Arlo Camera (in Actiontiles) select motion and then add it. The tile does not show motion. However using a Virtual switch set from IFTTT can get the same effect.

I’ve had a similar issue, but am not sure when it stated. (Being winter time here, I’m not outside at night a lot to notice.) I am using the ST Smart Lighting so that when an Arlo Light or Arlo camera have motion triggered, then it turns on the Arlo light. (I have 6 lights and 4 cameras.) It’s worked without any issues for years now (except whenever Arlo updates something and breaks the connection between Arlo & ST). However, I’ve noticed that none of my Arlo lights turn on with any outside motion now.

I also use ST Smart Lighting to turn on certain inside “notification” light bulbs certain colors when a door or window is opened, or when there is motion inside and ST Home Monitor is in “Night” (or “Arm (stay)”) mode. That ST Smart Lighting operation still works just fine.

To troubleshoot, I created a quick Automation in ST, so that when motion is detected on “Arlo Light Front Porch”, then it should turn on “Arlo Light Front Porch”. This did not work.

I am able to turn the Arlo lights on & off directly from the ST App.

Based on the 2 replies to this Arlo thread on 2/8, it is still not fixed.

Has anyone had any success with a resolution? I will post over on Arlo’s thread as well, but their solution is always uninstall everything, and reinstall it again (i.e. remove Arlo devices from ST, re-link to ST, re-create all my automations, routines, apps, etc. that use Arlo products, etc.)… which is a huge PITA.

My system has been working reliably for over a week now. I’m on an Android phone. I don’t know the steps one would use for an iPhone, but here are the steps I followed:

You’ll have to de-link the Arlo integration, hard-close the app, clear cache & data from the app, and delete the Arlo app. At this point, some people have found “phantom cameras” still residing in ST (I did not, but regardless, they should not be there). If so, delete them. Then, reboot the phone (an important step to reallocate the freed-up system memory), reinstall the app, log in, and re-link the integration. Somebody please correct me if I’ve forgotten a step.

I did those steps, and it still didn’t work, but several days later (possibly a week), everything started working. I think the delay was because Arlo was still twiddling with integration.

I am having this same issue and it isn’t fixed for me. Any update from Arlo as to when this will be fixed?

Just tried those steps and it didnt work. Looks like Arlo knows about the issue and is working on it.

What a pain in the ass, My 1st ticket was submitted in November. All my webcore functionality is useless, what other cameras work with Smarthings? I am ready to move on. I have been unlinking and relinking Smarthings every week. Sometimes it then works for part of day, sometimes a day, and until last week, It was working for almost three week straight! I not sure if they dont care or are incompetent

1 Like

Over the weekend I created an Alexa Virtual Switch Device for each Arlo camera since I have Arlo connected to Amazon Alexa. I then setup Alexa Routines that when Motion is detected from a specific Arlo camera to turn On the associated Alexa Virtual Switch, and another Routine when Motion is not detected for 0 time to turn Off the Alexa Virtual Switch.

I then added these Alexa Virtual switches to all of my SmartThings Automations and even the STHM since the Alexa Virtual Switch is an Open/Close capable virtual sensor.

I did this to get around Arlo and SmartThings lack of enthusiasm to fix the direct link issue, and because even if they do, I would still need the internet (less the third party Amazon in this case) for the integration anyway. Plus, irregardless of even if they fix the Arlo/SmartThings integration, at least this provides a backup solution ‘WHEN’ the Arlo/SmartThings fails again in the future.

Now hopefully the Arlo to Amazon Alexa integration remains solid…

1 Like

This problem isn´t fixed yet, is it?
With which cameras does it work?

1 Like

The motion detection is working again finally today. Keeping my Alexa routine just in case it stop working again after two weeks just like before :disappointed_relieved: