Detecting Arlo Motion stopped working

I’m pulling out my hair with an automation: I have a Zooz z-wave sensor, which works perfectly. After sunset, it senses motion on my front walkway and turns on the porch light. It’s been working fine for nearly a year, so I wanted to add the motion sense capability from 2 Arlo cameras to the same automation. I have the automation set to “…any condition…”, and the cameras (1 Arlo Ultra, and 1 Arlo Pro 3 Floodlight) are set to push notifications. The Zooz sensor still works as expected, but no amout of motion in front of the cameras will turn the light on. It’s as if these cameras aren’t sending out the motion signal. But I know they’re seeing motion, because I have plenty of video clips of sime maniac (me) jumping around in front of the cameras! The Ultra hub is set to either “Armed” (records video & sends a push) or a custom mode that I call “Diarmed #2” (doesn’t record, but sends a push).

Any thoughts?

1 Like

Other people have reported that arlo motion detection notifications, which used to work as ST automation triggers, stopped working earlier this month. :disappointed_relieved:

You may need to contact Arlo support, but check that thread first. The topic title is a clickable link.

1 Like

Thanks @JDRoberts. It’s at least reassuring that I haven’t lost my mind. (Although I’m sure my wife would disagree)

2 Likes

This isn’t the best approach, but I’m using a virtual device triggered by the IFTTT applet to detect my Arlo motion. IFTTT allows motion to be based on All Motion, Pets, Cars, or People. I didn’t want tons of false alerts so I set mine up for People only.

1 Like

So glad that others are experiencing the same issue. I have used Arlo motion as a trigger for a Smart Lighting automation for months now. . I am not sure exactly when it stopped working, but within the last week. . I have tried everything to fix, including disconnecting ST from Arlo, deleting and recreating the automations, as well as restarting Arlo and ST. I used camera on as a trigger and this worked, so the problem seems isolated to using motion as a trigger.

1 Like

I too have lost the Arlo motion integration with the Smartthings Smart Light app. All of my other routines in the Smart Light app are working. I tried deleting and rewriting the routines. Reconnected Arlo to Smartthings and nothing seems to have worked. Rebooted router, ST, and Arlo. I never lost my notifications from Arlo. Any help would be appreciated.

1 Like

Yeah, I’m not exactly sure how Arlo communicates a motion signal to Smartthings. It still seems to see motion, and correctly sends motion notifications. Glad I’m not the only one who’s seen this problem.

Has anyone communicated this problem to Arlo support?

1 Like

I had started a service ticket via chat last night (12/29/21). I did a bunch of stuff and they said it had to be escalated to the “Service Team” So I have not resolved the issue. I did everything that I could on my end. Rebooted router, Arlo, ST hub, unlinked Arlo/ST, reconnected. Manually deleted all of the Arlo devices from ST. Re linked. Still cant get motion to trigger any devices. All of my other Smart Light routines work fine.

Same here. I used Arlo cameras as motion sensors reliably since 2017, they stopped 2 providing motion sensing to SmartThings 2 weeks ago. Some screwed something in the APIs.

2 Likes

I am currently trying a resolution from Arlo. I will let you know if it works tonight.

  1. Disintegrate/Remove the Arlo devices from SmartThings.

  2. Uninstall the Arlo app

  3. Restart the phone

  4. Re-install the Arlo app.

  5. Allow all permissions upon opening the newly installed Arlo app.

  6. Check if the App version is updated by going into the app Settings, then About. The latest iOS and android app versions are 3.5.10.

*Make sure notifications permission is on for the Arlo app on your phone settings.

  1. Add the Arlo again into SmartThings.

  2. After that, please test and observe.

Update:
This recommended solution worked. Kinda. If you follow it step by step and you have a failure with the integration or your devices do not show up then you have to start over. It took me several attempts. I had it working the first attempt but I had batteries out of 2 cameras and when I put them in, they wouldn’t send motion notifications to ST. So I did the process all over again. Took 3 tries to get it to work. And it seems glitchy. Not all the lights are turning back off after my"Off after 5 minutes of no motion" rule.

I’m surprised that they didn’t ask you to reset each camera, too! This sounds like a “shotgun approach”, meaning they don’t really know what’s wrong. When you have 10-12 cameras, you’re almost guaranteed to have an “integration failure” with one of them, once or twice. Yeah, I won’t be trying that “fix” until someone can assure me that it’s a proven solution. This might be an easy fix, for some of you, but one of my cameras is 17ft high! I’ll have to hire someone to get it down!

2 Likes

They actually provided a 3 part solution. Resetting the hub and starting over was the 2nd solution. And I’m with ya, I’m not doing that until it’s a proven fix. 3 of my 7 cameras are not easy to get to…

I was given a new recommended solution that appears to have worked. Let’s hope it lasts for more than a few hours.

As I reviewed the case, I can see that when integration with Smart Thing it will not send a notification when detecting a motion. As I consulted with the appropriate team they advised me to do, kindly try to remove devices from SmartThings. Then, please try to do the following steps:

  1. Perform a Reset Network Settings (Phone Settings > General > Reset > Reset Network Settings)

  2. Connect to the same network as the Arlo base station. Disable Cellular data and VPN.

  3. Disarmed the Arlo system. You may follow the link below to disarm:

Arm or Disarm Arlo Devices

  1. Re-configure SmartThings and check if the same issue.

We are hoping for your continued patience and understanding.

Hey Ryan,

I was with you up to step #4. Exactly what do you mean by “Re-configure SmartThings”?

I have several automations in SmartThings that rely on motion from various Arlo cameras. Are you (or Arlo) suggesting that I need to delete these automations, and then re-create them, or just to check them to see if they’re working? Deleting the automations would be a lit of work, but it’s doable. But, I’m not exactly looking forward to it either!

I’ll do 1-3 tomorrow morning, and I’ll check the automations. If that doesn’t work, I’ll delete all of the automations & re-create one of them, as a test

Don’t bother. It stopped working a few hours later. Same as the last fix.

Just tried it, and had to re-pair my Galaxy watch (I hadn’t thought about that!), but it didn’t do anything. So I deleted my automations, and re-created just one, and it didn’t work. To be clear, the automation is to turn on the front porch light when either driveway Floodlight Pro 3 or the front yard Ultra cameras detect motion. I get a motion notification from Arlo, but the light doesn’t turn on, so SmartThings isn’t getting the message that motion occurred.

I just recreated the automation with my Zooz sensor, and it works fine. The problem is with Arlo!

1 Like

I had the same issue. Lost all my saved Wi-Fi connections and Bluetooth devices. What a pain in the A

I agree! A major PITA (Pain In The A**), but easily restored.

Several years ago, I installed the Smart Lighting app, in SmartThings. It’s what I use to automate household stuff, like turning lights on/off. I though maybe it was interfering with the automation routines, so I turned it off: same problem. Then, I enabled Smart Lighting, and disabled all of my automations: same problem.

On the Arlo side, I’ve tried: enabling push & email notifications, just enabling push, and just enabling email: same problem. I get notifications just fine, but whatever mechanism is used to signal SmartThings, it ain’t happening!

When I have a few hours to play around with this, I’ll call Arlo support. Their chat feature is useless!

Arlo doesn’t seem to have a control to “Notify SmartThings”. I wish they did! They also don’t describe anywhere how their cameras notify SmartThings: is it a push or email notification. In either case, how does SmartThings know to look for it? What’s the mechanism? That’s what I don’t understand.

Normally this would be done through the SmartThings API. Arlo sends an Internet message in the right format, which anyone can do, smartthings knows that it has received this kind of message and based on the content acts on it. It’s pretty much the same method that Arlo would use to communicate with Alexa or another voice assistant, although the content format may be different.

That part shouldn’t be difficult: literally dozens of other companies do it, it’s how all the cloud to cloud integrations that you see in the smartthings app work.

Sometimes this method is modified for specific individual companies in order to add some extra features or reduce latency. For example, there’s a special integration of this type with Phillips hue. I don’t know if that was done for Arlo or not.