Detecting Arlo Motion stopped working

BTW, i have this issue even with Alexa routines. I set up a few routines with my Arlo’s to try and get by until the ST/Arlo integration works again, and its not even working within Alexa.

1 Like

I had a weird problem with Alexa & SmartThings: I had a group called “Jeff’s Office Lights”. Worked flawlessly for months. Then Alexa got it in her head that she should copy that group, and add my new Samsung 85" TV to the group. Then, when I shut off my office lights through Alexa, it’d turn off the living room TV! It took me awhile to realize that the new group was only viewable through the Alexa app. If I turned on the old group, through the SmartThings app, it worked fine.

As another poster said, Arlo’s big solution (which didn’t solve his problem) was to delete the cameras, uninstall the app, reset the phone’s network settings, & reinstall the cameras. Problem is, the app has basically nothing to do with Arlo sending motion info: I can turn my phone off, and it should still work. I think the problem is at the hub-level, because I get BOTH push & emails notifications from the cameras, but SmartThings isn’t getting notified of motion. Several users have indicated the system WAS working, prior to Nov. 1st.

Arlo doesn’t communicate directly to the smartthings hub, it’s a cloud to cloud integration. In addition to turning your phone off, you should also be able to take your smartthings/Aeotec hub off power and have the integration still work.

So the problem should be in the “smartthings connector“ in the diagram I posted above. Somewhere in the communication between Arlo and smartthings. :thinking:

At this point, over 90% of smartthings customers don’t have a smartthings/Aeotec hub at all. They have a Samsung appliance or television and some Wi-Fi devices. But they still use the smartthings app and most integrations are cloud to cloud.

Arlo converted to using the new “schema“ architecture a few months ago. But that was just going from one cloud to cloud integration to a different cloud to cloud integration. No hub required on the smartthings side.

SmartThings Schema is the fastest method to connect your cloud devices to SmartThings using AWS Lambda or webhook endpoints.

Arlo has been making changes to this integration since it was introduced, mostly to add additional devices, and it looks like something they did a few weeks ago broke the motion integration. :disappointed_relieved:

I still don’t fully understand it, but that’s OK. Wherever the problem truly lies, Arlo support is hindering their own customers by providing useless solutions, like uninstalling & reinstalling. Several people have tried it, to no avail.

Eventually, it’ll get fixed, but later rather than sooner, I’m afraid. I’m not convinced anyone at Arlo even realizes there’s a problem.
There seems to be a huge disconnect between customers & higher-level support staff. Usually, when I call in to support, I get someone from out of the country, who’s just reading a script, and there’s no way to escalate a problem without wasting time by jumping through hoops.
This issue isn’t going to be solved by tweaking settings, or rebooting routers. As you say, Arlo broke something


Same here. I’ve used Arlo cameras as motion sensors reliably for several years, they stopped providing motion sensing to SmartThings about late December 2021. I’ve been trying all sorts of things to fix it, without sucess. Releived to find it’s not just me though!


Arlo support posted that they are aware of the issue and working on a fix. It’s in this thread:

No mention of a timeline for a fix.

1 Like

Case Update

Hi Ryan,

Good day!

This is Marelyn from Arlo Support Team. I would like to follow-up on your case. Please be informed that issue on Smartthings with Arlo should now be working. Kindly test and let us know if issue persists.

We look forward to hearing back from you.



Arlo Support

1 Like

It’s still not working for me… can anybody else confirm that this worked for them?

It stopped working after about 6 hours

This problem isn´t fixed yet, is it?

Still not fixed, as of this morning.

I can’t believe this still isn’t working. Do they know what changed? If so, can’t they roll back the changes or are they completely baffled on why it’s broken?

From the looks of it, it may be on Arlo’s end. The cloud to cloud integration is broken. Getting arlo to do anything is like getting your teeth pulled. It’s pushing a month now to getting these integrations fixed. Appairently, people are using Alexa to run automated routines since the Arlo to Alexa integrations are still working fine.

Just set up a routine in the Alexa app. For example
If arlo camera senses motion
Between 6pm and 6am
Turn on light
Wait 1 min
Turn off light.

This has been working the last few nights for me. Just make sure you are picking the right camera integration from arlo to alexa, not the arlo camera integrated to ST to Alexa. Its the one with a camera icon, not the switch icon.

Getting Arlo Support to admit anything, is damned-near impossible. I’ve offered my technical expertise as a software developer & beta-tester, using my smart-home as a test platform, but so far, they’ve ignored my offer.

There’s no question that it’s on Arlo’s end. Whether they’re actually doing anything about it, is unclear.

While I’d prefer to have my automations strictly on one platform (SmartThings), I’d be open to using Alexa to solve this issue, until Arlo gets their act together.

I cant even get that to work. Ive selected the proper camera too :frowning:

Just make sure your Alexa account is linked to arlo directly. Just go through all the cameras and one of those are bound to work. My issue was I saw duplicates of each camera I have installed. One camera (the Webcam icon) is the one directly linked to Alexa, the other listing (which has a switch icon) is the same camera integrated via arlo to ST to Alexa. Same thing with switches… I see duplicate listing of my switches too… one from tasmota to Alexa and the other is tasmota to ST to Alexa. Unfortunately but of them have a switch icon. It’s important that you have selected the one that is linked directly to Alexa and not the one that passes through ST otherwise you get a longer delay or a drop signal.

It’s a pain in the butt to have other automations but it is what it is at this point until they fix it. Another issue I found is after Alexa routine runs once, there’s a few min delay before it can run again. Aside from that, seems to work for a several nights now

Hope this helps.

Reading the Arlo forums, it appears that the problem might be the Smartthings platform rather than Arlo. Interesting.

Does anyone heard something from Arlo/Smartthings about this topic? It´s very quite here…