Danalock 125 BTZE


I wonder if you can help.

I’ve got a Danalock V125 door lock which is working well when used with it’s own app, however, I would like to connect it to my SmartThings setup but having some issues.

I’ve gone into the IDE and added a new device with the type being Danalock. However, no matter what I do, I can’t get smartthings to connect to it.

I initially tried to pair it using the app and holding down the button for 2 beeps, but it never used to find it. That’s the reason why I ended up going down the route of using the IDE.

Any help appreciated.



You need to have the lock very close (sitting on top of) the hub.

When you pair, it will be recognised as a generic z-wave lock and report the battery level as well.

You don’t need to go into the IDE and assign any DTH to it.

When I originally tried to set mine up, I made the mistake of pairing it when it was installed on the door, and it wasn’t quite right, so I excluded (important) and removed the danalock to place on top of the hub, re-paired and it was fine.

Its been up and working on ST for about 3 months plus, without a problem.




Thanks for the reply. [:blush:]

I’ve taken the lock off and put it directly on the hub, however, no matter what I try, when I try and exclude the device via the SmartThings app, I don’t get a prompt to say that the lock has been excluded successfully. Could it be a duff lock? Mega infuriating!

Any help, appreciated [:blush:]



Are you sure you have an EU and not a US version? They have different ZWave frequencies.


Will check tonight when I get back.

Thanks for your comments.

Even though it doesn’t report a successful exclusion, have you tried re-pairing ??

Zwave is certainly fickle, but it’s unlikely to be faulty, as a single chip does both Bluetooth and zwave - therefore if one works, so will the other.

Reboot, retry in all combinations - and read/re-read the manual

Shaun Reinson


Not sure if I’m being blind, but find attached a close up of the chip in the lock. Can’t see EU anywhere…

I was doing the exclusion via the app, going to the hub, and general app exclusion under z-wave utilities. When I try and add it in the ‘add things’ option, it never appears, no matter how many beeps I hold it down for. There are definitely no double beeps after holding the button down for two. But there are beeps after holding the button down for three.

Sorry for all the noob-like, questions. Didn’t think I’d have this much of a headache after getting everything else in my house all connected up to SmartThings in half an hour!


Sorry, that’s what I meant. Two beeps.

I will try that in the morning before work.

Thanks again.

I think that’s the Bluetooth only version - no ZWave. What did the seller say?


Check out this image… if it is a ZW version, there will be a chip with a Z-Wave logo (see just below the EU+ around the 2:00 mark (upper right)


Thanks for that picture. Comparing the two, it is indeed not the z wave one.

I actually bought it direct from Amazon. It’s going back to them.

Thanks for all your help. Really appreciate it.


1 Like