[DEPRECATED] Free Ecobee Suite, version: 1.5.*

askalexa
thermostat
smartapp_hvac
dth_hvac
project_hvac

(Barry) #1

As of July 29, 2018, this release has been superceded by release 1.6.00

Version 1.5.00 Released June 8, 2018

I am pleased to announce the general availability of version 1.5.00 of my Free Ecobee Suite.

While this is not a massive update, it does include some interesting new bits, mostly driven by user feedback and request. Most importantly, you can install this release directly on top of your existing release (note that there is 1 new file in this update - ecobee-suite-quiet-time.groovy).

Highlights of This Release

The most significant changes to 1.5.0 include:

  • Ecobee Suite Thermostat Device Handler now implements UI/API control and display of Humidifier and Dehumidifier (if configured/attached), with a newly reorganized section for the 5 adjustable parameters (heating & cooling setpoints, circulation time, desired humidifier and dehumidifier humidity targets).
  • New Ecobee Suite Quiet Time Helper will turn off fan, circulation, humidifiers, dehumidifiers, or the entire thermostat based on one (or more) switches (real or virtual). Useful to eliminate noise while watching movies, for example (at the expense of some - or all - climate control).
  • Ecobee Suite Smart Circulation Helper now integrates with new Quiet Time Helper so that circulation time isn’t adjusted if any of the Quiet Time switches is enabled.
  • Ecobee Suite Smart Mode Helper now supports mode changes based on internal temperatures as well
  • Ecobee Suite Smart Zones Helper now supports ‘sharing’ of heating/cooling from the Master Zone (thermostat) to one or more Slave Zones when the Slave Zone’s temperature is above/below the appropriate heating/cooling setpoint.

As always, the latest code, documentation and installation instructions can be found here:

Please provide bug reports, feedback, questions, requests, and even complaints here on this thread…

Change Log

Date File Version Changes
2018-06-20 Open Contacts v1.5.01 Fixed HVACoff() function - wasn’t turning HVAC off
2018-07-20 Open Contacts v1.5.03 Fixed qtOn crash in setup
2018-07-20 Quiet Mode v1.5.02 Fixed crash in initialization code

[DEPRECATED] Updated Ecobee Suite, v1.4.0 (Free)
New to automation and ST: controlling Ecobee?
[RELEASE] Free Ecobee Suite, version 1.6.1*
[DEPRECATED] Updated Ecobee Suite, v1.4.0 (Free)
Change Ecobee mode based on open/close sensor?
#2

I applied the updates and so far so good for the last hour thanks again…


Ecobee disconnecting from Smartthings
#3

Didn’t even realized I updated (from github) to 1.5 a couple of days ago, LOL … all is working as always :+1:


(Ben) #4

I’ve been having trouble with this since I updated. Previously I was a few versions behind but I don’t know which ones.
I have a contact rule setup to automatically turn off the hvac after they have been opened for 5 minutes. However it is not turning off.
I’ve been going through the code trying to troubleshoot this. It appears that the atomicState.thermSavedState never gets updated correctly, so it remains in an “off” state.

So starting with the windows closed and the thermostat in auto, I open a window
sensorOpened runs
atomicState.HVACModeState is on, so the conditions are skipped and turnOffHVAC() runs, which is what I would expect
doHVAC evaluates to true, quiet time skips, settings.hvacOff evaluates to true, seems good so far
tmpThermSavedState[tid].mode is “off” so the first condition is skipped, settings.adjustSetpoints is false so that section is skipped, then tmpThermSavedState[tid].mode != ‘off’ evaluates again and is still false so the third section is skipped.

I’m not sure what to check at this point. Thanks for your help in advance!


(Barry) #5

I suspect that line 355 of open-contacts is at fault. Can you please try changing:

if (tmpThermSavedState[tid].mode != 'off') {

to

if (therm.currentValue('thermostatMode') != 'off') {

I think that should solve the problem - please let me know either way… (I’m not able to test this out myself at the moment, sorry).

Update

This fix was released on 2018/06/20 as ecobee-suite-open-contacts.groovy, version 1.5.01


(Ben) #6

That worked! Thank you very much.


(Scutzi128) #7

When I go to add the “ecobee Suite Routines” from Myapps after I save it, should it not show up under SmartApps? Cause when I do that I am not seeing anything and therefor I can’t see what I have setup/edit it.


(Barry) #8

No, these are Child apps, and you shouldn’t be adding these from My Apps. - they won’t/don’t work that way.

These are all created and configured from within Ecobee Suite Manager, under the Helper SmartApps tab (as is the case with Smart Lighting, for example). Helps to keep things tidier in your Applications list…


(Scutzi128) #9

Thank you so much. I’m a noob to this so I’ve still got a lot of learning to do.


(YankeeJohnboy) #10

Just providing a data point, the open contacts app also stopped working after the 1.5 suite update, and still isn’t working even after the 1.5.01 contacts update :slightly_frowning_face:
I don’t have the troubleshooting skills of @kaiser_willi (hopefully he’s still working post-update).


(Barry) #11

@YankeeJohnboy -

Can you tell me more about what isn’t working?

Have you opened the existing Open Contact Helpers from within Ecobee Suite Manager, then re-saved them? I’m wondering if some new variable didn’t get initialized.

With a bit more info, I’m sure I can figure out what’s going on…


(Ben) #12

I did push the update from Github and it is working.

Just tested it using a contact smartapp that solely monitors a virtual open/close contact sensor and is set to turn on/off the HVAC without a delay. You should be able to do the same steps using an actual sensor if you don’t know how to create a virtual one, and you can switch the timeout to instant instead of 5 minutes that way you don’t have to wait.

I verified that the sensor being monitored was closed in the Smartthings app
I checked on the Ecobee smartthings device and it was in auto
I checked the Ecobee website and the thermostat was set to auto
I opened the virtual sensor then refreshed the ecobee website and it had changed to off
I closed the virtual sensor then refreshed the ecobee website and it was back in auto

Some information that would be helpful to troubleshoot this would be the results of testing like that, or answers to the questions below.
Is the problem reproducible?
What steps can you take to reproduce it?
what is the expected outcome?
what actually occurs?


(YankeeJohnboy) #13

When it failed the first time, I opened the helper and did a re-save, but that didn’t really help. At your suggestion today, I edited the name of the helper by a character and did a re-save, partial success! It’s now working to turn off the system on open contact. When the window was closed, it turned the system back on, but after a couple minutes, it was off again without notification (verified ST still sees all contacts closed)… so not sure what’s happening there.


(Barry) #14

Have a look at the Recently page for your thermostat after it shuts off again. Scroll back to where you see an entry that says something like Thermostat Mode changed to Auto by (Open Contacts Helper Name), and then see if there’s any info for the next Thermostat Mode changed to Off by …


(James Luongo) #15

Hi, first time using the Ecobee Suite. I was able to set it up just fine and install all the helper apps and get myself logged into the API. I’m having an issue with the contacts & switches helper when I tell it to use Quiet Time. I do have a quiet time helper app set up with a virtual switch. In the contacts & switches app, when I select Quiet Time it has me choose the button I’m using for Quiet Time. After I choose the button it takes me to the previous page, which is blank. It never does anything from there, I only have the option to go back to the previous page so my helper app is never created.

I’m using the SmartThings Classic app on Android.


(YankeeJohnboy) #16

I took your advice and tracked through the recently activity today when my wife opened and closed the windows to suit herself. While I think my initial issue was due to the glitch, after that point my issue was of my own doing. I turned on a dormant program that I had on the sidelines to reacquire the lost contacts v windows functionality, and forgot to turn it back off when the glitch was corrected. This was causing a double action condition, where the contacts app in the suite was doing the correct action based on the contacts activity, and the legacy program was flipping the switch again based on the same condition resulting in no net change. I put the old program back to sleep, hopefully that’ll be the end of it. Thank you both for your help to see my own mistake :face_with_symbols_over_mouth:


(micgo lee) #17

i have a problem, i m not able to connect the device. when i install Ecobee suite i did not uninstall the original app or remove the device. i tired removing both app and reinstall didn’t fix the problem

if i have to uninstall Ecobee suite just that i can use the original app again what will be the step ?

thx for any type of help


(Barry) #18

@micgo -

It looks like you just have not finished the installation. Are you unable to click “Done” at the top of that page (the red box is covering that option)? That should be the next step- it will exit Ecobee Suite Manager. Then when you re-enter Ecobee Suite Manager, you should see the options to select thermostats and sensors.

If you want to remove the Suite and start over again, you will need to go into the IDE, and on the “My Devices” page, delete any devices that have “ecobee_suite” in their Device Network ID. Then remove Ecobee Suite Manager, and start from the top.


#19

Is anyone seeing an issue with the Ecobee API staying connected? If I reconfigure it in the app it works for a day or so and then drops again. It’s causing polling to stop working and I am not able to control the ecobee from smartthings. Works fine from the ecobee app though.

Getting this error in the log over and over:

5:53:25 PM: info Updating API status with [apiConnected:full, lastPoll:Succeeded]
5:53:25 PM: error refreshAuthToken() - HttpResponseException occurred. Exception info: groovyx.net.http.HttpResponseException: Bad Request StatusCode: 400


(Barry) #20

This is not normal.

One thing to try - go into Ecobee Suite Manager, and re-login/reauthenticate to Ecobee.

Also, check to see if your SmartThings hub is going off-line at the same time.