D Day for latest and greatest. Is it fixed?

So my routines have been at best sporadically working. My scheduled task have been hit and miss for the past year. Today’s update is said to fix all of that. Will it?

I read the release notes again. It looks scheduling fixes may be limited in scope. I hope it is just downplaying the actual fix. We’ll have to wait and see.

1 Like

Yeah, me too, but it does sound like I need to put the wemo switch back to reboot the hub when things get out of whack…ha, ha, ha

1 Like

Yeah, they’ve messed things up real good this week.

My rules are AFU. Hell, when I create a new rule in RM a random old rule disappears! How awesome is that!

Let’s just get this fix done so I can go back to actually making my system work again.

I’m a huge supporter of ST, but honestly… I’m thinking about breaking out a wink hub just to take care of some of my simpler stuff.

1 Like

I just noticed that you can view your Smartapps logs in the IDE while under code view now.
It’s either a glitch or a half-baked new feature :smile:

1 Like

Let’s not all build up huge hopes that this firmware update will fix your hub and cook you breakfast, then all get disappointed when the eggs are a little undercooked.

ST has a lot of work to do, see this as progress but not the fix to end all fixes.

I really don’t want ST to cook my eggs, I prefer if they can just turn my lights on and off when I ask them to, so I can cook my own eggs :slight_smile:


Anyone wants to take a guess?

I still get “an unexptected error” has occurred about every time I hit a button. sooo

And today’s update did nothing to fix ‘the fix’ that was implemented a while ago and is now broken. Ridiculous that such basic principle of Home Automation as schedules, cannot be (timely) corrected.


Now I am depressed. Was hoping this fix would fix the issue with z-wave devices. It two to three days now and we are still at all z-wave devices are still not operable through the ST app (or Echo - but without the ST hub, that goes without saying). I am officially stopping purchasing of additional home automation devices; I am really starting to turn against ST; I now consider this pretty bad.

Please fill me in in what you have going on.
Post a link to another thread you are talking about this our you can pm me, I might be able to help ai just had a major issue that might be similar.

1 Like

Yep, still broken. The update and whatever happened Monday night set scheduling way back.

Bamarayne, I appreciate the offer. Not planning on playing with it more tonight. A brief summary is as follows:

  1. Zigbee devices seem to work fine.
  2. For 3 days now I have not been able to control any z-wave device.
    a) For outlets I can press the button on the app. It turns green, the event log show a command sent but device does not change state. Device does not physically activate.
    b) For garage relay I press the button on the app. It does not turn green, the event log sometimes show a commend sent in all cases device does not change state. Device does not physically activate.
  3. Reset hub several times. No positive effect.
  4. Reconnect outlet (more convenient to get to). No positive effect.
  5. Repair z wave network from api and it throws a lot of fail msg.
  6. Today’s update does not seem to make a difference.

Thanks for the offer and any advice is appreciated. The hub was only $100.00 but the outlets, bulbs (zigbee), and switches (have some 3 way and single z-wave switches) kinda add up fast. I have to decide how much to play with ST. Its not as much fun anymore.

Yesterday I opened a ticket with support and they helped me through this scheduled failures. Today all of my routines and smart lights fired as they should. If you don’t have an open ticket for it yet, I recommend you do.

I am patiently waiting for them to get back to me. My ticket for failed routines is over 2 months old. And still open, last time I checked, which is a couple of days ago. Can you share what they did to untangle your stuck schedules?

Ouch. I thought that old schedule problem of yours was fixed. I guess mine was easier for them since it just started this week. Here is the explanation they gave on the e-mail:

We took a quick look at things from our end and noticed that your SmartApp hadn’t re-scheduled itself properly - We went ahead and refreshed it from our end so it should be working fine now.

This is due to an issue on our end that is a top priority for our engineers to fix. This shouldn’t happen often, so keep an eye on that and let us know if it stops working again. You can also reschedule the Routine/SmartApp yourself by going into the SmartApp and saving it again.

That, and the good old hit done on the routines and SmartApps did the job.

Thanks for sharing. It has been an ongoing issue. Is fixed and then falls back. I had a good run for couple of weeks until recently. Hopefully tomorrow’s database update will clear everything and we start fresh. Time will tell…


1 Like

mine was online the whole window… didn’t even attempt an update… what is up with that?

I really hope you’re right. I’m kind of tired of hoping that the daily hail mary enacted by ST will fix the myriad of issues (schedules failing, dumping errors constantly, etc.).

I am curious though. My scheduled jobs (those that did not use runIn, etc., but actually used schedule) had not failed for months. Why all of a sudden (as in this past Monday), did everything take a dump (ST upgrade?)? I hope they figure out what they broke. There I go again… hoping. Damn, I gotta stop that.