Thermostat problems (multiple brands) Nov 2022

Multiple reports coming in from different community members that thermostats that worked just fine through October 2022 have now stopped working.

There have been multiple updates in the last few weeks, so I’m not sure which are relevant.

I’m just sticking this topic here to try and consolidate the reports.

If you are having this problem, please report it through the official support channel as well, that’s the best way to get resources assigned to working on it.

You should be able to open your app and find a Help link there. If not, you can try the support page:

Zigbee models reported so far:

Zwave models reported so far:


Stelpro (this may be a different problem)

@nayelyz @andresg

I am having an issue also with a Z-Wave CT-101 which worked fine until recently. I can use the Z-Wave Thermostat device handler to control the temperature up and down but creating scenes or routines do no do anything when they run. It is also missing the battery percentage. Using the CT100 Thermostat device handler always fails trying to increase or decrease the temperature (screenshot attached showing the error). This device handler had worked fine since 2018 when I installed the thermostat.

I tried to look at the other CT101 thermostat reported issue but the link doesn’t work. I had previously posted mine at CT101 Z-Wave Thermostat no longer working for routines (Nov 2022)

1 Like

Hi, everyone.

We are looking into this issue with the Engineering team and they have asked for Hub logs. So, everyone facing this issue, please follow these steps and DM me when you are done:

  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below “send hub logs”

And please let us know which Samsung Account you’re using and if you have more than one Hub, the name of the one where the device is paired.


Sent logs to you, @andresg. Unfortunately I cannot DM you because I am a new user to this forum.

The Samsung account used is: jason@col*****.net

None of my GoControl thermostats have been working properly since the end of October (worked flawlessly in 2 locations for last 5+ years). Not to mention several other devices that I’ve reported to support. GC-TBZ48 product code. These used to require custom DTH in groovy, which I’ve deleted.

This Groovy->Edge migration is a disaster.

I’m also having this issue with a Centralite Pearl Thermostat. I can control the operating mode and (nonexistent) fan state, and if I change the temperature on the thermostat it shows immediately in the app, but if I try to change the temperature from the app or from an automation, it fails most of the time (not all the time). The error I get is “A network or server error occurred. Try again later.”

I tried removing and re-adding the thermostat to my network and factory resetting the unit, but the problem remains the same. Obviously communication with the device is working, so this seems pretty clear that it’s a driver bug.


When I click on IDE, I get this very generic Beta version dashboard. None of my hubs have a “view utilities” option or “send hub logs” or anything remotely resembling that. It is a very simplified interface.

That is not the IDE. To reach the IDE, visit this URL SmartThings. Add a little smartness to your things.

Keep in mind, the IDE (as it is currently) is minimally useful and will be fully discontinued by 12/30/22. No word yet on if a replacement is in the works.

1 Like

@andresg are there any updates on the problem with the CT101 Thermostat? I know I and several others opened cases and sent logs but have not heard anything regarding the issue. I am also trying to determine how much worse the problem is going to be when the older drivers are removed and the new drivers are pushed out? I can’t get my device to install the CT101 using the new driver. It never finds my device.

Thanks for any help you can provide.


I just noticed that my thermostat seems to be working better today. I checked and the app now shows it’s on a driver version 2022-12-20.


I seem to have spoken too soon. It was working reliably, but now it’s not again.

All mine continue to be non-functional from the app. I can see their status, and attempt to change, but get the same network server error when I try. They can change through automations.

Im getting a message in the app for the thermostat that the device hasn’t updated all of its status information yet and to check back later. I also get a server, network error with thermostat only.
I did a modem/router reset, reset the thermostat, cleared cache from smarthings and no luck.
I finally called smarthings and apparetly they are going to look into this because many users are experiencing the same. This is frustrating.

Definitely frustrating. :rage:

I’ve moved your post to the existing thread on this issue. You can go back up to the top if you want to read what other people have reported. :thinking:

This message is from smarthings after I reached out. I clicked on IDE link and it takes me to smarthings groovy ide. It then says I don’t have any device handler. I understand what the tech support wants me to do but I have no idea how to get to what he is asking which is View Hub Utilities because it does not take me there.


That sounds like a front line support person reading off of an old script. I don’t think you can do that kind of logging anymore since the IDE started shutting down last month. :thinking:

@Automated_House or one of the other people who have done deep dives into the system might know how you send hub logs now. If it’s possible, I suspect it’s done through the app, but since the app isn’t easily voice navigable, I’m not very familiar with it anymore. :disappointed_relieved:

I almost feel like abandoning smarthings altogether and buy a different hub system that controls all my devices. Customer service is not so great when they provide old information and the smarthings employees aren’t onboard with the new.


This is different however, it says SmartThings. Will you be in the same boat?

Yes, that’s the same hardware and software as the smartthings brand V3, just a different box. So it will have the same issues as the V3.

About a year ago, Samsung decided to stop producing home automation hardware and they signed a partnership deal with Aeotec. Although now that’s changed again, and they are going to come out with a new Samsung brand minihub, which will not have zwave. But that one, called “the station“ won’t be out until later this year.

1 Like

I’m having issues with a Centralite Pearl thermostat that shows it is using the edge driver on V2 hub. Automation temperature changes mostly don’t work. About one in 20 manual changes by the app will stick. I had to change automations to turn the heat mode to off instead of dropping the heating temp. Very frustrating especially with the natural gas prices spiking this month.