CT100 Thermostat - No Mate Button

I recently purchased a used CT100. Unfortunately, the mate button and radio/antenna icon do not show. They’ve disappeared completely, meaning there is no way for me to begin to pair it.

When I press the reset button, it briefly does the screen test and I can see it pop up (along with all the other icons), but it goes away after the screen test. In no menu does it display or is selectable. I’ve tried many different reset methods without success.

Someone had the same issue from a post on another forum many years ago, but was resolved with multiple (4) hard resets. I’ve tried all the reset methods I can find. I’m always open to trying more options.

Any ideas?

EDIT/RESOLVED: The manufacturer said it was broken and needed to be replaced.

Some of these models have a simple mode. I believe that option disappears when you set the thermostat to advanced mode. Try switching it back to simple mode from the Menu settings on the thermostat. The reset button doesn’t do a hard reset on the thermostat, only a soft reset.

To do a factory reset try these steps:

Thanks for the reply!
I have performed many soft resets.
When I attempted factory reset, nothing happened by holding the lower left corner. In Off mode, I did press and hold the center of the screen for 5 seconds; it displayed the firmware (F 1.07) in the top left corner and “00” in the center of the screen, then returned to Off mode after about 30 seconds. I’ve done this several times in the past without success.
Unfortunately, the Mate icon is still missing (as is the antenna and radio icons).
Any other thoughts?

Just a quick note the Mate button shows up after you press the MENU button, not on the main screen. If it still isn’t showing up then wondering if the zwave module is faulty

Correct. It still doesn’t show up.
I hear you’re the best, so if you can’t solve it, I don’t know who can!

My guess is something got damaged in the shipping.

Any other thoughts, friends?

Try this

To do a factory reset on the CT101:
Put CT101or CT100in off position - by pressing mode button until “OFF” show in top left of screen
Next press the menu button
Next press and hold the center of the screen for about 5 sec or until the screen changes then release
You will see 2 arrows first press the up arrow and wait for the count down
Then press the down arrow and wait for the count down
All parameter values will be restored to defaults, and a message is sent to any radio module installed to instruct the module to restore it’s own default values… The thermostat then resets itself.
Press the house to get back to the main screen

Sadly, I’ve done that a few times too without success.

I’m beginning to think the darn thing is just broken…

I’m super appreciative of your help!