Cree Connected Bulbs Not Local Devices


(Scott) #1

I just noticed that my Cree Connected bulbs are not on the local device list. Does anyone else have these and are you seeing the same thing?
https://graph.api.smartthings.com/localDevice/list?offset=20&max=10

I’m going to setup a couple lamps and would like to standardize on devices that will work in locally processed scenarios. I’m tempted to dump the Cree Connected bulbs for standard LED’s with GE smart outlets.


(Fastcarve) #2

Yes, I’m seeing the same thing.


(Max) #3

So what bulbs are the best to use? GE links are trash, Crees are great but dont run local. Hue lux bulbs?


(Scott) #4

I would be curious to know what the other options are as well.


(Walter Edwards) #5

@Slagle can we get Cree bulbs to run local? I have a nuber of them and would like to see this. Thanks!!!


(Mike) #6

we know that only smartapp running local is Smart Lighting

@slagle is somewhere list of local running devices?
I was thinking that everything sold by smartthings shop is able to run local
but zigbee GE dimmers https://shop.smartthings.com/#!/products/ge-in-wall-smart-dimmer-switch are not showing in my https://graph.api.smartthings.com/localDevice/list

yet if i use smartthings device type for IRIS motion and IRIS outlet I can see it listed local and it works with smart lighting


(Ray) #7

Hey guys, just try using the GE link bulb device type. I don’t have Cree bulbs but I am using GE device type on a bunch of Ecosmart bulbs and they work locally. I was using the Cree device type but switched to GE because of this.


(Scott) #8

Thanks, I’ll give it a whirl.


(Fastcarve) #9

I gave this a try and the bulbs quit working until I changed the device type back to Cree bulbs.


(Ray) #10

Too bad it doesn’t work with GE link. It’s the only local bulb device type I know of and I don’t have Cree bulb to try out before posting. Sorry about that.


(Scott) #11

Same results on my side as well.


(Brian J Lambert) #12

It’s been about a month now and I just migrated to v2. The Cree Connected bulb continues to be a cloud only device. Is there any reason for it? Even the GE Link bulbs run locally.


(Fastcarve) #13

I wrote to support about a month ago asking about this. Here’s the response I received:

“At this time the Cree bulbs are not enabled to run on the local app engine. As our developers work to add more devices and SmartApps to this service, I’m sure this will be on the list as it is an officially supported device.”


(Brian J Lambert) #14

Thanks for reaching out to support. I also notice my Osram Lightify bulbs are not local either. Hopefully all these get added in the near future.


(Scott) #15

Thanks for the update! Sure appreciate it. Just picked up a couple more of them for the living room. Figured consistency is more important than anything at this point.


(Kevin) #16

[quote=“fastcarve, post:13, topic:29717”]
At this time the Cree bulbs are not enabled to run on the local app engine.
[/quote]You can get the Cree bulbs to run locally if you use the device type “SmartPower Dimming Outlet”. The light appears to turn on/off and dim fine, but I’m not sure if using an outlet device type for a bulb will cause other problems.


(Bernie H) #17

This also works for GE Link. Bulbs seem to work fine and showing up on the local device list and Smart Lighting as running Local app. :grin:


(Benji) #18

GE Links run locally with the default device type.


(Bernie H) #19

Hmm Mine were not. I will have to see what device handler they were using. It said GE Link. Wonder if I had an old Handler?


(Kevin) #20

[quote=“celblazer, post:19, topic:29717”]
Wonder if I had an old Handler?[/quote]
I think the only way you could have an old DH is if when you got the bulb, the DH wasn’t available yet so you installed a custom one through the IDE. The one that runs locally is called “GE Link Bulb”.