Couldn't add device (Network or Server Error Occurred) - Netatmo & Rachio

Newbie here! I’ve been able to connect my V3 Hub using the new SmartThings Andriod App to both Google Assistant and through that to a Harmony Hub (as well as local LAN Devices and Sensors), but when I try to add either my Netatmo or Rachio I get the error msg. Any suggestions?

Do you have any special firewall or spam blockers running?

Hi Jimmy,
I have a Unifi UDM Pro running as the Router/GW and have tried turning OFF “Threat Mgt” as a test but it did not help. I also don’t see any Unifi Alerts when I try to Add the devices. I also tried adding the devices from my phone when it was connected only of 4G instead of WiFi but same thing.

1 Like

Try uninstalling the app, then reinstall, then reboot your mobile device :slight_smile:

Thanks jkp - Done - but same issue.

Initially, I did get a bit further. After successfully adding the Google Assistant, I tried to add the Rachio and got to the part where you have to enter in the Username/Password for the Rachio account but it crashed at that point. Ever since I now get the error within a few seconds of selecting the device to add. I thought it may have been server related so I left it overnight but it is still the same today.

Doubtful it is the unifi IPS - I have it also.

No other ad/spam blockers on your home network such as adguard? Vpn?

Nope, just the Unifi IPS. It still could be related, as I have previously had to turn it off IPS for my son to update/install/config Stream but apart from that never had IPS block any other item.

Ok last question - you are using the built in integrations and not any 3rd party custom apps?

I added a script for direct control of my Diakin AC Wifi models.

So all up I have so far, just Aeotec Multipurpsoe Sensor, SmartThings Multipurpose Sensor, SmartThings Button, and the Daikin WiFi Split System.

I’m also running a Domoticz setup that is connected to the Netatmo but not the Rachio (looking to see if SmartThings can replace or augment my current Domoticz setup)… but I don’t think the Domoticz setup should impact the adding of devices…

I’m stumped. If no one has suggestions, you may want to contact ST support. The best method is to call and speak directly with them if you are in a region where calling is available.

Lets see how support goes in Australia. One thing I described poorly, is the Harmony Hub is not connected to the Hub but to Google Assistant that I connected to the Hub

Have you tried on a totally different device? Another phone or tablet? It may be a region problem too.

I’ve not tried other devices (yet) but the Region may be an issues, as there is a txt msg above the Netatmo and Rachio Icon that says “Devices available in other countries”

Nope - I get the same msg for my Ecobee and it connects through just fine.

Also tried on a Tablet - same issue

I tried adding bunch of different “devices” (that I don’t have) and the process seemed to work with it progressing to the credentials page for each of them (as I don’t have them I just backed out at that point).

To check if it is just me, could I ask someone to try to add a Netatmo and/or Rachio device and see if you get through to the credentials stage?


SAame thing for me for racchio. I am sure it is not a firewall issue, as i get the thing from bothe home wifi, 4G and at work.

I was able to connect to rachio without problem. (US based, using the new app)

@jody.albritton or @Brad_ST is there a known issue with regions/shards outside of the USA not being able to connect to ST Schema based integrations?