Control of my Leviton WiFi switches stopped working yesterday

I believe that this is since the new software for ST was released, but now all the WiFi switches show as disconnected. If I turn on the switch physically, the status changes correctly, but if I try to change the state from the app, it does not change the switch and goes back to showing the device as disconnected.

The My Leviton app still works correctly.

Has anyone else seen this? Is it a bug in the new ST software? Is there a work around?

Which mobile app are you using? SmartThings Classic or SmartThing (Samsung Connect)?

I have been using the classic app. reading through the forum, I discovered the new one and tried that. Different UI, of course, but the same behavior. Toggling the switch shows the correct state, but can’t control from the app

Just wondering if you figured this out as I am having the same problem all of my leviton wifi switches show unavailable in the classic and disconnected in the connect app but work fine with the leviton app

My symptoms are slightly different. In the classic app a switch will show “OFF”. If I press the button in the app, it changes to “TURNING ON”, but does not turn on the switch. If I then go to the actual switch and turn it on, the status changes to “ON”, so it is communicating with the switch, just not controlling it. And, of course, the scheduled events do not work either.

The Hub says online since 4/12/18 and firmware 000.021.00012. The behavior is all since the 4/12 date.

Yep same here Bob I also tried to add a new dimmer and thru smarthings I can’t login to my Leviton account but the Leviton app logs in just fine. Mine also stopped working on 4/12 after the new firmware update.

Ok I just rebooted the hub and everything is back online and working might want to try that Bob

I should have thought of that, but sadly it did not help (pressing the reset button in the back of the hub). Same symptoms.

Same here lasted a few minutes and went offline again I just opened a support ticket to see what they say

Same thing here. Leviton app works fine, Smartthings doesn’t work to access the switches. Anyone have a workaround?

The support page says it will only work with the classic app.

I would suggest getting in touch with support and see what they say. Make sure they know you have the Wi-Fi version, not the Z wave version.

Thanks for finding that bit in the support pages. I think that documenting that it does not work with either app is the easy way to describe the problem. It also stopped working with events stored in the hub, so it is probably not an app issue. I also filed a support request. New firmware releases often result in a bunch of trouble tickets, so…

1 Like

I’m having the same issue. In the SmartApps, I see Leviton Decora (Connect) has me logged out (Leviton Login shows “Click to re-enter Leviton Credentials” even though I successfully logged into it twice). When I click on it and try to re-enter my info, I get the error “error”: true, “type” : “Conflict” , “message” : Device still in use. Remove from any SmartApps or Dashboards, then try again".

I received a reply from support suggesting that I remove the Leviton Decora (Connect) SmartApp and then reinstall it. That should pull in all the switches from the Leviton account. I would have to re associate the switches with their automations. I will keep you posted.

Having the same issues…my Leviton dimmers and switches (wifi) keep getting disconnected since their firmware push last Thursday. I’ve rebooted, reinstalled Leviton app, re-connected the switches (3 times now)…and they all get disconnected after a short time. Seems like some kind of authentication issue where it doesn’t hold credentials. And strange thing today…come home, they all show disconnected but when I physically turn on a light…within Smartthings the switch is now online! Called support…they are “researching” the issue but no ETA. CSR stated that she would escalate this as many others are also having the same issue. BTW…the new app sucks! Long live classic!!!

Tracking, same exact issue as Bob. Super pissed as most of my devices are WiFi.

Got this response from tech support:

Hello Mike,

Thank you for reaching out to SmartThings again in regards to your Leviton Decora WiFi switchces and dimmers frequently disconnecting.

We are escalating this ticket in order to further investigate. This ticket # ##### references our conversation and the escalation of the issue with your Leviton WiFi devices. Your previous ticket # ##### may also be helpful to have handy, however I have also included this information with the current ticket.

I am terribly sorry for the understandable frustration that you are currently experiencing with the Hub and with the new SmartThings app. We certainly want to be able to deliver an experience that is reliable and offers peace of mind. Clearly, with your current situation, that is not the case. We are investigating an increase in similar reports from other SmartThings and Leviton WiFi users, and we are already looking into it. We will reach out once we have more information.

Your patience and assistance are tremendously appreciated. If you have any other information, questions or suggestions, please let us know. We are here to help.

Kind regards,

Michelle B

Technical Support Agent

1 Like

Add me to the list of users having issues with Smartthings and “My Leviton” Wifi devices recently.

Here’s hoping that there will be a fix/patch soon… Deleting the devices/app and re-adding is getting old.

1 Like

I am also in this situation. Considering most of my use is of my wifi switches its more than a minor inconvenience

Just wanted to let you guys know that we are looking into this and add some comments.

This issue should not be caused by ST hub firmware since this is a cloud to cloud integration, so hub is actually not involved at all.

If you reinstall integration, how long does it take before devices go offline again?