Connection to Router

Hi, I’m just wondering if I need to have the Smartthings Hub connected to my router through Ethernet, or if there’s a way to connect it wirelessly?

I initially installed it and it worked fine through Ethernet, but I’d like to connect it through wi-fi. So I removed the device and tried to add it as ‘Samsung SmartThings Wifi’ instead - is this what I’m supposed to do?

Anyway, I tried doing that and it won’t flash red/green during the setup anymore, so I did a reset using the button at the back (using a sharp object), but then the app can’t find the hub.

Can someone please point me in the right direction?
Thank you

You’ll have to be more specific when describing the version of your hub. V2 only connects via Ethernet while V3 offers WiFi.

https://justclickappliances.com/smartthings-v2-vs-v3-differences-explained/

SmartThings v2 vs. v3 — Differences

Difference #1: Connectivity to Router – One big change that SmartThings made with the v3 model is the way that the device connects to your router. With the v2 model, you’ll need to connect the hub to your router via the Ethernet port — necessitating a hardwired connection.

With the v3, however, SmartThings upgraded the experience and now supports connection to your router via WiFi.

The sticker at the bottom of the device has ‘V3P15’ at the end of the M/N line, does that mean it’s V3?

When I plug in the power cable, it gives me a solid green light. But if I use a pin to reset it (without holding it for too long), it starts blinking green/red. I then follow the instructions on the app (scan the QR code), type in my wifi information, but it keeps giving me an error that only says ‘Registration Failed.’ If I retry, the same thing keeps happening.

Thanks so much for your help

I don’t own the product but did research and it appears to be V3 and thus have WiFi. Below is a link to the product describing features and specs and includes a download of the manual. I included the manual PDF link as well below.

https://www.z-wave.com/shop-z-wave-smart-home-products/smart-hubs-samsung-samsung-smartthings-hub-3rd-generation

Try the instructions near the bottom of this page for “Change a SmartThings Hub’s Wi-Fi network”

The problem is that I removed the device (I thought I had to in order to enable connection through wifi), and now I can’t add it again because the registration fails every time. Do you have any idea why this happens?

Edit: sorry about that guys, I was doing the reset wrong. Will try to reset and re-add the hub as a device. I appreciate your help