Connect location services driving me crazy. BRING BACK CLASSIC

I am NOT open to using 360. I used to have a siren that when everyone was away and ST seen motion on any sensor … Alarm would sound. Obviously that’s a no go now with every single time someone comes home the a
Siren going off.

I’ve deleted all my automations and tried to add them back… lights, door locks , thermostats, garage doors. Well now I’ve got my garage door randomly opening at 2am. My lights and dead bolts will randomly think we are away and turn off/ lock. CONNECT has ruined SmartThings.

Uninstall the classic app, it is known to cause location issues whn both apps are installed

I lost all my Location Services as soon as I deleted the old app. I have tried everything I can think of for days and still cannot get Smartthings to recognize my iPhone as a presence sensor. Please address this issue, Smartthings.

I deleted the classic app a few weeks ago. Here is my front door randomly unlocking, locking, unlocking, locking, unlocking… I’ve even reset my home location and uninstalled all users other than me. One of the biggest issues is I can’t tell if I’m “home” or “away” my phone doesn’t show up as a presence sensor and it doesn’t show up what state I’m in… since sometimes it’s 4-5 hours behind.

Make no sense that classic worked fine then they force everyone to move to connect… delete all the phone presence sensors/ delete where you can see what status your in… then then the presence sensor (phone) that control everything takes 5 mins to update or 6 hours to update from away/ present. No rhyme or reason… but opening garage doors/ unlocking doors/ turning off instant hot water heater IS completely unacceptable … somewhere around 1/3 of my outlets won’t work if no one is home (micro switches) or at least if ST’s thinks no one is home. All this crap worked fine with classic

Ok a few more things for you to try. The old app had SHM which is a different app than STHM. Download thenclassic app and make sure the SHM has no users anf is not being used by anything. Then delete classic again. Then on the new app. Create a virtual switch and make automations for each user do that you can display their status. At the location settings increase the location radius a bit and set the location pin again. Also make sure that the new app does not have an automation for the locak based on triggers other than the location which could lock unlock the lock automaticaly.

Not sure why but about a month ago, my ST Classic app started saying “opps, something went wrong!” I assumed that ST discontinued the classic app so I deleted it.

Ive added it back and just get an annoying pop up every few seconds, but it works. I deleted all the automations that wasn’t transferred. I’ve moved my geofencing up to 300m now, there is just a 5-10 min lag in the location services. I also removed my garage DH and smart app then reinstalled it (MyQ Lite- with sensor by brbeaird) which will let me open the door but not close it. I now have the classic app which it does work/show status/battery and has a toggle for up/down. The new app has a button that I can open it… doesn’t work to close it.

I did the same with my locks (removed/ re-installed) and now It wont send any notifications but the install took several attempts and about an hour ( DH by ethayer)

On the my 2 schlage locks and all my lights/ outlets/ microswitches … I deleted the SmartApps/smart lighting/ automations — all lights off when away… Then I created a few automations that waits 5 minutes after I leave/ wife leaves/ everyone away to turn off certain lights/ switches and such then lock the doors . I removed all of the unlocking of the doors. Ive only had all this set up since yesterday, but I haven’t gotten and random things turning or locking on/off. Some how the garage door auto opening wont work because of the delay… then I get a bunch of alerts-- Motion/door active… So not ready for to set the siren back up

I would defiantly be happier using the classic app that actually works

My main problem is when I leave my “home zone”, my phone doesn’t kick into Away Mode as per the Automation I set up. However, when I return, it does kick into the Home Mode, and I get the notification. It’s so weird. It doesn’t detect me leaving but i detects me returning. All my automation for returning or being home works, but my one automation when I leave the home does not work.

1 Like

Im looking for a complete list (for CrossPoint) of the supported platforms… Looks like crosspoint is brand new and there are 83 post in their forum, I dont see a complete list anywhere. Do you know where I could find one?

So I bought a new iphone 12 (IOS 14.5.1) a few weeks ago and for the life of me I cant get my location services working with ST. Her’s works fine…opens garage door/ turns on lights/ unlocks door/ changes security modes ect ect. . But on my new phone, I couldn’t sign into the ST Classic app, so I deleted it. The new phone shows up as a " mobile presense “in the IDE without a hub assigned. I deleted my old phone and relabeled the new one so I would be sure that it shows up in IDE. At one point I assigned it to my home hub. Inside the app I have toggled * get your location from this phone” to off, then signed out, then deleted the app.

I reinstalled, signed back in , toggled on for the location and went to settings and made sure the location services were set to always and I have the it set to Always and when I check I have a purple hollow arrow beside the app which means that the app may receive my location under certain conditions. I think that means when I’m inside my geofence which is set to 1000 meters. Some apps have the solid purple arrow which means this app has recently used your location.

If I goto history within the app I only see 1 entry with the iphone 12 - “is away” a few days ago, In the IDE it appears to be correct and it shows 1 entry in the history of me leaving this morning. I deleted the app off the phone last night, so I think its correct.

Even though I wasn’t seeing my phone in the history and I don’t have classic anymore. In the app I created 2 automations of Both phones away, scene = Away. Then either phone home, Scene= home.
I already had the scenes Away = Change this location mode to away/ lock doors/ turn off certain devices. And home = change location to home.

But every morning If my wife leaves first, I start getting intrusion alerts when I get up and inside the app - manage location it shows the mode as Away. I can run the home scene … But then once I leave, it stays Home… But then on the IDE it shows Iphone 12 value = unoccupied. What am I missing??

I did the EXACT same thing, toggled the location off, signed out, deleted the app … re-installed. But I did the same thing on my wife’s phone. The newest app won’t let you toggle the phone on. And yes, I went back and made sure there are automations with the presence sensors. Now MY locations are working. But my wife’s are not working now and yes we are using different emails as we have been for years.


I need another Zwave/ zigbee automation controller.

I use other locations services/ geofencing for my thermostat and cameras. Type in the account, give app permissions, set max distance, type which phones do what, hit enter and it works for years.

What’s to point to home automation of your home/ away won’t work??

Same for me. Or random actuation. Sometimes it does kick into away, or sometimes not. Because you now can’t see the phone status (as a presence detector) any more. I don’t know if it’s a phone thing or ST glitch

I’m on Android 10 and I just keep having issues with multiple ‘phone has arrived home’ events randomly happening throughout the day when I haven’t left, it seems anytime the app queries presence it triggers another event (almost always when I start the app too, despite the app being set to never sleep etc).

All is setup correctly on my phone, location access always on, enhanced location with WiFi switched on, zero power saving applied etc, etc. I’ve also uninstalled/re-installed the app multiple times but that hasn’t solved the issue either. It was affecting my wife’s iPhone too, but that seems to have stopped as of late…

I’ve also setup the app and added my WiFi network in the hope that would help, but it doesn’t seem to make any difference.

Genuinely no idea, classic worked, when I initially switched over everything seemed to work, I didn’t change anything, then it just started playing up.

So when you look in the IDE or the API are you seeing just the one mobile presence device for your phone and is it what the IDE refers to as the ‘placeholder’ type? Just trying to establish there isn’t an old DTH based presence device loitering.

What does the device event history actually show for the mobile presence device (again either in the IDE or the API)? Are there actually changes from ‘not present’ to ‘present’ appearing, or just ‘present’ events without intervening ‘not present’, or absolutely nothing to coincide with the Automations activating (I’m assuming that is the issue)?

Since the newest iOS app (v 1.6.68), which popped up in the last 2 weeks… I’ve had to deleted all the automations and “mobile presence sensors”. When I add the phones back, they show up in IDE as “Placeholders” in the type. However I havent found anywhere in the app (history) or IDE (device/ list events) that anything shows up. In the app, I see in the notifications tab the automations which are triggered by my phones geofencing… Such as "One or both phones home- Scene changed to home and alarm armed (stay). However its not showing all of them. Then my phone is doing 95% or better and hers is 25% at best.

And then eventhough, I will see the the notifications that alarm = Armed (stay) which shouldn’t send any notifications for motion or door triggers inside the house does, until I opened smartthings and re-run the automation or manually switch the Alarm to (stay)

Try looking in IDE > Locations > devices for any phone presence that may have a device type other than placeholder… i.e. mobile presence sensor. Some users mentIoned they did not see it in IDE > Devices but did under the locations section. If you do find something… don’t delete it immediately. First remove them from any automations set to use their presence, disable get location from their phone for that user, log them out of the app. Then you can remove the rogue presence sensor for them.

Log them back in, enable get location and set up the automations again.


Thanks for the response. Just one device in the IDE and it was listed as a ‘placeholder’ device… I’ve now changed it to mobile presence? Is that the right thing to do?

Will checkout logs etc tomorrow, it after midnight here in the UK and I’ve only just seen this. Many thanks again.

They don’t even show up in logging. When the wife comes home, should open that garage door, switch the security status to armed (stay), turn on an outlet that controls a sinkerator instant hot water unit and a micro switch that turns the outlets on in her walk-in closet (has a vanity/ island in it).

Today she opens the garage door manually at 5:56pm … alarm switches to stay (or never armed when I left) but the hotwater / outlets switch on. Photos from app.

Then I left logging on

Then here is the device, her iphone is highlight

Then when I goto the device - list events … nothing is there but obviously her phone arriving triggered the outlets

And nothing in the notification tab since yesterday.

Wonder if we have the same thing happening? Cause last couple days Im getting weird triggering of my ‘leaving home’ ‘automation’ but i see nothing in the IDE, and my mode isnt changing either. But all my interior lights and outlets are being switched off when they shouldnt. I see nothing in the IDE from my phone or hardly anything else. Only clue I have is that my phone was “Last Activity At” at the exact time that my outlet just turned off

Not the right thing to do… it needs to be placeholder.

Look in IDE > Locations > devices for any presence sensors with mobile presence as the device type and not the one you changed.