Confirmed: Trane TZEMT500... Thermostat Works with ST

This post is to confirm that the Trane TZEMT500BB32MAA Thermostat (based around the RCS TZ-45) is in fact compatible with Smartthings.

I installed this tstat today and added it to my Home ST hub. It was not easy to add for some reason. Had to make multiple attempts but got it done.

Took several minutes for the data to populate the tstat tile but it eventually came in. Then later, the “actual” temp on the app tile started climbing It went up to 100. I looked at the Trane tstat on the wall it it was not running away. I killed the app (Android OS) and relaunched it. No change. I power-cycled my hub. Bingo! Solved.

I began trying to add some mode change apps and had trouble in the configuration. I looked in the app store and found the app had just been updated again. Woot! And that solved the configuration issue I was having. Got some mode change apps all set.

Then I tried to add the tstat to the Dashboard but cannot figure out how. I submitted a HelpDesk ticket on this. Turning another ticket in for “current” temp appearing on tile as 100 degrees when it’s not 100 degrees. This is intermittent. Sometimes killing and relaunching the app fixes this.

Later, I played with Hello Home. I tweaked Good Morning! and Good Night!.

Good Night! is set to run automatically at 11 pm and it will turn off some lights and set the hub’s mode to Night. Then I’ve configured an instance of the Keep Me Cozy app that only fires in Night mode that adjusts our nighttime HVAC setpoints.

Good Morning! is configured to run automatically at 6 am and it will set the hub’s mode to Home. Then I’ve configured another instance of the Keep Me Cozy app that only fires in Home mode that adjusts our daytime HVAC setpoints.

We’ll see how this all works! :slight_smile:

Tried to copy my personal blog post in her but got some malformed formatting.

If anyone is looking for inspiration in a no-coding required example of adding a zwave thermostat to ST and some automatic mode changes and some automatic HVAC setpoint changes based on mode, take a look at my blog post: