Changing icons - doesn't stick?

Hey guys, I did a quick forum search and didn’t really see this mentioned, so forgive me if it’s already been addressed.

Anyways, my problem is that when I set new icons for certain devices (switches in particular, including a smart plug and several Hue bulbs that show up as switches) the icons don’t stick. I mean that when i exit the preferences, the icon has not changed. This is hit or miss - I have one bulb who’s icon is fine, the others just revert back to the outlet icon. Sometimes the switches show the right icon when off, and then when turned on the icon goes back to the outlet. Super annoying since I have to shake my phone to see what’s what, or use trial and error.

I know I can make groups, but I’d rather see all my things at once and know exactly what they are, instead of navigating in and out of group menus to get to different devices. Plus, within a group I suspect the problem would persist (not being able to tell the difference between switches at a glance).

Any ideas?



Did it start happening in the past couple of days? I reported an issue with Support (@tyler has been diligently following up with me every hr. :)) whereby my icons disappeared for couple of GE outdoor modules (along with incorrect state in things versus lights & switches). Worked perfectly fine for me today though.

I’ve experienced it too, but only noticed this exact problem within the last week or so. I hadn’t gotten around to perusing the forums or complaining to Support yet.

Same here. Been going on for the last weekish.

I have this issue, but with recently paired GE Bulbs. I have 2 bulbs, both with couch icons. When one of the bulbs is off, then it shows the couch icon (when its on it shows the bulb). The other bulb shows the couch icon when off, but goes to the bulb icon when on. Weird. Glad to know I’m not the only one having an issue… Just emailed support.

I have this problem with the SmartThings App on my Windows Phone. If I change the icons on an iPhone the change takes, and is reflected on the Windows Phone the next time I open the App.

It’s been like this for me since I installed my hue bulbs (maybe a week ago?) It’s strange, it worked perfectly for one bulb (the icon is correctly set to the one I chose, both when the light is on and off) but for the other two, no luck.

Hey Johnessey, thanks for emailing support - looking forward to hearing what they have to say!


This email arrived a few minutes ago:

“Yes we are aware of this. We’ve gotten a few reports. We’ve let QA know, though as it doesn’t actually change functionality or impact performance, it is likely that other issues will be prioritized above it. Though I’d expect it to be resolved by the next build they work on and release.”

Missng or incorrect icon is a minor annoyance but incorrect status in the dashboard is definitely not. It will throw most people offguard and may cause some people to drive back home.

Yeah, both my contact sensors were reading as open earlier today, when I know they were not (verified by dropcam). Will have to investigate when I get home.

Go to your device tile in the mobile app and press “Activity” tile. Does the Activity Feed display correctly? When I had this exact problem, I had the spinning circle twitching continuously but not loading full event history. Then after a day or so the device just stopped responding and had to be Z-wave excluded and re-paired with all SmartApps needing to be setup again. More than a slight annoyance.

@Dlee – Yeah, the feed is looking good, real time, etc. No issues. But the problem you described, I had the same issue with a GE Appliance outlet. The exact same odd twitching… was weird. Anyways, I was able to fix it by unplugging the GE Appliance outlet from the wall, waiting 30 seconds (not sure that even matters), then plugging it back in… once I did that, the Activity Feed worked just fine, displayed real time information (and the icon actually seemed to truly state OFF/ON).

I’ve had the twitching / lack of Activity Feed issue happen before (with my GE Appliance modules), unplugging them from power, then plugging back in has fixed it for me every time.

So… you have this issue with a GE Appliance outlet?

Yes, but mine is hard hard wired. I guess I could turn off the circuit panel switch for 30 seconds if it happens again. I actually have several hardwired outlets from that 3-hour period last summer when Amazon sold them for $13. :smiley:. And I have some GE light switches as well. I think this is the first time I noticed the twitching spinning circle problem. It happened the same time the icon change did not update/showed different icon with on/off status. I had a host of issues and delays when reconfiguring a few outlets smartapps/timers/schedules on Sunday for xmas tree lights and other outdoor light strings.

@Dlee – yeah, might be a bit of a pain to shut off the outlets from your breaker box :wink: Might be worth a shot though…

Yeah, the circle thing is new… I only have it on one device though, weirdness :\

I’ve been experiencing this since around Thanksgiving with an AEON switch that I bought for my Christmas tree. It keeps going back to the generic switch icon.

me too.

My torchlamp-ON-green changes to wallsocket-OFF-gray. I thought it was a feature, not a bug.

icons are broken for many of my devices… not all, but many

My change icons have been broken for any new device I have added since around 11/30. Everything added before then is fine and a few around that date will update the icon for either ‘on’ or ‘off’, but not both (I get default plug icon) . I have tried periodically to update it in the last week because it is annoying when I have so many devices and have to ‘shake’ to try and figure out which is which. I REALLY just want the label with a background color like you see when shaken… we have already dropped one device due to the shaking thing. My wife won’t even use the app anymore because of it, and just turns things on/off manually.

Also, the app has been getting slower and slower to open. It is taking about 5-10 seconds now. I have about 56/57 devices on it and have many more I want to add. The update from last week at least fixed my scheduled stuff that was failing or happening late.

I just installed my v2 hub, first SmartThings hub. Every one of my devices shows as the default outlet and none of them will change if I edit them.

1 Like