Changed internet service, now nothing works

I just changed my internet service from Ziply DSL to T Mobile 5G wireless internet, but now pretty much nothing works. From the “HUB” page on IDE, nearly all cloud devices show as online, while most local devices show as offline. I have reset my hub several times by unplugging it, but that made no difference. Since the DSL service and modem are still online, I reconnected the hub back to the DSL service and and get the same results in IDE and still, nothing works. I changed WiFi settings throughout my house to connect to the new service, but to my knowledge that shouldn’t affect my SmartThings hub or devices. Did I forget something or did my HUB just decide to go TU at this time?

Which hub do you have?

V2 model STH-ETH-200

Remove the ethernet cable, Power it off and remove the batteries … let it stay off for several minutes. Maybe 10 minutes. Put the batteries back in, plug the power cord in, wait a couple of minutes and plug the ethernet cable in. See what happens.

Question… is it plugged into a switch connected to the modem or directly to the modem? If additional ports available on the modem… you can try plugging in directly to it to see what happens.

1 Like

I’ll try that a little later, gotta run some errands. I am plugged directly into the modem.

That didn’t work, also tried other ethernet ports…nothing. I have equipment plugged in to other ports and that equipment is working. The green light on the hub is on/steady.

Just spend three hours on the phone with tech support. Turns out you can’t change internet providers without having to reset all devices and your hub. Gotta say though, that despite the negative comments I’ve seen about Samsung support, I thought the support people I talked to were quite knowledgeable and helpful. Unfortunately I’m back to rebuilding my entire network :rage: :money_mouth_face:

wait! what?

i just switched last week from Charter Spectrum to AT&T fiber and mine connected fine.

tagging @Brad_ST


We changed Internet providers twice while having a smartthings hub and did not have to reset end devices. :thinking:


is time synced properly on your t-mobile internet modem?

t-mobile - the company who cancelled my service twice within 24 hours a month ago :wink:

Definitely shouldn’t need to reset a hub or devices when switching ISPs. I’d be curious what the hub’s LED was doing when the hub was offline.

1 Like

The hub page is going to show you any devices assigned to your hub. When you say cloud and local do you mean the execution location? The cloud executing devices may be hub connected. All of the local executing ones, bar the odd virtual switch, definitely will be.

So do the ones shown as ‘online’ actually work? Do any ‘offline’ ones work?

Thanks for all the comments. I don’t know why changing providers messed my system up, but it did. Samsung support told me changing providers caused it…just going by what they said, but that was the only thing I changed, I unplugging my ethernet cable from one router and plugged it into another!
orangebucket , I said “Hub page” but that should have been “devices page”…my bad, lol. Yes I was referring to execution location. I reset the hub and now resetting all my devices, so I can’t go back and see on/offline devices. Virtual switches worked to initiate automations, but nothing involving a physical switch would cooperate. example, my “Good morning” routine was initiated by me saying “Alexa, Good Morning”, causing my virtual “good morning” switch to activate and key the automation. So when things went bad, I could see the automation activate, but the lights and heat didn’t come on, although the “mode” HOME changed and my security system went to disarm (controlled by “mode” change). My physical switches all showed offline, they worked manually, but could not control them remotely. I never got around to checking on various sensors. At any rate, although I would love to understand exactly what happened, I am now rebuilding my system of about 120 devices. I wish I had taken some screenshots, but I didn’t, so getting a little foggy on details, but thanks for trying to help.

There were platform issues recently, is it possible you ran into that in the middle of everything else?

JD, quite possible. I forget exactly when I switched over, but think it was the 9th or 10th. The issue you highlighted is very similar to what I had.

1 Like