Centralite Temperature / Humidity - driver problem

Hi all,

Picked up this device off Amazon to use for some temperature monitoring:

When I pair it, it appears to pick up an Edge driver (I presume - it’s “placeholder” in the IDE) called “Centralite Multipurpose Sensor”. Problem is, it’s a buggered driver - the tile shows what I think is the battery %, and when I open the device to see the details, there is just a status that says “connected”, with no menu, not even a back button to let me out - I have to close and re-open the app to do anything else.

Any idea how to set this up with a more appropriate driver?


I’ve seen that once before with the mobile app. I don’t think it’s a driver problem though. I have 2 of those working fine with edge. It could just be a very long delay with ST in configuring. Does it still look that way in the app? If so, if you long press on the device, does “edit” show up? If so, try that and delete the device from the hub and try again.

Also, go to https://my.smartthings.com to check if you see the same

Thanks. I deleted and re-paired, and this time it configured and is fully accessible. It was probably hung up in pairing/configuring.

1 Like

Can someone let me know which driver you are using. I have the same device using @Mariano_Colmenarejo driver, and it is only displaying the temperature. Humidity and Battery are not displaying anything.

I have several of these, and here’s one of them:

Thanks @johnconstantelo . I switched to that driver and it immediately worked.

1 Like

Hi @damohabir

Please, Wath device fingerprints are?
If works with stock driver then could work with mine

I may have spoken too soon. The humidity only updates when first joined. I have removed and added the device 3 times. It updates when added and never updates again. The temperature updates on schedule every time, but humidity never does. In one case I waited over 12 hours.

Key Value
Name temp-humid-battery
Mfg Name SmartThingsCommunity
Mfg Code CentraLite
Model 3310-G
ocf Type x.com.st.d.sensor.multifunction
Category MultiFunctionalSensor
Room Upstairs Hallway
Presentation ID 568db25b-36d8-3366-b5a5-5233642fc58e
Parent ID 2c87b711-2a98-412e-b2d0-317521ba8a94
Parent Name
Driver ID ccea734e-e56e-4d2c-a259-3b2e1fdebd82
Driver Name Zigbee Humidity Sensor
EUI 000D6F0017E69646
Network ID 5172
Provisioning State NONFUNCTIONAL
Local Execution yes

Hi @damohabir

You could change to my driver and capture the logs with CLI to see the configurations response

I think I may have resolved this for now. I initially loaded @Mariano_Colmenarejo driver on my hub. So when I paired the device, it immediately joined using MC’s device driver. Even switching back and forth between MC’s driver and the stock driver did not resolve the issue. Temperature would update correctly, but humidity would only update while pairing and never again.
I finally remover MC’s driver from the hub and re-paired the device, so it picked up the ST driver. And it seems to be updating correctly now.

1 Like

I have the same device and was using the stock driver to put out by SmartThings, and noticed it doesn’t update the humidity readers except when I manually refresh the device in the app. Does anyone know how to rectify this issue? Thanks!

Timely topic for me because I just ordered another one of these, which is arriving on Saturday. I’ll post back any issues.

The issue with reporting humidity could be related to the device not binding properly, so removing and rejoining, or switching drivers may help. I’ll know more after I get my new one joined.

Based on the discussion above I switched to one of Mariano’s drivers and then back to the stock driver and deleted Mariano’s drivers (the old and current one) from my hub. I’m still seeing an issue with the temperature changes routinely being reported, but humidity not.

Hi @maranhao ,

I just installed this sensor and it seems to be working just fine. I have it in a shower and ran it for a bit. Humidity reported as expected:

Deleting the device and reinstalling it solved the issue. Weird.

1 Like