Centralite 3310-G temperature and humidity sensor?

Is anyone using the subject device and have it reporting both temperature AND humidity properly with Edge?

I have two, one I installed a few months back, and one I installed yesterday.

The older one has reports for both temp and humidity, but I have not seen humidity move from 70%, despite moving it out of a freezer in to the house air last night. Looking through its history, I have not seen a change in humidity as far back as I can look.

The newer one has no reports for humidity at all. It’s been installed for 15 hours or so.

I’ve tried both the Smartthings beta Zigbee Humidity Sensor driver and Mariano’s Zigbee Temp Sensor and Child Thermostat Mc driver with the same result.

Trying to figure out if the device just reports humidity this infrequently, in which case it’s not at all useful as a sensor.

Thanks!

I have three of these. They are reporting humidity every few hours. They are working with an edge driver. I have one in a room where laundry gets hung on drying racks. I can see the humidity levels going up and down in accordance with the laundry being hung.

I have several as well, including our showers, and they all are updating. They’re also on Edge drivers.

@eric182 @johnconstantelo

Thanks guys, can you let me know which driver they are using?

And if it’s a ST driver, is it one of the beta ones?

Thanks!

‘Zigbee Humidity Sensor’ : (prod)

Here’s the fingerprint that includes this device:
image

@johnconstantelo

Thanks. I’ll take a look. I have one on that driver (though I think it’s the “beta” - not sure if that may make a difference), and one on a Mariano driver. The one on the Mariano driver has been stuck at 70% for many days. The one on the beta zigbee humidity has not yet reported a humidity value, almost 18 hours later.

Is there a difference with the beta drivers? Should I be seeing non-beta ST drivers on my hub?

Here is mine

Thanks guys.

Interestingly, the one device started reporting and both have updated. Only once, to a coincidental “50%”, but it’s a start.

I’ve put one of the devices near the stream of a humidifer and will see if it updates again.

1 Like

I am also having this issue I have used both the ST driver and the MC driver, and the only difference is where the humity is stuck

My humidity readings looks to have started moving. Quite slow to update, don’t know if this is the device or the driver. I moved everything to the ST beta zigbee driver.