Centralite Pearl Thermostat DTH (March 2019)

Cool, sorry for the delayed reply.

That’s probably because ST hasn’t received a status update for that capability from the device yet. You can remove the thermo cover and put it back on to trigger a battery and power source report. That’s what I’ve done to get that state to update, or you can wait for the device to send ST a value.

I’m definitely not seeing that happen in the mobile app, but what’s really really weird that I’ve never seen before is the IDE having duplicates, and not the mobile app, check this out:

I can tell you for certain that something changed on ST’s end to have the IDE look like that for this device.

@jody.albritton, what would have caused a situation like that to happen? I’ve never seen anything like this before. It’s only happening on my 2 thermostats so far, but I’ll look through my other devices today to see if this behavior is happening elsewhere.

Looks like something may have changed under the hood with the recent update. Had no problems using this DTH with the new app for many months, but when I had to re-link my voice assistant yesterday, things went weird.

Just like you I’m also seeing the duplicates in the app and on the website’s IDE. Also the app keeps wanting to display the current temperature in Celsius even though the thermostat and website report correctly in Fahrenheit (changing it on the app doesn’t seem to save).

I tested using the generic ZigBee thermostat profile and the app duplicates went away (but not the website) but the weird Celsius/Fahrenheit bug still remained.

I’ll keep poking around too and see if I can find out what may be causing this too…


The duplicate issue is also happening on my keypad and a few other device. Very concerning…

Same issues here when using new ST app.

  1. Duplication of settings fields with DTH “My Centralite Thermostat”
  2. Degree C in current Temp field and Degree F in Set Temp Fields with DTH “My Centralite Thermostat”
    The following has not been reported in my reading:
  3. Current Temp field populated with Low Set Point value in both detail screen and tile.
    As other have observed:
  4. While on batteries, reported as “AC Power Supply”.
    Here is a new observation.
  5. When DTH is set to “ZigBee Thermostat” #1, 2 and 3 are correct albit Power Source and battery level are always reported incorrectly.
    However if I switch DTH to “My Centralite Thermostat” and back to “ZigBee Thermostat” #1, 2 and 3 may or may not be in the error state.
    I can’t say when this fell apart given my migration of three locations to the new app and each location having a Centralite Pearl thermostat.
    One of the three locations is otherwise offline unless the DTH has recently been changed and it will go back offline within minutes and then remain in that state.
    Very Frustrating.
    Any help is appreciated.
1 Like

Went back and set he device handler to the published generic Zigbee Thermostat profile and it seems to be behaving better. With the exception of the battery level the other functions on the app are back to normal (no duplicates, correct operating state, F/C units, etc). Google assistant is also able to control the thermostat again.

Interestingly on the website it still shows duplicate fields but that doesn’t appear to be carrying over to the app. I’ll see what is different in that code VS the one listed on this post which worked before the update.

I’m new to SmartThings. Just installed Pearl and paired with SmartThings Hub. Now, I can’t seem to find a way to program the schedule in the SmartThings mobile app. This is the same whether I use the default device handler, or the one posted here by OP.

Perhaps I need to install a third party SmartApp like:

By default there is nothing when I try to add from the mobile app. I had to paste the above source code in the ST cloud. Am I missing anything?

Most device handlers do not have scheduling built in, as you’ve discovered. A SmartApp like @rboy’s is what you need if you do not want to build Automations in the ST mobile app.

1 Like

@Tash, so far my code has been working just fine with the new app and voice assistants like Alexa.

I used this updated code/handler from the built-in handler and now both of my thermostats work great with the new Smartthings/Alexa integration. Thank you very much. I’ve had no issues with C vs F or any of the other issues described in this thread. Thanks Agin!

1 Like

Hi @johnconstantelo & @jwilkinson74,
Can you point me to the file with the latest DTH for Centralite Pearl Thermometer? I clicked on the link further back in this thread, but that one shows last updated on 03-01-2020. Given that this thread is more recent, is there a newer version of the DTH somewhere? For reference, here’s the link I was looking at. If that is, indeed, the latest, let me know!



That’s the one I’m still using.

1 Like

Thank you @johnconstantelo,
I installed your DTH to fix several problems with the stock Centralite Thermostat DTH:

  1. Duplicate Temperature Setting Controls
  2. Duplicate Operating Mode Setting Controls
  3. Duplicate Fan Mode Setting Controls
  4. Operating State always shows “Heating” even when idle

Your DTH fixed the first one, but not the other three. I still had two operating mode and two fan mode controls in the app, and operating state was still showing “Heating” all the time.

I then changed to the generic “Zigbee Thermostat” DTH and everything is fixed and working properly. However, now the thermostat is showing on AC power with 0% battery even though it’s not on AC power and the batteries are new.

Has anyone else experienced this? My thermostats are only controlling a hot water heating system with no cooling and no fan, so I just have two wires connected (Rh and W1).


That’s the one I use and other than a duplicate of some items, this works great for me. The thermostat hasn’t changed and along this still works, it’s my understanding that there no need for a newer version. Have you tried this one yet?

I have 2 of these thermostats, one has duplicates and the other is fine. In the IDE, both show duplicate states. Who knows when that happened, but it was never like that and I’ve had these devices for a couple or 3 years, at a minimum.

I have time this weekend to delete and readd one of them to see if it resolves the duplicates.

@Jim_Ryan, I just deleted and rejoined the one thermo I had that showed duplicate entries in the mobile app and IDE. I made sure it rejoined using ST’s stock handler before using mine, and sure enough, it joined and had duplicates in the IDE. What I did was pure ST out of the box functionality, so there’s something on their end causing this. Submitting a support ticket will help, which I haven’t yet, but with everything else on their platter, this will take a back burner. Plus, I believe someone here already submitted a ticket and was told this was an unsupported device, even through they have a DTH for it, go figure.

I went ahead and started using my DTH anyway because it works better, even though it shows duplicates. There’s nothing I can do about it since that’s the way ST joined the device for some reason.

@Brad_ST, FYI. Looks like you guys made some update last month for your stock DTH : “CHAD-5726 Update Thermostat DTHs to discrete capabilities #49771” If that was intended to fix the duplicate states when joining, it did not work.

Hi @Jim_Ryan, would you be willing to try something for me? I changed my DTH to go back to using a VID ST was using in their Zigbee Thermostat DTH, and that seems to have removed the duplicates in the mobile app for me.

My github repo was just updated with those changes. You will probably need to change your device to some other ST DTH, like their “Centralite Thermostat” handler, wait a minute or two, and then switch back to my updated one for things to change. At least that’s what I had to do.

Hi @johnconstantelo,
I only just now got to test your changes from December. The duplicates are gone and it all appears to be working fine except that it is showing battery of 0%. It is running on 24VAC from the furnace, but it would still be nice to know the backup battery status. Unless, of course, the thermostat itself isn’t reporting that…

Sometimes battery reporting on these are a little flakey, so it won’t update until it sends something. What I’ve done to force a report is pull the cover off and then put it back on.

Oh, good news! This morning the battery had updated. I’ll apply this DTH to the rest of my thermostats.

1 Like

Thank you for the code (link in this thread). Helped me get the Thermostat to pair with ST. Device and features do not appear as you screen shot. Is there newer code/development?