Installed Pearl thermostats. Added to Smartthings no prob but can't set temp


#1

Ok so I got 3 Pearl thermostats. I installed one last weekend and added it to my Smartthings app. I was able to set the temp from the app and have the thermostat act accordingly.

So today I installed the other 2 which went smoothly and were easily discovered and added to Smartthings but if I try to change the temp or a setting of any of the thermostats via the app nothing happens on the thermostats. The app correctly displays the current status and temp of the thermostats. It’s as if the thermostats are in a read only mode or something. If I try changing the temp from the app it visually on the app looks like it worked but nothing happens on the actual themostats. Then a few minutes later the app shows the temp back to where the thermostat is actually set.

Any thoughts on what is going on here?


#2

Is the first one you installed last weekend still working?

It could be a range/interference issue depending upon where you have your hub. Do you have any Zigbee repeater-capable devices, like an Iris/ST smart wall plug? If not, that may help.

Also, in the IDE, what does the hub’s event log show for that device with regards to last activity? Has it been hours, minutes, days? Is it online or offline?


#3

First one is not working anymore. The first one is about 20 ft from the hub and is line of site in the same room. I have no repeaters. All thermostats have status ONLINE and last activity “moments ago”.


#4

Ok that’s odd. I’d perform a reset/rejoin. Since its a zigbee device, just reset the device while being in the Connect New Device screen in the mobile app. You won’t see any acknowledgement in the app, but after a bit just exit out. The hubs event log will show the rejoin messages.


#5

Ok I tried that. It reconnected quickly and I do see the rejoin messages in the event log. When I change a setting on the thermostat itself it immediately reflects that change in the app but my problem still remains. Nothing I try to set from the app has any effect on the thermostat.

The only wild guess I can think of is that I set Unsecure Rejoin to disabled for Zigbee on the hub. I tried reenabling the setting but the setting never takes. I tried via the app and the IDE but Unsecure Rejoin remains disabled and can’t turn it back on. I mean it doesn’t make sense that this setting would give me the problem I have since I’m clearly connected to the stats.


#6

Ok got everything working. It occurred to me that maybe my Pi-hole (blocks ads on the whole network by being the dns server) was preventing the smartthings hub from connecting to certain services??? I don’t know. Anyway. I whitelisted the smartthings hub and rebooted the hub and rejoined all the thermostats. Everything works great now. Whew :slight_smile:
Thanks for your help @johnconstantelo !