Centralite 4256050-ZHAC Module Support


(Adam Whitlock) #1

I’ve been able to pair the CentraLite 4256050-ZHAC module with SmartThings without any problems. It initially appears as a SmartThings SmartPower Outlet when paired and will turn on & off the remote device. The problem I have is that the device state doesn’t appear to be accurate. If I turn a device on or off and restart the application the state displayed is not correct.

I have assigned the module the CentraLite Switch and CentraLite Dimmer device types with moderate success. I tried creating a custom device using the base code for the previous two applications in trying to create a new device for the CentraLite 4256050-ZHAC module. Regardless of make, the devices are all using standard ZigBee HA commands for on/off and polling.

Can someone point me in the right direction? Can this device be fully supported? I see no reason why it can’t. This is the same module as the Comcast Xfinity lighting modules, as far as I understand.


CentraLite Switch aka Smartthings Outlet Power Reporting Broken?
(Jeff DeWolfe) #2

I’m wondering if @Dianoga @Ben or @urman would have any ideas? Does this device just need a firmware update pushed out to it? I know that Support had to do that with the new centralite switches I have to get power monitoring to work properly.


(Andrew Urman) #3

It could be changed to CentraLite Switch. You could also possibly push the configure tile in the app to get it to start reporting state.

We focused development around their new switches like we sell in the shop.


(Adam Whitlock) #4

@urman, I changed the device type to CentraLite switch which hasn’t improved its ability to update the power status. I didn’t try adding the “Configure” tile to the app before, so I created a new device type using the CentraLite Switch code and a “Configure” tile. This didn’t seem to help either.

I noticed that the “Things” section switch and the main device switch within “Things” do not appear to be synchronized either.

Is it possible that the 4256050-ZHAC modules are not able to bind properly? These applications are standard ZigBee HA cluster codes for the appropriate uses, so using the wrong code shouldn’t be the problem. Without any good technical documentation on these devices it’s hard for me to know if binding or different cluster codes are causing the problem or not.

Edited:

Here is the debug log output I received for certain commands:

Configure - No output
Refresh - 0104 0B04 01 01 0140 00 58F0 00 00 0000 01 01 0B0586
On - 0104 0006 01 01 0140 00 58F0 00 00 0000 0B 01 0100
Off - 0104 0006 01 01 0140 00 58F0 00 00 0000 0B 01 0000


(Andrew Urman) #5

I believe those are the older HA 1.1 switches. That means these don’t have reported configured by default.

These are responses from the device.

Configure - No output - Pretty sure we dump this message.
Refresh - 0104 0B04 01 01 0140 00 58F0 00 00 0000 01 01 0B0586 - Energy Metering value
On - 0104 0006 01 01 0140 00 58F0 00 00 0000 0B 01 0100 - On message success
Off - 0104 0006 01 01 0140 00 58F0 00 00 0000 0B 01 0000 - Off message success


(Chris Sanner) #6

So can “reported” be added or is this something that will be permanently missing from these devices?
and has this been solved?
if so, how can I make use of it?
and if not, how can I help?
(yes, newbie over here)


(Craig) #7

How did you pair it? I can’t even exclude it from my previous network using the Z-wave utilities which has worked with all other devices.


(Andrew Urman) #8

this devices is actually a ZigBee device, which should just need to be reset to be removed from the network.


(Craig) #9

Right. So I reset it, but I still can’t add it to Smartthings. What device type did you try and is there some other method to pair it other than clicking the button on the side to turn it on/off?


(Jonathan) #10

To pair it you need to make sure that it reset by holding to power button while plugging it in. Once that light blinks select smart switch from the add menu and let it work I have 4 and on each of them it took a couple of tries but I’m a little eerie when using them cause you never know if they are really off.


(Jaime Carranza) #11

Hey guys… so I just got my STH recently and had not much trouble setting up a zwave switch and kwikset deadbolt, but I can not for the life of me get this zigbee appliance module to work 2456050-ZHAC . I’ve tried holding the button down while plugging it in, which just blinks for < 10 seconds then stops. I’ve tried pressing the button on the side for ~2sec until it starts blinking. Both of these while in the smartsetup android app > Connect new device AND Switches & Dimmers > SmartPower Outlet.

I signed up for the developer options to try and add it manually “https://graph.api.smartthings.com/device/create” but i’m afraid I don’t know the zigbee id from the network id. Any help in pairing these would be greatly appreciated.


(Tony Gutierrez) #12

So I’m in the same boat. All paired, but no power reporting (I do have the latest hub/zigbee firmware). Logs:

Read attr: read attr - raw: D615010B04060B0586, dni: D615, endpoint: 01, cluster: 0B04, size: 06, attrId: 050b, result: unsupported attr

(Tony Gutierrez) #13

To pair the LAMP MODULE…Must be next to hub. Start app searching. Hold down button while plugging in, and release when led blinks once. If it doesn’t pair then, hold down the button for a few more seconds. No idea abut the APPLIANCE module.


(Jason Layton) #14

CentraLite switch has anyone been able to figure out how to update the power status?


(Adam Whitlock) #15

Like @urman stated, they are older ZigBee HA 1.1 switches. If someone could write firmware to update the switches it would take care of the actual device usage problem we are running into.

Does anyone know how to use the metering capability? That was something I was curious about when I still had my hub. I’m currently hub-less until I can get the new version of the hub.


(Russell) #16

I can’t get these to tell me if they are on or off properly either. They will turn and off as needed but the status is never right. Plus they don’t tell you the metering usage either still. Any one had any luck with testing these out?


Zigbee Energy Meter
(Tony Gutierrez) #17

To get the state of these you have to use some pretty ugly code since they are older HA versions.

I was able to achieve it by adding a block like this to the parse function:

} else if (description?.startsWith("catchall: 0104 0006")) {
	log.debug "Switch command catchall"
	name = "switch"
	value = description?.endsWith("0000001001") || description?.endsWith("0B 01 0100") ? "on" : "off"
}

and change your refresh to poll this:

def refresh() {
"st rattr 0x${device.deviceNetworkId} 1 0006 0000"
}

(TJ) #18

This was perfect. my status is now reported correctly. However, the dim functionality doesn’t work at all. I can get it to report " trace setLevel(56)" and the slider and level meter show what i set it do, but the lamp plugged into the device is not dimming at all. I have verified that the lamp is dimmable.

Any thoughts?


(TJ) #19

I have been using this switch successfully with the reporting of state, but am still unable to dim the lights using the custom device type. Does anyone have any suggestions on how to fix this issue?


(Chris) #20

You cannot dim the appliance module. It is designed for appliances, and running an appliance on a dimmer is NOT a good idea! If you want to be albe to dim your lights, get a light control module.


Please wait message