Centralite 4256050-ZHAC Module Support

I was able to get this to work. The trick, for me at least, was to pair it to the Smartthings hub. It showed up as a generic “thing”. It never stated that it a new device was found just after 5mins it displayed. After I signed into the IDE website and changed the device type to “ZigBee Dimmer Power” and it worked and polled fine.

I did try to use the built in Centralite Dimmer and it would fail to poll correctly, would turn on/off fine. The generic seems to work.

And yes, if anyone is wondering this was one that I obtained from my old Xfinity Home that I repurposed. No additional firmware or coding needed.


Wow, having similar issues with appliance outlet model 4257050-rzhac. After hub firmware update or power outage the outlets would report status but not respond to commands. Solved issue with a hub reboot however in the course of troubleshooting issue I removed the first outlet discovered with issue. Could not get re-discovery, bounced hub bounced outlet, configured outlet with web app edits, some progress but no real success.
Reset requires
hold button down while plugging in
Release at first light
Outlet should turn off after release
Turn outlet back on
Hold down button untill blue light flashes
Run “Connect New Device” in App
Voila! discovery
So much trouble for such pecise action with so little accurate documentation


I recently had to replace the v2 hub and now it won’t smdisxover either of the 2 appliance modules I have… I get the device into pairing with the blinking light but Smartthings just will not connect the switch…

There is a way to enter the mac address of the modules. I don’t remember how I got the modules reconnected but I did. Try a hard reset of the modules and hub. It can be done

Has anyone had any luck with these recently. I have 5 of these outlets left over from an Xfinity Home install and have tried everything above but cannot get the hub to find them. I reset them by holding the on/off button while plugging them in and that seems to reset them however no combination of holding down the button seams to work.

I tried hard resetting the hub and that did not appear to help.

(Manual I found): http://dz.prosyst.com/extra/public/4256050_ZHA_Lamp_Module_Install.pdf

Any suggestions?

Hub firmware: 000.015.00008
Outlets: CentraLite 4256050-ZHAC

Thanks Jason_A!! Worked like a charm.

I know this is an old thread, but it’s still useful. I too am converting away from my horrid Xfinity system and repurposing the devices it came with. I was able to get my device working using your method, but have stumbled upon an interesting issue.
When I connect the switchable outlet to a device with a passive power source, the backflow of power is apparently kicking the switch to remain “on.” Since these switches (according to others) use older code relating to HA1.2 you could think maybe this is just a hardware limitation, but this was being used with my Xfinity system the same way, connected to the same device, yet when I turned the attached device off - it stayed off.

I’ve done some troubleshooting and can affirm it only misbehaves when something that has a capacitor/battery is attached… i.e. USB charger and a phone. When the USB charger is plugged into the outlet with a USB cord attached the device works correctly. The moment a phone is plugged into the USB the switch will only briefly turn off and then kick back “on” by itself after 2-5 seconds.
With my application, I am using it to power a doggie cam in a bathroom where I keep my pets when I’m not home. Ideally, I’d like the camera to stay off until I leave home - so by leaving my home the outlet will trigger on, and I have a camera to see my dogs. Since the camera is in a bathroom, having a permanently powered-on camera is not cool. :slight_smile: This camera is a newer camera that’s micro USB powered. It does not have a battery, but it likely has a capacitor on the devices mobo. I’ve tested multiple USB chargers, cables, and devices and the only thing that remains consistent is devices that have a secondary, passive power source.
TIA for any input.

OMGosh what a pita this little thing is… thanks for the procedure, it did work following your instructions.

I have this device too with xfinity. I see a lot of people have left xfinity to move to smart things. does comcast willing give the devices away and not try to take them back when you disconnect from their home stuff?

The only thing Comcast takes back after the disconnect is the touch screen. All the sensors are yours to keep and do what you will with them.

thanks @nucleusjay. im trying to get all the devices to pair before i cancel comcast and i cant get the thermostat to pair. it seems all the programming guides online are not the one for my actual device. 2100 and 2300 make my device blink the network indicator but it doesnt pair with my phone :frowning:

so i was using your code above and then im getting a weird issue in Live logging and it makes me not able to see power status of the device. I added a debug into your code with this

Blockquote :
} else if (description?.startsWith(“catchall: 0104 0006”)) {
log.debug "Switch command catchall"
name = "switch"
value = description?.endsWith(“0000001001”) || description?.endsWith(“0B 01 0100”) ? “on” : “off”

But some weird way on the line name=“switch” ST is throwing this exception
description is: catchall: 0104 0006 01 01 0140 00 19F6 00 00 0000 0B 01 0100
: error groovy.lang.MissingPropertyException: No such property: name for class: script1501943925334445257082 @ line 43

You code sets “on” when it ends in 0B 01 0100 so I’m not understanding why ST is throwing this exception. Any ideas?

@Tony_Gutierrez i noticed name and value were never declared so i did that, but it’s still not working. what does description expect us to return?

Done now. Everything is working

// Parse incoming device messages to generate events
def parse(String description) {
log.debug "description is: " + description

def name
def value
def result

if (description?.startsWith("catchall: 0104 000A")) {
	log.debug "Dropping catchall for SmartPower Outlet"
	return []
} else if (description?.startsWith("catchall: 0104 0006")) {
    log.debug "Switch command catchall"
    name = "switch"
    value = description?.endsWith("0000001001") || description?.endsWith("0B 01 0100") ? "on" : "off"
else {
	name = description?.startsWith("on/off: ") ? "switch" : null
	value = name == "switch" ? (description?.endsWith(" 1") ? "on" : "off") : null

result = createEvent(name: name, value: value)
log.debug "Parse returned ${result?.descriptionText}"
return result


I was looking at an option to make this working and didn’t like the idea of using it as a dimmer. I did my own experiment and was successful.

I did write about how to get it working http://orahyplabs.com/2017/08/centralite-4256050-zhac-outlet-smartthings.html

It polls correctly and even shows the energy usage (just one line of code change)

For anyone reading this who is having trouble pairing this unit…

Please make sure you have removed batteries from any OLD devices from your OLD system (ex Xfinity). These are repeater devices and will connect to known zigbee networks FIRST before pairing mode is an option. If any of the older devices remain, you will see the 4 flashes and never get to pairing mode.

After their removal, hold button while connecting to wall outlet and release on first blink. You will note the blink pattern is now slower.

Btw this works great… I was even looking to disable the dimmer function too :slight_smile:

hi, where can i find the dht for 4256050-rzhac centralite appliance module , i have look all over and i can not find it. thanks

I purchased two of the CentraLite 4256050-ZHAC. One paired easily. The second I can’t get into pairing mode. How can i reset it? I have already opened up the housing. No batteries to remove. Thanks

Press and hold the button on the left side, while plugging it in will reset and put into pairing mode. Watch for the flashing green light and it will show up in Smartthings Classic. I do not use the new app.