Capability for Ring/Bells

So I added this under the Cameras section. Is this the only place I need to add it?

the only thing it show is it is green (assume it mean online) that is it. I did see where it is showing up as a motion sensor seems that is the only feature as of now

hard To Tell From Everything Posted, but I cant Seem To Find A Working “Button” (one, two, three, or Four) to Create An Automation To Turn On Lights When The Bell Is Rung. Are We Still Working On This? Thanks Guys, not A Developer Obviously :slight_smile:

If you are talking about CoRE then you need to update to the latest version and try again :wink:

Nope, just trying to work through the app. Is there a better place to ask?

For Core?

I don’t know core from my elbow unfortunately, hoping someone might have insight into running it straight from the ST app. I’ve managed to get the doorbell added (as a button even), but when I try to make it do something via a routine or smart app, etc., it doesn’t seem to want to work.

We are working on a fix now. In fact, I am verifying it at this very moment.

Also, for the next week, no one ring a doorbell in my vicinity… I might just lose it! haha :fearful:

4 Likes

Thank you! I figured it was still in draft mode. I’ll keep an eye here :slight_smile:

Anyone else seeing this error from the DTH in the logs?

4:32:58 PM: error java.lang.SecurityException: Getting properties on class java.lang.IllegalArgumentException is not allowed @ line 752

Hi John,
I have a bug filed for this. You should be able to re-perform whatever step you were attempting and it will succeed.

-Donald

3 Likes

Now that we have both Ring & Skybell integration, who’s working on the facial recognition for SHM ? :smiley:

3 Likes

For those having issues with the authentication screen: I have been beating my head on this for a few days so that I can get concrete examples to send to Ring. Are there any customized settings for the display, display density, or accessibility that you have adjusted? I have an iPhone 6 and a Samsung Galaxy S6 Edge that I cannot for the life of me reproduce this on.

Someone mentioned different text size at some point…

I’m on a Galaxy S6 Edge device. If you change system font settings from tiny to large you should be able to reproduce the issue.

I see a few possible solutions:

  1. Mobile friendly/responsive auth screen from Ring.
  2. Set web view inside the app to fit all content.
  3. Set web view inside the app to force desktop view with zoom capabilities.

1 would be ideal. That’s what Nest does. 2 and 3 get the job done but will most likely require users to zoom in and out to use the form.

I have an iPhone 5S and iPad 4 and can not see the authentication button on either (not even a sliver as some were able to see). I have tried smaller font size but no luck. I attached screen shots earlier in the post.

Pretty silly to need a workaround for this, but I’m on an HTC one M8 and couldn’t get the authorization to show no matter what I did. So, using an old thread about runnign Smartthigns in Chrome, I was able to barely see the button, and now it is all added.

1 Like

I had this problem. It appears that there is a

at the bottom of the web page that is fixed and the button/link to confirm is hidden behind this
. Setting the text size on my phone (Edge 7) to the smallest setting allow enough of the page content to be display above the
to see a small portion of the confirm and touch it.

I’m sorry I didn’t do a screen grab.

Thanks. I’ll have to try that again. I even went into accessibility and selected jumbo fonts. It looks like while they have a mobile friendly auth site the bottom footer can cover up part of the mid-page content. Out of curiosity, what are the software versions (Android/Samsung specific) that are on your S6 Edge? I have the T-Mobile one and am going to make sure that it has all of the updates.

Thanks everyone!

My phone is an S7 Edge on Verizon. I’m using the latest software and the Chrome browser.