Can't view any devices in the Smart Things app?

I can’t seem to view any devices on the SmartThings app?

Smart Things classic won’t open as it’s migrated. On the new app, I can’t open any of my devices. They all show up, but when I click on them, I get a pop up that says: “We need to download an add-on to help you get the most from your [device name].” I click Download, and then a little popup says: “We’re having trouble connecting. Check your network connection and try again” And this is the situation for all devices on the new app. Mixture of devices mainly from Samsung and Fibaro but they all say this message, and it’s same for my tablet and my phone.

When I go to to Devices, and click on an item, I get a different message: “A new version of the device controller is available. Update it to continue.” I click update, and then under the device I just clicked on, it flashes up “Downloading” for a moment. When I click on it again I get the same message.

The Hub is set to Do Not Allow firmware updates, I changed this to Allow, and then retried all of the above, but nothing different happened. Incidentally, my hub (v3) is on firmware 000.030.00005 which I believe is the latest version.

Can anyone help? Can I manually download what it needs? Is it a permissions issue? I do use a blacklisting package on my network, is there anything I have to whitelist? I have wifi and 4G, and browser and other apps working fine.

Try to whitelist http://usage.trackjs.com/ and http://smartthings.com/

Update: A friend has tried this on his phone for me and can download the add-on fine, and then it all works, so it’s just me by the looks. @saosinx88 Thanks for the reply, I can get onto both those links on my phone with with no problem - usage.trackjs.com shows a welcome message that says if you can see this page it’s working. Smartthings.com goes through to the website fine on my phone too.

The Classic app should continue to work. Can you provide more details… any error messages? Have you tried signing out and signing back in? When signing back in… are you selecting New to SmartThings and using your Samsung account?

As for the new app… what phone do you have and what OS version on it? What is the version of the ST app? Have you tried disabling wireless on your mobile device and using cellular data only and thus bypassing your home network? Although I am not sure this issue is related to anything on your home network.

1 Like

Thanks for the reply - classic app, I’ve tried again and this time it opens fine. When I tried to re-open previously, it was just showing the last migration screen with a link to the new app on play store. Maybe it just got stuck.

I’ve got a Samsung S7 on Android 8.0.0. ST is version 1.7.47-22. I reinstalled yesterday to see if it would make any difference.

I turned off wifi just now, restarted phone with it off, opened ST and tried to view a thing, but still the same thing happens: popup asks me to download, click ok, then another popup saying there’s a network error.

Tagging @SamsungZell

I believe I have seen this issue reported before but I can’t find the threads that mentioned it. I do not remember what the solution was. When you uninstalled the app from your mobile device, did you restart it (or power it down) and then reinstall? I don’t believe clearing app cache would help in this case. For some reason, I believe it was a simple solution but can’t remember what it was. Ugh!

@jkp thanks for tagging me, I believe we used a full cache partition wipe the last time.

@t-rex, I would perform a wiping of the cache partition of your Galaxy S7, this will not erase any personal data or settings.

You can achieve that by using the steps below:

Turn off the device.
Press and hold the Volume Up key, Home key, and Power key at the same time.
When the phone powers on, the Android System Recovery screen appears
Release all of the keys.
Press the Volume down key to highlight “wipe cache partition.”
Press the Power key to select.

I hope this message finds you well!

^SamsungZell

@t-rex do you have a support ticket number to reference?

Same issue on my device. I was seeing it before, on Android 10, but I am also seeing it on Android 11 beta, running on my Pixel 3. New Smartthings app, app devices recieved the same errors as mentioned above.

I’m able to click that link and see the page just fine. I’m running an Eero on standard configuration on the back of AT&T Fiber.

Contact ST support

I’ve tried the “wipe cache partition” a few times and it hasn’t done anything.

@Brad_ST I haven’t got any support ticket number I’m afraid. Where should I raise it? SmartThings support or samsung or…?

An email to support@smartthings.co.uk or you can report an issue from the help menu in the new app.

One point of clarification about the above. There isn’t a setting for turning off hub firmware updates. You might be referring to allowing Zigbee firmware updates. Regardless, it shouldn’t be a factor here.

1 Like

@Brad_ST I definitely have an option to turn firmware updates on or off, as per the screenshot - I presumed this was for the hub?

That’s for allowing ota updates for connected devices. Not the hub itself.

1 Like

I’m also having this problem. I’m unable to use most of my devices, whether they be SmartThings brand or third party. I have a Pixel 3 on Android 11 beta, just like @coopdan.

1 Like

Same exact issue here. I’ve been having it for over a month. Pixel 4 on Android 11 Beta as well.