[UPDATED] Rule Machine with Triggers

It depends on the app, what is it?

You can set up a virtual switch and have the rule in rule machine turn that switch on. Set up the other app to do something based of that virtual switch.

It’s a sensor Initialization app for me Ecobee3 thermostat.

It’s supposed to run every 5 minutes but with the problems with smartthings scheduling it will stop running.

If I manually trgger it then it runs finr for awhile.

I can use the conditikn on a dummy sensor to trigger the delay action but I cant figure out how to trigger the app.

what I do it find something on your network that reports a value at the interval you wish to poll the sensor. Create a rule that does not use time but uses the value from that sensor to trigger a poll action in rule machine.

It’s not a polling issue, I don’t think, as Pollster doesn’t fix it.

Re-launching the app is what I need to do, it has a quick launch button (a king of play arrow thing), which is what I am trying to execute but can’t figure out how to do.

Cheers,

Matthew

I have a rule that was working before and after I made some changes, when I try to open the rule I receive the following message, ‘You are not authorized to perform the requested operations’. Any ideas on how I can remove this rule? It’s on an Android phone.

Very nice, thanks… All better now.

Hello, finally i am able to use Rule Machine… no idea what fixed it :slight_smile: I like it a lot.

However, i am now trying to create a simple command with my lights. Actually, its not that simple, and i dont know what im doing wrong. I actually have 2 different issues so i wanted to ask here:

Goal:
Turn Hue Bulb to specific color and level if motion is detected and illuminance is below “X”.
Turn off after “Y” seconds of non motion. (if in the interim motion is detected again, start counter again)
However, if Hue Bulb is already turned on, do not change the level.

What i did so far:
Create conditions: Illuminance Sensor <= “X”; Motion Sensor = Active; Hue Lamp = Off
Create rule: Illuminance <= “X” & Motion Sensor = Active & Hue Lamp = Off
Create Actions: Turn on
If False: Pending off: Hue Bulb “Y” minutes

Issue 1:
Light goes on, and turns off after 1 minute if no motion is detected. However, if motion is detected again within this 1 minute timeframe, the lamp goes off, and on directly afterwards after 1 minute. This happens continously.

Issue 2:
Light turns on, but it randomly turns off, even if motion is detected. Sometimes it works for several minutes, sometimes it shuts off when im standing in front of the motion sensor. Even when i check if motion is detected, it shows within the Smartthings app, and the light only turns on after some time passed.

I hope was able to explain my issues well, its harder than i thought to put this into words… if anybody has some ideas what i can try out, please let me know

This is messed up. First off, you need a rule not a conditional trigger. Secondly, having a condition that is affected by your actions creates a loop (Kitchen off for false, which then makes the rule true.

Start over, rethink your logic.

Issue 2 is similar. Use a rule not a conditional trigger.

Ok now i am confused… what is a conditional trigger in this case?
I see from screenshots of version 1.7.11 there is a new field conditional triggers. I will update the app first.

A conditional trigger is a trigger with conditions and a rule. It’s conditions/rule are only evaluated when the trigger fires, so won’t work for pending off types of rules.

You probably want a rule instead.

Ok i have updated my rules now, but have the feeling that this is way to complicated…
1.Trigger 1 turns on virtual switch if lamp turns on.
2. Rule 1 turns on lamp if motion and luminance is TRUE. Rule is deactivated when virtual switch is ON.
3. Trigger 2 turns off virtual switch if motion is inactive and activates rule 1 after 1 minute.

This seems to work, however of course the lights will always turn off if i walked by the motion sensor once. But i can live with that for now. More troubling is that the light changes its level if i trigger motion with this 1 minute as the Virtual Switch is already turned off. Lets see if i can find any nicer solution to this.

Your app is really powerful, and there is a very steep learning curve. Still dont understand all the options… but i am so happy that this exists! Without it, Smartthings wouldn’t be as valuable as it is! Thank you!

1 Like

I just encountered a small glitch with a battery notification rule.

I added a presence sensor, but the battery level was showing N/A, this caused the rule to report a low battery condition but it was reporting it for a different device.

As soon as I removed the presence sensor from the condition it was fine.

Cheers,

Matthew

Could you show me a screenshot of your rule for this? Either here or by private message. I’d like to understand what happened.

As you can see it’s just a simple rule, any device at or below 25% battery send me a text.

If I add a device that has a battery level showing N/A the rule becomes true but it sent me a text saying the back door contact was low, even though it was at 77% battery.

Cheers,

Matthew

Thanks, that’s interesting. Not sure what the N/A means, but probably that the value is null. Or, maybe it’s 0. If it’s 0 then you can see why it would make the rule true. The device shown in the text would be the last device that reported to Rule Machine. RM assumes that’s the device that caused it to run. You’re getting the message right when you hit Done, correct? RM evaluates the rule then, so the text isn’t meaningful as to device.

If you could look in the IDE the next time you see a device with N/A, and see what the IDE says it’s battery value is, I’d appreciate it.

Bruce

No problem, I should be able to replicate the issue this afternoon when I have some time at home.

Cheers,

Matthew

If I want to deactivate Rule Machine temporarily, without deleting my rules or deleting Rule Machine, how might I do that? Is there a simple way just to toggle it off?

Thank you.

All I can think of is to create a virtual switch and update each rule and near the bottom add the switch into the “Switch to disable Rule” option… I can’t see any global disable…unless it can be done in the IDE

Create a new mode that won’t be used for anything. Restrict each rule to only run in that mode.

1 Like