Can't re-use name for bulb removed from system - stuck and need help

I recently got Hue bridge and added four Hue lights (A19 white) and am having an odd issue.

One of the lights I replaced was named “Cathy’s Light” and worked perfectly via Google Home. Another I replaced is called “TV Fan Light.”

I removed the two old lights from SmartThings and then added the two new Hue lights to the Hue bridge via the Hue mobile app, named them the same as the bulbs they replaced, Cathy’s light and TV Fan Light in the Hue app, and then added both lights to SmartThings.

I then went into the Google Home app and added the new lights.

But for some reason, Google could only control the TV Fan Light bulb, it would not control the one called “Cathy’s.”

Behavior:

Cathy’s light:
Hey Google, turn on/off Cathy’s light. **
** - Sorry, I don’t know how to do that

TV Fan Light:
Hey Google, turn on/off TV Fan Light.

  • Turning TV fan light on/off

So zero problems controlling the TV fan light bulb, but unable to control the Cathy’s light bulb directly.

Also, interestingly, there were zero problems controlling both lights via the room.
Hey Google, turn on/off Family Room

  • Turning two lights on/off

I tried setting the nick name for the light in GH = Cathy’s light and that didn’t help either.

I removed the bulb from ST and the Hue system, and then added it back again to Hue, ST, and GH, named Cathy’s Light, etc., and the same problem persisted.

I’m not using the name Cathy’s light anywhere else in my system that I can find.

Any suggestions - I’m stumped, and my sig other wants her her old bulb name back! :slight_smile:

Google Home doesn’t like special characters, not even apostrophes. Try just dropping the apostrophe: “Cathys Light” and see if that helps.

2 Likes

Thanks, I’ll give that a try.

I’ve been using “Cathy’s” from the beginning, but maybe the recent changes caused an issue…

Wow…that fixed it. I set the nickname in GH to Cathys light and it works again. So wierd…

Thanks, @JDRoberts to the rescue!!

As long as we’re here, since Hue lights are natively supported by GH, I didn’t add them into GH via the SmartThings scan. I assume that’s the right way to go - all GH to manage them directly.

2 Likes