TCP bulb connectivity issues


(Gus) #1

I have been using these for a while but they are just not reliable. They connect to the hub and are recognized in ST and the TCP app however they need to be rebooted almost every day (switch off then back on). Even after rebooting, they still show a red X in the TCP app and don’t sync with the ST app. They show ON in the ST app but then i can’t adjust % level.

I am having nothing but problems with these bulbs so I would appreciate any help.

I have assigned a static IP address. the Gateway IP address in the system information shows 10.0.1.100/24 does this mean I need to set up port forwarding?


(Blake Westerdahl) #2

I had the same issue and it turned out to be a range issue with the bulbs. I had one bulb 10 feet away which never lost connection and 2 bulbs about 25 feet away in the opposite direction that were losing connection just as you described.

I added a bulb about half between the bridge and two that were losing connection. At first it didn’t help so I deleted all the bulbs and then added them back going from the nearest to the farthest. Now they work perfectly with both the TCP app and SmartThings.

My leanings with the TCP bulbs:

  1. unless you have direct line of sight, the range is only 10-15 feet to the bridge/next bulb.
  2. They don’t seem to have any repair function to their mesh networking. If the path to the bridge doesn’t work, they just don’t work instead of trying to find another route.

(Gus) #3

@trotsky40: thanks for the reply however two of my bulbs are within10 feet and the other two are within 20 feet.

how did you delete the bulbs? from ST or TCP or both and what was the process you used?

Thanks


(Blake Westerdahl) #4

I deleted the TCP Connect app from Smarthings (this removes all the bulbs). Then from the TCP app delete the bulbs. Re-added the bulbs in the TCP app. Then install the TCP Connect app in Smartthings.


(Gus) #5

@trotsky40
Thanks for the steps. I will try that tomorrow. Do you leave the TCP app running in the background or do you close it?


(Greg) #6

I had the same issues and it turned out to be a range issue also. I moved my TCP hub about 2 inches and now it works fine. Also using pollster helps keep ST on/off values correct if you ever use the physical light switch.


(Matt Fink) #7

I’ve been having various issues with the TCP bulbs - I have all new GE link bulbs on order (I bought out my local home depots supply) and will replace with those - they have been great.


(Jody) #8

My issue with the TCP bulbs seems to be directly SmartThings related. In the TCP app, turning lights on/off/setting the dimmer is instantaneous. I don’t have any issue with them becoming unresponsive to the TCP app or hub. I mainly notice the lag when triggering them with motion sensors, and I realize their is a cloud component that adds a slight delay to the process. Another issue is that the tiles do not update properly. If the lights are turned off due to lack of motion I have to go into each light in the things category and turn the lights off and back on, then in the lights group I can use the button that turns all of them on or off in the kitchen for example.


(Gus) #9

I read about the GE Link bulbs on another thread and I have decided to switch over. I now have a TCP hub and 4 bulbs for sale if anyone is interested.