Can't get new Smartthings Outlet to be discovered

I’ve tried the standard way, specifying a Smartthings Outlet rather than the generic search for new devices.

I’ve tried restarting the hub.

I’ve tried having the outlet plugged in literally next to the hub.

I’ve tried following the instructions to hold down the button then letting go when the blue led comes on.

None of these work. Please help! I only have 1 other outlet (part of the starter pack) and bought this one to act as a repeater to extend the range.

Please help!!!

I had the same issue, how I got it to work:

Unplug outlet
Start discovery within SmartThings
Hold little button
Plug it in
Wait until LED is blue
Let go of little button

That is all I did. Moments later, it was discovered. I was within 3 ft of hub when I did this.

Thats exactly what I did when mine did not show up…and it worked… so this should definitely work.

Well, I would suggest creating a ticket with support. It never hurts, you may have just been unlucky to get a defective unit… OR SmartThings could be having issues causing your problem.


Only other thing is I’ve bought an additional multi sensor + 2 motion sensors and none of them connected easily either… but they did all connect eventually. This outlet is being a nightmare. I’ve created a ticket.

Am I right in thinking the button I should be holding down is the one that DOESN’T turn the Outlet on and off? (instructions are very unclear and actually have the device pictured upside down compared to it’s 3 prong uk socket!) IE I’ve been holding the button on the right hand side (if you look at the socket with the 2 pins at the bottom, 1 at the top). Been doing this as obviously the other one is an on/off switch and doesn’t go blue if you hold it down. Cheers

scrap that I’ve just done it with that other button again and it’s worked!!! Thanks for the help - wouldn’t have bothered trying that again if you hadn’t replied :smile:

:slight_smile: Yeah mine had a button right next to the LED I used.

odd - mine has 1 button and 1 led on the left, the same on the right. LEDs do same thing but buttons don’t seem to

I found its the left side button as you look at the socket to connect to a hub.

LHS on the outlet when its plugged in - and you have to press VERY HARD - I used the handle of a screwdriver - once you’ve done this, the blue light will flash three times and it will pair.

Can’t stress highly enough how hard you have to press, I thought I was doing it enough with my finger, but its quite a flush fitting and you’ll need something hard.

Vague instructions don’t really help…