SmartThings Community

Can't Get New Smartthings Hub to add devices with Classic App

I was able to get my new Smartthings Hub setup just fine in the new App and was also to get logged into the Classic App with the Samsung login which migrated all devices I had setup in the new version of the app. I wanted to add some custom scripting through the old app to integrate MyQ from my garage doors through the old app, but it won’t let me add devices without “Setting up my hub” which requires a Code which my understanding, only came with the V2 and older hubs. Is there a way I can add new devices with the new hub on the Classic app without having this code to setup the hub? Like I said before, all items seem to work on the Classic app if they were previously setup on the new app, but I can’t setup new devices with the Classic app. Any help would be appreciated! Thanks!

Once a Hub is added to a Location, the Classic App seldom (if ever?) cares about the Hub anymore and just references the Location Object.

As of New App, a Location can contain more than one Hub but that is rare and still not recommended.

So I would not expect the Classic App to be requesting your Hub as long as it has been added to the Location already and that Location is set as the default (use the SmartThings IDE if necessary to change the “default” setting).

But I also think that the New App add device function should even work for custom devices because that is processed at the back end - not on the App.

What steps are you using in the classic app? Is it logged in?

1 Like

I can login fine in the Classic app. It’s just when I go to “my home” and hit the “add a thing” that it asks about the code for the hub. Everything else that was setup under the newer app seems to work fine.

Sounds like you may have 2 locations and the classic app is defaulting to one without a hub.
This post has some details that may help:

1 Like

Ok. I solved it. It didn’t have two locations but your post got me thinking so I added a new location and added the hub to it and then the Classic app started to work. My original location had somehow let me add my hub but it was never listed as an active device that was registered to any room. Once I got the hub registered to the office and it showed up as an icon, I was in business. Thanks everyone for the help!

1 Like