Can't delete Arlo (Connect) SmartApp?!


#1

I’m having essentially the same issue as in this topic from October 2017. His solution was to wipe everything and start fresh: Unable to delete Arlo (Connect) SmartApp from API. There has to be a better solution.

SmartThings started overwriting my Arlo rules and camera rules, so I decided to delete all my cameras from SmartThings, then remove them from all dashboards, routines, etc. and finally delete the Arlo (Connect) SmartApp and start fresh. Every camera and reference to every camera is gone now, and I’m still getting the following error when I attempt to delete the SmartApp:

“Device still in use. Remove from any SmartApps or Dashboards, then try again.”

I did that. Then I rebooted the hub, my phone, etc. then attempted to delete the smartapp from the web UI. No dice.

Any ideas? I really don’t want to start from scratch. Sadly, there’s still no way to backup and restore your entire config in SmartThings. What?!


(Brian Harding) #2

@lp4
I haven’t done this, but have you deleted the Smartthing Mode in Arlo first?

Brian


#3

I forgot to mention that was one of the first things I tried. Now I’m stuck and can’t add cameras to smartthings.


(Brian Harding) #4

@lp4
I really don’t know where to start. The Smartthings Connect is a Smartthings Smartapp and I don’t believe you can delete it. Either Smartthings or Arlo made some changes, ( I don’t know who), but the effect is that Smartthings is now almost in full control of the cameras instead of Arlo. If you don’t use Arlo Connect, then there is not much reason to add the cameras back to Smartthings. Simply use the Arlo app. More on that later.
But if you want to use the cameras in Smartthings, try to go to the Marketplace in Smartthings and go to the camera section and try to add the cameras back.
If that doesn’t work, use the Arlo Connect to see if that works. Then delete the Smartthings Mode in Arlo but in doing so, you won’t be able to use the cameras to do much as Smartthings and Arlo apps do a handshake.
You could use the new ArloPilot app that sounds pretty good and not use the Smartthings Mode in Arlo.
Maybe someone that doesn’t use the Smartthings Mode could better tell you how they are set up.

Brian


(jkp) #5

where in IDE did you attempt to delete it? what was the error?