Arlo (Connect) - Can't Remove from Smart Apps (Unexpected Error)


#1

The other day I got a prompt in my smart things app to re-enter my password. I did exactly that and then for some reason none of my cameras showed up in the arlo smart app screen. All of the cameras still show in the smartlighting automation and devices but nothing works.

I tried to removed the arlo(connect) smartapp but now all it does is give me unexpected error.

Anyone know what might be going on?


(www.rboyapps.com - Make your home your butler!) #2

Contact ST support, Arlo’s working are hidden from the world


(Mavrrick) #3

Try removing all smartapps from your cameras and then remove the cameras as devices.


(Brian Harding) #4

@okami
You are not giving us enough information for us to try to help you. So, I am going to ask you a few questions to help clarify things.

  1. Do the cameras all work as they should in the Arlo App, (not using Smartthings)?
  2. In Smartthings, do the cameras show up under the “Things” list?
  3. Have you tried deleting the Smartthings app and re-installing it?
  4. Which Smartthings app are you using, Smartthings Connect or Smartthings Classic?
  5. Which Arlo cameras are you using, the ones with a base station or the Q series which work on wifi?

The Arlo Connect app is not meant to be removed. Why would you want to remove it? There are two ways to pair the Arlo cameras with the Smartthings app. One is with the Arlo Connect app which is the easiest way to connect them. The other way is to go to the Marketplace under cameras and select the cameras you wish to pair. When the cameras are paired, there will be a Smartthings Mode in the Arlo app. It is very buggy and you should not use it. There are better ways to activate/deactivate the cameras using Smartthings, but more about that after you have answered the questions.

Brian


(charlesdm) #5

I got a unexpected error doing the same thing, I had to remove my Arlo cameras from being used in smart home monitor anywhere, once removed from there I was able to remove the Arlo connect.


(Brian Harding) #6

I have learned a lot from members of this community so I am hoping to learn something here. I have a few questions:

  1. What did removing the Arlo Connect accomplish for you?
  2. Did you add your cameras back into Smartthings after removing the app?
  3. Are you still using Smartthings to control your cameras?
  4. If so did you go to the Marketplace and add the cameras there?

Brian


(Mavrrick) #7

Can’t speak for the OP but when I added a second Arlo Q several months back it didn’t setup properly from just using the add option for the device. The only way i got it to work right was to completely remove all of the Arlo related stuff and then add it back.

To say it isn’'t ment to be removed is a bit of a mis statement. All Smartapps can be removed if needed. It can and should be as a possible troubleshooting step if it gets to that point. It is just a drastic step.

In my case i did add them back to Smartthings. My issues was not a issue with them being in smartthings, but that at the time i didn’t get the default Smartthings mode and for some reason the camera was acting a bit off.

That said I just added two Arlo Pro 2 cameras and a base station yesterday and they appear to of add with no issue at all. So who knows what the deal is.


#8

Hello All!

*Note these are the original Arlo cameras and Base Station

I had to call in to support and finally got through. They apparently have been slammed recently so the normal samsung CSRs (not well versed in smartthings) are filling in for them. Here is all the info asked for in it helps someone else.

  1. Password change in Arlo caused the un-sync to happen in smartthings. During this time all the camera’s showed up still even in the smart lighting app but nothing was working. I use Arlo as my motion detectors to trigger certain lights so it was easy to see it not working.
  2. After that happened I tried a few things
  • Go into Smartthings and put the password back in. It connected but none of my cameras showed up in the connect screen (though they were still all visible in the things and smartapps). Nothing at this point was working
  • Try to remove the arlo connection in smartthings to try to just re-enter the data. Any attempt trying this gave me the unexpected error.
  • Went to Arlo to remove the smartthings mode and then try to remove arlo connection in smartthings again. Again no luck.
  • Remove the Smartthings app and reinstall. All the same settings were there so results were the same.

Finally I had to keep calling until i found someone that actually knew what smartthings was. He went into my account and removed the connection. After that I added the connection back and just readded all my cameras.

Thanks!


(Brian Harding) #9

I am glad that both of you got your cameras back working again as they should.
I purchased my Smartthings system and Arlo cameras about 3 years ago and everything worked fine. Then, about the beginning of this year, I think, the Smartthings Mode in Arlo became very buggy. There were all sorts of complaints. Out of that frustration, I read from a couple of posters on this site that the best way to setup the cameras was to leave the Arlo cameras in the Armed mode and allow Smartthings to do all of the controlling of the cameras. I did not think that would work since I worried about reduction of battery life. I tried it anyway and sure enough they were right. The routines in Smartthings can be set up to activate/deactivate the cameras and although they are in the Armed mode in Arlo they will not record or detect motion unless the Smartthings routine activates the cameras. Thus there is no loss of battery power when the routines deactivate the cameras. The routines perform the same function as the on/off slider in Arlo for each camera except that Smartthings is able to turn/off as many cameras as necessary for that particular routine. Works great! After using Arlo Connect smart app to connect the cameras, I deleted my Smartthings mode in Arlo. The two systems have become much more reliable.

Hope this helps someone.

Brian