Unable to delete Arlo (Connect) SmartApp from API


(James) #1

Help! I was having some issues with my Arlo integration, so I decided to delete the SmartApp and try again.

First I removed all of my cameras from any rules, then went into the API and deleted the cameras individually from my devices.

I then tried to delete the Arlo (Connect) SmartApp using the API (My Locations > List SmartApps > Edit > Uninstall) but it gave me an error. So I looked in the logs and found this:

: error physicalgraph.exception.ConflictException: Device still in use. Remove from any SmartApps or Dashboards, then try again

The problem is, all of my cameras are deleted, there are no links to any apps/rules…etc and all that is left is the Arlo (Connect) SmartApp. I can’t even re-add the cameras now as it says no cameras found!

Please save me from a full reset as that will be an entire days work!


Can't delete Arlo (Connect) SmartApp?!
#2

Go into the IDE settings click on HUB then list of devices then smart apps and it’s going to be a list of every single smart app that you have on the top right you’ll be able to click the edit button and delete from there. I’m not in front of the IDE so the names might be slightly different.


#3

“There was an error uninstalling your smartapp”

I’m having issues as well and cannot delete the smartapp


#4

Oh, never mind. It deleted once I deleted all of the cameras from the device list


(James) #5

That’s what I already tried and even in the IDE it didn’t want to delete. Ended up wiping my hub and starting from the beginning. Took a whole day to get everything back to how it was.


(evan) #6

This thread is old but if anyone is having this issue, you can overcome this by changing your password in your Arlo account. This forces Smartthings to re-authenticate.