Can't build an automation to change security mode

Hello All,
I’ve been a ST user since the kickstarter and generally seemed to not have any problems getting things to work. This time, however, I’m baffled.
I’m trying to build the automation to arm the STHM when my iPhone is away. When I go into the “THEN” portion of the IF-THEN automation, the “Change Security Mode” is greyed out. I know ST is able to use the phone for presence sensing because I have the reminders set to turn on and off the arming and they do fire when I’m about 1/4 from home. I just can’t get the automation to do it. This is all since the new 2021 app update.

Any ideas? Thanks!!

1 Like

Mine was grayed out but still allowed me to select it. I’m using IOS. Its a bit finicky. I’ve reloaded the app twice since the update and always seems to fix any problems.

The Automations seem to conflate the Security Mode with STHM. I accidentally deleted STHM the other day and my Security Mode conditions got deleted for no reason. So I’d be wondering if STHM is being perceived as not being installed.

The app reload was a good thought! But no joy! I was really hopeful too.
I even tried selecting the STHM while it’s greyed but no luck there either. I CAN select the STHM mode for the IF statement just not the THEN…

To add, yes, I’m on iPhone.

That would be my guess. On the Life tab. see if the STHM is there. If it is then select it and go through the setup process again. If not I think under the Life tab you can hit the + and add it.

Also, Could there be a conflict with another Automation running?

LOL You guys are suggesting great things, but no luck. I did have STHM on Life tab, so I uninstalled and reinstalled. Still can’t add to THEN.

No other automations that involve the status. Only lights and temperature things.

It doesn’t directly fix the problem you stated, but when my iPhone presence is “away” it runs a “Goodbye” scene I created. Among other things, the scene changes my Smarthings Mode to Away-Armed. Then I created another automation that when Mode=Away-Armed then change security mode to “Armed Away” . I also set up the reverse for “I’m Back” presence. (I think the default modes in Smarthings are “Away” and “Home” but I changed them to “Away -Armed” and “Home-Disarmed” but you can just use the default modes)

Now I know I can create a virtual switch then an automation that flips the switch and a trigger in WebCore to change STHM. That’s too ‘long way around’! I would love to get the native method working. Seems odd they would have an issue with this because it seems auto arming STHM would be one of those core functions.

I didn’t use a virtual switch or WebCore at all, just the native MODES and Automations, but yes, it should be easier.

Thanks Mike, I just reread your post and it made sense the second time around… lol
So I just went to build the Goodbye but there again, the only actions are to change location mode and control devices. Nothing for the STHM mode.

It also occurred to me to check my 2 other iPads to see if the problem was only on my phone but they have the same issue.

Something maybe to add to the mix, not sure if it has relevance, I have 2 hubs. One at home and the other at my cabin. They are both in the same app under my account.

That shouldn’t make any difference. I have two locations on one account.

I’m on the Android app, though. Maybe something with the IOS app. Mine is certainly available, as I have a couple automations that change the security mode.

Interesting Brian,
I just realized after seeing yours, the “Run Scenes” is also greyed. Also to add more, I CAN modfiy STHM mode and scenes in the other hub. That hub also has 2 scenes I built, hello and goodbye.

Can you take a screen shot of what’s on the IF side of the automation? The automation builder will grey out scenes and STHM from actions if it thinks items in the IF will conflict.


I’m assuming the “ID” you mean “IF” side you want the screenshot (Typo)?
That doesn’t appear to have any bearing. Normally I’ve been trying to use “Member location AWAY”, but I just tried simple time based setting for STHM. Example, every day at 2:00 THEN… I still can’t “THEN” a scene or STHM.

While I’m on the cabin hub, If I open a new Automation, without any IF I can go right into THEN and see scene and STHM are available. In the home hub, I do same and scene and STHM grey.

Strange. Are you the main owner/member on both locations? Are both located in the same country?

yes for both.

And yes Strange! lol

So that sounds like two different Locations. Does each Location have STHM configured and Scenes set up?